Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


eps files disappearing in InDesign 2021 16.3.2

Explorer ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

I just updated to InDesign 2021 16.3.2 and now when I import an eps file it doesn't show up, or only partially shows when I'm vewing the layout in "high quality display" mode. If I switch to "typcial display" it's visible again. Some eps files come in ok, but if I rotate them, they disappear completely.  I'm on Mojave OS, on an older model iMac. Is this a known bug?

TOPICS
Bug

Views

211

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Aug 12, 2021 Aug 12, 2021
The eps format has not been updated since the 1990s. There can be no expectation therefore that versions of InDesign that use code 30 years more advanced will be able to comfortably accommodate such an old format. Eps had its heyday back before InDesign came around and most people were using QuarkXpress for page layout. Since Quark was not an Adobe product it lacked the necessary coding to be able to integrate Illustrator's native format so an Encapsulated Postscript—which is a self-contained fi...

Likes

Translate

Translate
Explorer , Aug 13, 2021 Aug 13, 2021
Hi John,I tried unchecking the GPU acceleration box in InDesign preferences and it worked! The image became visable.I'm not sure exactly what this means. Does my old iMac just not have enough precessor power? Is there any downside to keeping the GPU acceleration off while I'm working?

Likes

Translate

Translate
Adobe Community Professional ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

It sounds like a general screen-redraw problem. Have you tried toggling GPU acceleration?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

Ok, that's above my pay grade. I have no idea what "toggling GPU acceleration" means, or how to do it. Could you give me basic instructions?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

GPU performance is an InDesign preference (Mac Only and only for some graphics cards).

My advice which can take or leave is never use EPS, or any other archaic file format if you don't have to and if you do, be prepared for what you're seeing. Export the document to PDF and see if everything is okay there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

Hi John,

I tried unchecking the GPU acceleration box in InDesign preferences and it worked! The image became visable.

I'm not sure exactly what this means. Does my old iMac just not have enough precessor power? Is there any downside to keeping the GPU acceleration off while I'm working?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

Despite having a brand new, top of the line iMac I was also having issues with the GPU preview. Text was disappearing. It was so bad I was ready to return to my old Mac, but unchecking GPU preview in the preferences panel seems to have helped.

 

Not sure how your OS version may enter into this, but I wouldn't get rid of your old computer yet, and kind of wish I had waited for Adobe to work out the bugs in CC for the Mac M1 chip before replacing mine.

 

Good luck!

Laura 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

Why do you use eps in the first place? Don't use it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

I use eps files for vector art files, (in this case, a logo created in illustrator. ) A lot of times it's what the client gives me to work with. They are infintely scaleable without quality loss and have a transparent background (unlike a jpeg). I tried resaving the eps as a native .ai file and placing it into InDesign and got the same result. I've been using eps files for many years and never had a problem.  This is the first I've heard eps format was archaic or bad. Can you explain why? I'm a home-based freelancer, so I don't have much interaction with other designers. Maybe I'm just way out of touch. Thanks for your responses.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

The eps format has not been updated since the 1990s. There can be no expectation therefore that versions of InDesign that use code 30 years more advanced will be able to comfortably accommodate such an old format. Eps had its heyday back before InDesign came around and most people were using QuarkXpress for page layout. Since Quark was not an Adobe product it lacked the necessary coding to be able to integrate Illustrator's native format so an Encapsulated Postscript—which is a self-contained file—was the only way to import Illustrator vector files. Once InDesign hit the scene it was possible for full integration of Illustrator's native format (.ai) including all of its transparency features into a page layout program. Presently one only need see that the rapid and continuous evolution of the Macintosh and Windows platforms has increased the necessity for Creative Cloud programs to keep up just to be able to operate correctly. Thus it only makes sense to use file formats that are able to evolve to meet these demands.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

Great explaination, Bill--thanks! And yup, that's exactly what I remember as an olden days Quark user before InDesign. Couldn't bring in native .ai files, had to save as eps files. That's been my habit ever since then. (Hey, I held on to my fax machine and land line way too long as well so this isn't really surprising.) I'll just use the native ai files from now on. However, I just tried to import the native .ai file instead of the eps in question, and it still did the same thing. The ai file doesn't show up either. I had to create a png and then it worked. I'd way rather use the vector file, since this application is for print. Maybe I just need to spring for a new iMac. Mine is 10 years old, so it can go in the pile with the fax machine. Maybe they will become friends.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

EPS does not support transparency nor color management.

If you use AI files directly it must be a version after 2002 and it must include PDF combatibility.

You can use PDF/X-4 also, not X-3 or X-1a or any PDF which was created with Distiller should be avoided.

Avoid Postscript: No EPS, no T1 fonts, no distiller PDFs.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

Don't use PNG files, they are rasterized files without color management only in RGB.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

This is a great explanation, I have seen tons of posts regarding eps files not importing into InDesign on this forum.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

Great explanation @Bill Silbert.

 

I'd also add that PostScript Font support is/has going away, so it makes sense to me that PostScript in general is going away, so just another reason to move beyond EPS files.


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

Hi Dan,

don't think so. Not with this particular EPS that was saved with Adobe Illustrator. In a more general view, yes, I would agree to avoid EPS as best as one can, but the file format is not the source of the issue in this case. There are no issues at all with the EPS on my Windows machine. Further: The OP had the same issues with a PDF from the same source AI file.

 

He turned off GPU support for InDesign and all was good.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

I will never stop to say this: .eps and is an evil for InDesign, use it .ai 

Remember, never say you can't do something in InDesign, it's always just a question of finding the right workaround to get the job done. © David Blatner

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

It really did not make any difference in this very case.

There's a bug with InDesign's GPU support.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

Premier Pro CC said:

"The ai file doesn't show up either."

 

Hi,

that is a strong indication that the placed EPS was not the real issue.

So in your case using AI ( with PDF preview ) was not the solution.

You needed a rendered version of the graphic to display it on the page.

 

Could you share the EPS file with us so we can have a look?

Put it on Dropbox or a similar and post the download link.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

Have you tried creating a new InDesign file and placing the .ai file into it, to rule out any possible file corruption?

If you are still having issues, try saving the Illustrator file to a PDF, using the Illustrator default settings, and placing that.

Does using overprint preview make any difference? (View> Overprint Preview)

You could revert back to an earlier version of InDesign, in the (unlikely) possibility that your graphics card is not compatible with the latest version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

Luke, yes, I did try creating a new doc. No difference. However, the graphic DOES show up in overprint preview. It also shows up if I switch my display settings from "high quality" to "typical" although it looks crappy. I'm not very tech-saavy--what does this mean?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

Dropbox won't let me download your files without a business account.??

If the file looks correct using overprint preview, that suggests there may be some overprinting white elements in the .eps. 

Can you confirm the issue occurs when the file is saved as .ai?

Does saving as .pdf make any difference?

Does rotating the file always cause it to disappear?

There is a small possibility that resetting your InDesign preferences may help, or reverting to a previous version of InDesign.

You could also keep overprint preview on all the time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

Hi Luke,

the EPS file exported from Adobe Illustrator is attached with this post by the OP:

https://community.adobe.com/t5/indesign/eps-files-disappearing-in-indesign-2021-16-3-2/m-p/12315696#...

 

The PDF saved with Adobe Illustrator in this post:

https://community.adobe.com/t5/indesign/eps-files-disappearing-in-indesign-2021-16-3-2/m-p/12315746#...

 

As already stated: I have no issues with both files on Windows 10.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

Hi Uwe,

I've attached both the eps file and the native ai file in question. Neither of these files show in the layout upafter updating to the latest version of InDesign. If I create a pdf, the graphic is there and looks fine.  I created this graphic 2 years ago in illustrator and have used it many times, mostly for print applications. The fonts are converted to outlines. Everything worked great until this latest InDesign software upgrade. All my other CC programs are up to date, but I am running an older mac OS—Mojave, and as I mentioned, my iMac is 10 years old.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

this is the .ai file

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

Dammit, I'm attaching it but it's not posting. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2