Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Exporting to PDF makes line weights appear thicker | CAD Plan/Pdf/Indesign/Pdf

New Here ,
Sep 28, 2019 Sep 28, 2019

Copy link to clipboard

Copied

Hi,

 

I'm an architectural student, currently working on my portfolio. In this portfolio, there are many drawings with specific line weights.

 

When I export to PDF directly from AutoCAD and view the drawings in Adobe Acrobat, the line weights are properly displayed.

 

HOWEVER, Here's my problem;
If I place the  AutoCAD-PDFs in an InDesign document and export them again with absolute maximum PDF quality, the line weights are then displayed incorrectly in Acrobat (they all get a lot thicker and a bit messy). The line weight information is not lost though, which can be seen by printing the PDF on paper or zooming in while in Acrobat. This means that the PDF files made by Indesign have a different script for how they are to be viewed on-screen.

 

Now I know that some of you might say that I need to use the setting "Fix Hairlines" in Adobe Acrobat. Even though that works, I don't want to rely on the assumption that people viewing my work know that they can adjust their own Acrobat settings.

 

I also don't want to rasterize my drawings as high-resolution images, I would like them to be real vector lines.

 

My point;

I want the PDF-file created with InDesign to take care of the view settings itself, as the AutoCAD-PDFs do.

 

Does anyone know how? Thanks.

 

Originally posted by Wrecka-D 2018.

TOPICS
Performance, Scripting, Sync and storage

Views

6.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 29, 2019 Sep 29, 2019

Copy link to clipboard

Copied

I know you don't like that answer, but the one you provided is the best one.

 

I wouldn't necessarily call it a bug, but artificial thickening of very thin vectors is a known limitation of Adobe Acrobat. Tragically, it has been since 3.0 was introduced in the late '90s. And the fix is just what you described, use the Fix Hairlines command to make that right on display. Not to speak for Adobe, or Acrobat developers, but my assumption is the rough look onscreen by default makes it easier for Acrobat to provide a screen view of good fidelity, if not absolute accuracy.

 

I know this doesn't help, but I hope it at least provides an explanation for what you're experiencing.

 

Randy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 29, 2019 Sep 29, 2019

Copy link to clipboard

Copied

Now I know that some of you might say that I need to use the setting "Fix Hairlines" in Adobe Acrobat.

 

The Print Production tab’s Fix hairlines would change the output weight of the lines, so I don't think you should do that.

 

It sounds like you are responding to the way Acrobat anti-aliases the screen preview at different magnifications, which has nothing to do with output weight of the line. There is a Page Display preference in Acrobat that handles line anti-aliasing. Look at the Enhance thin lines preference, which changes the aliasing of thin lines when there isn’t enough screen resolution to accurately display the weight at the chosen zoom magnification. You’ll still have the problem of not being able to control your client‘s preferences.

 

InDesign on the left, Acrobat on the right, both at 100% view:

 

Screen Shot 7.png

 

Unchecking Enhance thin lines changes the display, not the output.

 

Screen Shot 8.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2021 Sep 10, 2021

Copy link to clipboard

Copied

Thank you so much!! I've been having this problem for ages!! At least I cna show that it isn't nothing wrong in the design...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 11, 2021 Sep 11, 2021

Copy link to clipboard

Copied

LATEST

You can sometimes avoid the line thickening display preference in Acrobat by converting your lines to shapes in Acrobat. Here is a link to a related discusion with instructions:

https://community.adobe.com/t5/illustrator-discussions/poor-display-quality-when-exporting-from-illu...

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 29, 2019 Sep 29, 2019

Copy link to clipboard

Copied

I also don't want to rasterize my drawings as high-resolution images, I would like them to be real vector lines.

 

Also, if the portfolio is going to be exclusively viewed on screen (in a browser?) and not printed, rasterizing might actually be a better option. Both Acrobat and browsers anti-alias images differently than vectors. I’ve worked a few architecture sites, and fine line drawings rasterized as pngs will usually look better than vectors in a browser. Here's Chrome with PDF vectors on top and a 525 x 300 px png on the bottom:

 

Screen Shot 10.png

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines