Getting "Type 1 Font" blue Warning in InDesign v17 and file has no Type 1 Font in it

Community Beginner ,
Oct 29, 2021 Oct 29, 2021

Copy link to clipboard

Copied

I had fixed my documents when I was running InDesign 2021 but InDesign 2022 is complaining all  over again with that blue banner that runs off my screen so I can't dismiss it. When I pull up the Change Font dialog, it shows no Type 1 fonts but I see in the Fonts XML file within the document that there is an inactive Times T1 listed. No way I can get rid of it.

 

But I did find a relatively painless way to dismiss the blue banner: Window > Application Frame. Select it and the banner disappears. Select it again and you're back to the screen layout you started with but without the banner. I wrote a very simple Keyboard Maestro macro to do that for me and I plan to live happily ever after with it.

 

 

{Moved & Renamed by MOD as this issue is different then the one discussed on the earlier post}

TOPICS
Bug

Views

392

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

I'm not in front of a computer right now, so can't test this, but I'm wondering if maybe you have the Times set as your Story Editor default display font?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

No, it is Georgia but I also tried Minion Pro. The Find Font dialog correctly reports zero Type1 fonts in the document (there are only two TrueType Times variants in there) without referring to the Story Editor location. Good guess, though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

Yah, I've since tested that theory and, nope! 🙂

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

This is driving me crazy. I started getting the warning on my old system and within a few weeks I completely purged my font manager, converted a few dozen legacy fonts to OTF, and reinstalled only current font types. Message never went away.

 

I am now on a wholly new, fresh-build system that has never had a T1 font loaded... and still get the message. As above, searches turn up nothing or an embedded font not in use.

 

I wish Big A could be a little more... flexible with this warning and changeover.

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (v2 now on Amazon!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

There is one other situation where this might happen, and that's if you have no document open, and Times had been set as the font in Type:Character panel, then closed, so it became the default font. (are you bringing old preferences forward with the new versions?)  It's not in any Styles and is not in use in any text block yet, so it does not list in the Find/Change panel, nor does it squawk about it missing if it's not installed. Mayyyybeeee?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

My default font was TrueType Times, so that wasn't it either. I exported the file and hunted through the IDML file looking for a clue but the font name specifies Times and the only Times I have installed now is TrueType.

 

It's as if someone confused TrueType with Type1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

This banner simply will not go away. The even larger mystery on my end is that I have a document using Myriad Pro activated from Adobe Fonts that seems to be claiming that it is a "OpenType Type 1" font, even though I have read here in the community elsewhere that any fonts from Adobe Fonts should not be subject to this problem. The same window also says "Type 1 fonts: 0" which would make me think I should be in the clear. Does anyone have any ideas on this? I want to ensure older documents can still be read if there is a problem. 

Screen Shot 2021-11-03 at 7.54.48 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

I get rid of it by selecting Window > Application Frame twice (once removes it and the second restores your previous setting). On my 13-inch screen, I can't see the button on the far right to dismiss the blue banner, so this is the only way I can get rid of it. I write a short Keyboard Maestro macro to do it for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Maybe this is the solution to your problem.

 

• Export the Indesign-document to IDML

• Drop the IDML on a program called ‘eCancrusher’. It unzips the IDML and it’s free

• Find the document ‘Fonts.xml’ in the folder of the unzipped IDML

• Open ‘Fonts.xml’ in a program called ‘BBEdit’ (also free)

• Search for: FontType="Type1”

• Delete the part of the Type1 font, including <FontFamily>, </FontFamily> and everything in between. 

• Save the file

• Drop the folder with the unzipped IDML on ‘eCancrusher’ again

• Open the IDML-file in Indesign

 

It worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Thanks, Johannes! Yes, that worked. It revealed two Type1 fonts listed in Fonts.xml that were not part of the document itself in any way. Deleting them from Fonts.xml and then reopening the IDML file did not display the warning banner.

 

Rather than using eCancrusher, I just used BBEdit, dropping the IDML file on it and editing Fonts. xml in BBedit.

 

Thanks, again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

I'm glad I could help. BBEdit gave me an error when saving, so I tried another program for that. I'm not a pro, i just try things. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

Replying here to confirm this also resolved the issue for my files as well. Thank you so much Johannes for your response. 🙂 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

An odd but effective way to get rid of the blue banner is to resize the window.

Just click this twice and it goes away.Untitled-2.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Hi All,

 

We are sorry for the trouble. We have tried to address this issue (Type 1 Font warning when there is no Type 1 font in the Document) in v17.1 released globally recently. Please update InDesign!

If you don't see the v17.1 Indesign update in the creative cloud, please try the steps suggested in this help article (https://helpx.adobe.com/in/creative-cloud/kb/creative-cloud-application-recognizing-available.html).

Let us know if this fixes the issue for you or not.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

LATEST

I tested this on a file that opened without a warning in InDesign 2021 but opened with a warning in InDesign 2022. The new version opens it without a warning. Hurray.

 

But I also exported the file as an IDML and examined the Fonts.xml resource where I saw that references to many fonts not used in the document, including Type 1 fonts. It appears InDesign v17.1 isn't cleaning up that problem.

 

Another problem that wasn't addressed is the extremely long blue banner warning about Type 1 fonts. The problem is that the button (I assume, since I've never seen it) at the far right end of the banner that dismisses the banner isn't on a 13-inch screen of certain older non-Retina models (at least). That's 1280 pixels wide. (My fix above of selecting Window > Application Frame twice does still work.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines