Glyphs misplaced by Export to PDF

Engaged ,
Apr 09, 2022 Apr 09, 2022

Copy link to clipboard

Copied

Dear all,

I have noticed an unexpected behaviour when exporting to PDF in InDesign 17.x, reproducible also in 16.x (not tested other previous version). 

I assembled this document using a single parent page filled with a single graphical frame, then used either the Place command of the InsertMultipagePDF scripts available in the Scripts panel, to insert the needed PDFs. 

In the last page of music, second-to-last system, there is a metric modulation in the form of half-note equal quarter-note. In the PDF exported from Sibelius it shows fine, in InDesign after import it shows fine, in the exported PDF it shows as this, with the equal sign overlapping the quarter note glyph as a result of being offset to the right: 

Screenshot 2022-04-09 at 10.02.31.png

I tried different PDF presets, from 1.3 to 1.7, with no appreciable differences. 

My current workaround is to assemble this document in Acrobat DC using the Combine Files tool. The reason why I was not doing this in the first place was to take advantage of the Links feature that automatically updates the document if I make a change to the source files. 

I am attaching both the INDD and the PDFs for your testing (personal use only, please). 

Can anyone see what is going wrong?

Thank you

TOPICS
Bug , Import and export , Print

Views

226

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Apr 10, 2022 Apr 10, 2022

I can replicate the issue

Using High Quality setting from InDesign preset PDF exports

 

However, in the settings - turn off Optimise for Fast Web View

Like my settings here

EugeneTyson_0-1649581684105.png

 

 

This produces the PDF looking correct to me - but might throw up different problems

 

 

I am getting an error - which is probably why the fonts are jumping around the page(s)

EugeneTyson_1-1649581736100.png

 

 

--------------------------------------------------

I strongly suggest that you outline the fonts in Acrobat before placing into InDesign.

 

I'

...

Likes

Translate

Translate
Community Expert ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

Sounds like an issue with Sibelus to be honest.

 

Something in their PDF creation that is not compatible with how InDesign handles things.

 

Perhaps you can pre-treat the PDF exported from Sibelus in Acrobat first.

Can you try Optimising the PDF in Acrobat - then try the InDesign workflow?

 

https://helpx.adobe.com/acrobat/using/optimizing-pdfs-acrobat-pro.html

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

The result is different, but still wrong. 

Attached are the optimised PDF (simple Save as Other > Optimised PDF > OK), and the exported PDF from InDesign.

I wonder why the onscreen rendition within InDesign is correct, while the export is not. 

Could it be a problem with InDesing, instead? Asking because, since I can contact Sibelius devs about this, I would like to avoid a table-tennis responsibility game, with me ft. the ball! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

As I've placed 1000s of PDFs in InDesign and never seen this - I can only assume that the problem lies with the PDF created by Sibelus.

 

As the result is different it would suggest that there's something wrong with the PDF created by Sibelus. 

 

Another option - and something I avoid like the plague but it's ok in some circumstances - and it might ----- just might ----- offer some vain of proof. 

 

If you open the PDF from Sibelus using Illustrator (and I strongly do not suggest this as a workflow).

Open it in Illustrator - does it look ok? 

If it looks ok - save it as .ai file with a PDF compatible file (option during save of .ai - the compatible PDF portion is what is displayed in InDesign - the .ai is the output from InDesign)

 

And does the problem still occur?

 

If the problem has gone away - you can only assume the Sibelus PDF has some underlying issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

Sadly ... the Illustrator workaround has been my go to for the last few months if I also wanted to export to EPUB in the end. I opened the PDF in AI, saved as .ai, then exported as SVG with embedded fonts, and used those for InDesign. Yes ... sigh ...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

I can replicate the issue

Using High Quality setting from InDesign preset PDF exports

 

However, in the settings - turn off Optimise for Fast Web View

Like my settings here

EugeneTyson_0-1649581684105.png

 

 

This produces the PDF looking correct to me - but might throw up different problems

 

 

I am getting an error - which is probably why the fonts are jumping around the page(s)

EugeneTyson_1-1649581736100.png

 

 

--------------------------------------------------

I strongly suggest that you outline the fonts in Acrobat before placing into InDesign.

 

I'd export from Sidelus 

Then open the resulting PDF in Acrobat and check for any issues.

If it looks good

 

Find the Preflight tools in Acrobat

EugeneTyson_2-1649582054279.png

 

Find the Convert Fonts to Outlines

EugeneTyson_3-1649582081897.png

 

 

And run it

Save the PDF

and place that in InDesign

 

Export your PDF

As the Opus Score Notation font is outlined it should prevent the jumping.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

I can confirm that, also when usign the Press Quality preset, AND unchecking the Optimise for Fast Web View, the problem goes away. 

Music fonts in Sibelius are both a marvel of engineering and a curse, as they are made of several fonts together, probably because many years ago one could only have 256 characters in a font? So, the Opus music font is made up of about a dozen fonts named Opus bla bla bla, one of which is Opus Metronome Std. 

I will take care of reporting the issue with that font to the devs. 

Could you tell me how to reproduce the error stating that such font has a bad width? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

I just scrolled through to the end of the PDF and the warning popped up.

You can use my screenshots if it helps you.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

LATEST

Reproduced! Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines