H1 tags not working after exporting can anyone relate?

New Here ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Hi, Can anyone relate? I'm trying to create an accessible document but when exporting to PDF, all my header tags are being read as H2's is this a bug? I've also set my images as artifacts, but theyre still coming out as unammed. Any help would be much appreciated

 

Cheers

 

Jase

TOPICS
Import and export , Publish online

Views

58

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

There are a number of things to consider including a corrupted document, but the first place to look is in the export settings for each of your headings.

 

In the Paragraph Style menu, at the bottom, is Export Tagging. Most of this has to do with the more complex EPUB export, but at the bottom is a field, PDF. Leaving this on Automatic for all styles is usually enough, but you may have to go into each heading style and set the level, h1 through h6, here for an accurate export.

 

Pretty rare thing to have to do. I'd bet that either you (inadvertently?) set your headings to h2 in this field, or that the document is corrupted. Not sure if anything else would change PDF headings from their defaults.

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (v2 now on Amazon!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Hi mate, firstly thanks for your reply. I've set all the headers correctly they've all been tagged. I Even created a fresh document with brand new styles and still only getting heading level 2's - The images I can get round because I can just alt tag them, but this is frustrating. I've even tried retagging and structuring after exporiting in acrobat but it's not having it!

 

So is H1 working for you then after exporting?

 

Cheers,

 

Jase

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

There is a weird intermittent bug in InDesign for the past couple of editions.

If you set the Tag in the Paragraph Style (example, H1), it doesn't stick and comes out as <H2> in the PDF.

 

The solution:

Always check your tags before making the PDF.

  • From the Options menu on the Paragraph Styles panel, select Edit All Export Tags.
  • In the resulting dialogue box, choose PDF at the top (not EPUB) and set the tags there. This dialobue will also change the tags inside the Paragraph Style as well.

 

FYI, I don't think this statement above is accurate: "Leaving this on Automatic for all styles is usually enough."

You always must set the tags for Headings 1-6.

 

"Automatic" always creates one of two options that the software decides: 1) a <P> tag, or 2) a complex nested tag structure, such as for lists <L>, with nested <LI> tags and then nested <Lbl> and <LBody> subtags.

 

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents | Books & Classes | InDesign | PDFs | Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Hi mate thanks for the reply, I've already set the tags within the 'edit all tags' menu. When I turn on accessibility on my Mac there's still no sign of any H1's when exported. funny thing is It actually shows h1 when I view the structure by 'structure types' in the reading order.  Are you able to get it working even with your fix + what version of indesign are you using?

 

Also I thought so about setting the tags as automatic you're right, I tried it anyway just to see and no difference.

 

I'll log a ticket with Indesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

LATEST

@Bevi Chagnon - PubCom just read that you said you have to set your tags h1-h6. Is that the case even though I wont be using any of the headings past h3? You saying I have to make sure all of those headings have been tagged for it to work?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines