Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


How do I change the language in InDesign so that I can do a spell check (in this case from english to french)

New Here ,
Mar 02, 2016 Mar 02, 2016

Copy link to clipboard

Copied

Anyone know how I can change the language setting in InDesign? I'm doing up a document in French and need to do a spell check but the dictionary is in English.

Thanks

TOPICS
How to

Views

36.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 26, 2017 May 26, 2017
No, not so.Work with Paragraph Styles. Change the language of the Paragraph Styles in Extended Character Attributes.

Likes

Translate

Translate
Adobe Community Professional ,
Mar 02, 2016 Mar 02, 2016

Copy link to clipboard

Copied

Language is a character attribute in InDesign. It's not a global setting.

It can be set in paragraph and character styles (Advanced Character Formats), or locally in the Control panel in Character mode with the Type tool is selected. (This is because you may have multiple language text within a document.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

Hi lucd6634402

I just found the solution to help you (next time), you can easily convert multiple textframes between two languages using the "Find/Change" feature.

  1. Edit > Find/Change
  2. Click the magnify icon next to "Find Format" and then "Change Format":
    1. Define the Find attributes, choose ‘Advanced Character Formats’. Change the language to “English: UK”.
    2. Define the Change attributes, choose ‘Advanced Character Formats’. Change the language to “French”
  3. Check the format settings are correct, e.g. "+ language: English: UK" and "+ language: French".
  4. Press "Change All"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

No, not so.

Work with Paragraph Styles. Change the language of the Paragraph Styles in Extended Character Attributes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

LATEST

I spent A WEEK with my indesign stuck on polish, everything would spell check in polish, didn't matter the document or size, it was stuck in polish. My PARAGRAPH STYES were polish!! No one else had this solution, thank you so much random guy from adobe support!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

Increase this productivity

Find/Change in Grep

Find

.

Change to

$0

In the Change Format section - select your language

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2019 Apr 12, 2019

Copy link to clipboard

Copied

Great solution, thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 15, 2019 Nov 15, 2019

Copy link to clipboard

Copied

Thanks, this worked for me!

Kind of ridiculous that it takes so many steps for such a simple change. I don't even know how some of my text boxes got changed to Hindi. Makes no sense... then the dictionary doesn't work right... then I have to do this ridiculous workaround. DOH! Thank you though, solved my problem 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Wow, thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

My hair grows grey thinking that people set-up documents like on a typewriter. One of the worst sins is not setting the correct language. You can even include non-standard dictionaries, as InDesign uses Hunspell, which is great because even exotic language dictionaries are available.

As stated before, the language of InDesign text is an attribute that is attached to the character. You should set the language as a paragraph style parameter at the very beginning of your work. The language style setting does not only influence the dictionary, but also the hyphenation rules, quotes etc.

If you have, inside a paragraph, a few words of some different language, you should use a character style to mark up those words.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 13, 2017 Dec 13, 2017

Copy link to clipboard

Copied

What if I need accents on my text for words in the Hawaiian Language? Hawaiian is not an option in advanced character format. I do not need it to translate, I just want to properly write the words with their typographical mark. For example aina needs to be 'āina.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 13, 2017 Dec 13, 2017

Copy link to clipboard

Copied

if Hawaiian is not an option, you cannot spellcheck, but you still can write the language. And there is an option to install a hunspell dictionnary, if you have one. I think, Mozilla has pretty a lot of dictionaries. I’ve read once an article installing a Luxembourgish hunspell-dictionary to Indesign. If that could help you, I will try to find it back.

You only need the correct character set for this and most probably a keyboard to help you inputing those characters. I’ve typeset Chinese, Vietnamese, Japanese, Turkish and Russian by simply doing copy/paste of the translations of my text I got from the translators in Word. Languages that cannot be checked may be marked with “none”. Works ok for me.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 13, 2017 Dec 13, 2017

Copy link to clipboard

Copied

taywray88  wrote

... I do not need it to translate,

Good! Because that"s not what this discussion is about, and it's not what applying the correct language to your text does. It's only for correct hyphenation and for spell checking. You can type any character you want, regardless of the applied language.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 14, 2017 Dec 14, 2017

Copy link to clipboard

Copied

If styles were not used, change the language on the Basic Paragraph style in the Paragraph Style panel. (Do this anyway even if styles were used.)

If Styles were used, I would not use Find & Change. Hopefully based-on styles were used. Look at the styles panels and track down the "parent" styles. Change them and any based-on styles will change too. (If based-on setting is set to No Paragraph Style, you will have to change the language on a style-by-style basis.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines