Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


How do I set text frame vertical justification defaults?

Explorer ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Along with another problem recently solved, I'm having an issue creating a new text frame that I never had before. Any new frame that I create always seems to have vertical justification set to center. While it's easy enough to fix on a frame-by-frame basis I'd like to reset to default to Top, which it has been for a long time.
Please and thanks.


Id CS6 on Windows 10. Yes, I know, it's old, but it still works great. Just like me.

TOPICS
How to

Views

106

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Mar 21, 2021 Mar 21, 2021
With no documents open choose Object>Text Frame Options..., set Align to Top, (along with any other frame settings you want as defaults), and restart InDesign.

Likes

Translate

Translate
Explorer , Mar 25, 2021 Mar 25, 2021
Problem solved. I did the Object>Text Frame Options thing with no open documents but it was already set to top, and I confirmed this by creating a new document and indeed it was set to top. Going back in to my work document, new text boxes remained set to center, however. The solution turned out to be simple. Without any text boxen selected go through the same process and lo-and-behold, it was set to center. I set it to top, created a new text box and bingo. Fixed. Thanks to all for pointing me ...

Likes

Translate

Translate
Adobe Community Professional ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

I believe that you can do this by setting up the attributes of the "Basic Text Frame" in the Object Styles panel:

 

Screen Shot 2021-03-19 at 6.35.49 PM.png

 

Double-click on it to see the attributes. Click attributes which are to be ignored by clicking on the Attributes in the list on the left from a "checkbox" to a "—" which means ignore.

 

Check the Text Frame General Options, and set the attributes you'd like to see in your default text frame.

 

Screen Shot 2021-03-19 at 6.36.18 PM.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

Unfortunately this is not the answer, although I had hoped it was. It was set to "Align: Top" but all new boxes are set to center. And any changes here will affect hundreds (well over 500) existing text boxes too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

BONUS INFORMATION:

 

Looking further, David Blatner suggested an alternative method described in this article:

 

https://creativepro.com/beware-basic-styles/

 

There are a couple limitations he describes in this article (for example, copying your frame to a different document). At the end of this article, he tells you how to create your own object style and define IT as the default Text Frame format.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 21, 2021 Mar 21, 2021

Copy link to clipboard

Copied

With no documents open choose Object>Text Frame Options..., set Align to Top, (along with any other frame settings you want as defaults), and restart InDesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

LATEST

Problem solved. I did the Object>Text Frame Options thing with no open documents but it was already set to top, and I confirmed this by creating a new document and indeed it was set to top. Going back in to my work document, new text boxes remained set to center, however. The solution turned out to be simple. Without any text boxen selected go through the same process and lo-and-behold, it was set to center. I set it to top, created a new text box and bingo. Fixed. Thanks to all for pointing me in the right direction. In the past, I'd tried this process with a box selected, and that was the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines