How do I turn off snapping to some sort of invisible grid in InDesign?

Community Beginner ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

In the last few upgrades of Indesign something has stumped me. When I move or scale objects there is snapping to some sort of invisible grid. This happens when I move or scale something with my mouse but not when I move something with the the up and down arrow keys (I set the keyboard increments to a very small setting and that works). I've tried troubleshooting this problem by playing with the settings for guides and grids under the "view" menu, changing preferences for units and increments and guides and pasteboards, anything I can think of. Nothing turns this snapping off and it is impossible to do percision alignment when scaling because I can't scale with the up and down arrow keys, only the mouse and other input devices. I have been using InDesign for a long while so I am a relatively advaced user but I haven't been able to figure this one out.

TOPICS
How to

Views

70.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Aug 27, 2012 Aug 27, 2012
Sorry, I totally missed that part of your answer.Yes, if you have selected pixel as your unit of measurement, objects will snap to the pixel grid. It is entirely possible to have objects be placed outside of this grid, but when moving them around they will snap to the grid. How did you go about changing the units of measurement for the document? If you aren't you should try (with rulers on) right clicking on the box in the top left hand corner where the rulers meet and selecting a different unit...

Likes

Translate

Translate
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Have you tried turning off "Snap to Document Grid" already?

Also, what unit of measurement do you work in?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Thanks. "Snap to document grid" has been off so that's doesn't seem to be it. I'm now working in pixels but there is no change in the snapping when I change the units.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Is it possibly snapping to another object?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

I'm at work and checking these suggestions as they come in on what I'm currently working on. I should say rechecking because I think I've tried everything but taking a second look makes me notice more specifics. Objects snap wherever they are on the document and at even increments. It doesn't depend on proximity to other objects or guides. It's like they're snapping to an invisible grid that's everywhere but, as I said previously, "snap to document grid" is definitely turned off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Does it also happen in a new file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Bingo, you're on to something. Just created a new and copied over some of the objects that were in the old file and it doesn't seem to be doing it. What does that mean? Something gone corrupt? It seems to happen in every file I open except this new one I just created.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Is it possible that you had pixels as your unit of measurement in the old document?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

OK, that'a a bit perplexing, but not impossible. Please recheck the old file to be sure snap to grid is not checked.

Is this a file from a previous version of ID, or converted from som other layout program?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Alex, as I mentioned earlier I did have pixels as the units of measurement in my old document. Does choosing pixels create an automatic "snap-to" situation in the document?

Peter, snap to the grid was still turned off. In past situation for previous version of InDesign when some things in a document got corrupt, I was able to resolve the problem by pasting the stuff into a new document. I forget what the particular problems were but creating a new document and pasting stuff in it from the old document fixed it. Don't know if this is the case here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Sorry, I totally missed that part of your answer.

Yes, if you have selected pixel as your unit of measurement, objects will snap to the pixel grid. It is entirely possible to have objects be placed outside of this grid, but when moving them around they will snap to the grid.

How did you go about changing the units of measurement for the document? If you aren't you should try (with rulers on) right clicking on the box in the top left hand corner where the rulers meet and selecting a different unit of measurement. I usually work in picas.

Screen Shot 2012-08-27 at 3.20.52 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Alec, sorry I don't think you missed anything, I was mistaken: I don't think I did mention pixels earlier. I know a few ways to change the units of measurement. I most often use the right click method. It's the fastest.

I did a test and it is indeed the pixel unit issue. As you describe, objects snaps to the invisible "pixel grid" when pixels are chosen. This begs the question: When one is using pixels, is there a way to turn that grid off? Seems to me, if the dimensions of objects can measure in fractions of a pixel, how can I align two objects edge-to-edge when I'm snapping to whole pixels? Do I have to keep switch back and forth between different units of measurement? This is the problem I'm running into.  By the way, I'm not creating web graphics but generating a layout in JPG format for a weekly HTLM email blast. Thanks so much for your help. Paul

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

Well I'm glad you resolved that. I'm not sure about that question though. Is there a reason that you need to have items not snap to the pixel grid? I feel like the grid is there for a good reason.

Does anyone else know of a workaround other than switching to other units?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 28, 2012 Aug 28, 2012

Copy link to clipboard

Copied

I agree. If working in pixels there is an implication that all objects should have whole-pixel dimensions only and should sanp to the pixel grid since you cannot dispaly half a pixel or two pieces of different pixels in the same location on a screen.

That said, switching to points will get you exactly the same size realtionships in ID without the snapping.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 01, 2012 Sep 01, 2012

Copy link to clipboard

Copied

Thanks, everyone, this ws a very interesting thread.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2013 Feb 21, 2013

Copy link to clipboard

Copied

…Here I am, several months later experiencing the same problem. Based off this thread I can now change the unit of increment that an object snaps to. But I don't want my objects to snap to any increment. Is there any way to turn this feature off so my objects snap only to guides and/or the document grid?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Feb 21, 2013 Feb 21, 2013

Copy link to clipboard

Copied

Bud, the only unit that will cause elements to snap in increments is pixels. If you use picas or points you don't have to worry about this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2013 Feb 21, 2013

Copy link to clipboard

Copied

This is true in most of my documents, but there are a few floating around this office that snap to each corresponding unit, points, inches, or pixels. It's very strange. I'd love to find a way to turn this off without having to make a new document and pasting all the content in to it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 21, 2013 Feb 21, 2013

Copy link to clipboard

Copied

Did you check to be sure snap to document grid is turned off?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 22, 2013 Feb 22, 2013

Copy link to clipboard

Copied

yes

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2013 Feb 22, 2013

Copy link to clipboard

Copied

See Remove minor corruption by exporting. Maybe that will help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2013 Jun 30, 2013

Copy link to clipboard

Copied

Hi there, not sure if this is an issue but if you go into Layout - Layout Adjustment, and click Enable Layout Adjustment, and change the Snap zone to 0mm, it might fix your problemScreen shot 2013-07-01 at 11.50.51 AM.pngScreen shot 2013-07-01 at 11.51.00 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2013 Sep 10, 2013

Copy link to clipboard

Copied

I have encountered this problem today. I turned off "Smart Guides" and now nothing is snapping and letting my place it anywhere I like. Hope my method helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2014 Jan 13, 2014

Copy link to clipboard

Copied

Hello! I was having a similar problem. I tried everything suggested above but it didn't work. Finally I just typed in the location of where I wanted the image to be placed:

Dimensions.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 13, 2014 Jan 13, 2014

Copy link to clipboard

Copied

As noted above, if you really are working for screen, the implication is you need to snap to even pixels. If you are not, switch to a different unit of measure for the rulers and the snapping will go away.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2