• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

How do I wrap the bottom objects text around the red lines?

Engaged ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

2022-11-13_14-14.png

For some reason the text wrapping doesn't work.

The text of the bottom object should wrap around the edges of the top object.

TOPICS
How to

Views

744

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Community Expert , Nov 13, 2022 Nov 13, 2022

Thank you for the file.

 

But you are wrong. Please select only the text frame and open the text frame options. Ingnore Text Wrap is checked on! Uncheck it and that's all.

 

pixxxelschubser_0-1668374380605.png

 

pixxxelschubser_1-1668374484237.png

 

Likes

Translate

Translate
Community Expert , Nov 14, 2022 Nov 14, 2022

Hey Chris:

 

I'm on a short class break and while this is not the answer, it may point us in the right direction...

 

With the three other frames in place, my results are inconsistent. Some times it works, sometimes the text turns white so I can't see it until I remove the black frame. When I removed the other three frames, you can see that the back one sill has Ignore Text Wrap enabled in the file you delivered. Disabling it and adding text wrap to the top frame works exactly as expected. It's

...

Likes

Translate

Translate
Community Expert , Nov 14, 2022 Nov 14, 2022

Hello
thank you very much for your sample file.

I can tell you what you have done. In return, can you please tell me why you did it?
😉

 

The text frame again has the option: ignore text wrap switched on. Why?

text_wrap_error_00.png

 

If the option is switched off, the text "disappears" completely.

text_wrap_error_01.png

 

This is because of the lowest text frame that goes across the whole page. This text frame has an active text wrap.

text_wrap_error_02.png

 

Switched off - and everything works as desired.

text_wrap_error_03.png

 

Oops.
Careful with irony: I love precision, but this

...

Likes

Translate

Translate
Engaged ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Wrap around bounding box doesn't work either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Unfortunately, you have neither the Control Bar displayed nor the Layers Panel (unfolded).
So I wonder: Did you use a special contour style? Or are these images. In the latter case, of course, the text wrap does not work (on text in an image).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Hi Chris:

 

They both look like images to me. Text wrap pushes editable text out of the way. It has no impact on images of text. 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

One thing which could prevent the text wrap would be if the text frame behind had Ignore Text Wrap turned OFF. To see, select the frame behind and choose Object > Text Frame Options. See if there is a checkbox at the bottom of the dialog checked "Ignore Text Wrap"

 

Screen Shot 2022-11-13 at 6.10.08 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

The object you have selected look like a placed image. If the text is a part of the image, it will not be affected by text wrap. The text needs to be editable live type in InDesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

To clarify:

there are 4 objects, a text object placed on an svg shape, each 2.

The text objects are not (yet) grouped to the svg shapes.

Ignore text wrap is activated for both text boxes, but changing ignore text wrap settings will not change anything.

Here is a new screenshot:

2022-11-13_19-45.png

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Chris: 

 

But isn't grouping the answer? Just group the top objects, then enable text wrap.

 

If that doesn't work, can you share this page of the file?

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Hi @Barb Binder 

this is the file.

I tried grouping, but still didn't work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Thank you for the file.

 

But you are wrong. Please select only the text frame and open the text frame options. Ingnore Text Wrap is checked on! Uncheck it and that's all.

 

pixxxelschubser_0-1668374380605.png

 

pixxxelschubser_1-1668374484237.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

That's right.

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

The top vector shape's color need to be slightly changed though for this to work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

And those are AI shapes not vectors, sorry I remembered wrong.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

2022-11-14_00-07.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

Now it doesn't work again,  the new file.

Text wrap is not ignored on the bottom text frame, yet the text wrap of the top frame won't work.

I tried to apply the text wrap to both the text frame and the ai object, grouped and ungrouped, and it doesn't work.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

Sorry, I am not at home and can't check your file now.

 

But please, check your preferences. There is a position for Text Wrap: only on text behind (or similar). Try to uncheck this position.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

It's unchecked.

And previously it worked, so that's why that cannot be the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

Hey Chris:

 

I'm on a short class break and while this is not the answer, it may point us in the right direction...

 

With the three other frames in place, my results are inconsistent. Some times it works, sometimes the text turns white so I can't see it until I remove the black frame. When I removed the other three frames, you can see that the back one sill has Ignore Text Wrap enabled in the file you delivered. Disabling it and adding text wrap to the top frame works exactly as expected. It's something with the two background frames, but I don't see it and I'm out of time. 

 

~Barb

 

Removing the other three frames first:

 

2022-11-14_11-41-49 (1).gif

 

Leaving the other three frames (you didn't package the file so I can't examine the two background graphics.):

2022-11-14_11-49-22 (1).gif

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

Here is the packaged file.

It seems then that the issue is with my .ai background shapes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

Hello
thank you very much for your sample file.

I can tell you what you have done. In return, can you please tell me why you did it?
😉

 

The text frame again has the option: ignore text wrap switched on. Why?

text_wrap_error_00.png

 

If the option is switched off, the text "disappears" completely.

text_wrap_error_01.png

 

This is because of the lowest text frame that goes across the whole page. This text frame has an active text wrap.

text_wrap_error_02.png

 

Switched off - and everything works as desired.

text_wrap_error_03.png

 

Oops.
Careful with irony: I love precision, but this is the very highest precision I have ever seen in an InDesign document - 0.001mm - wow.

text_wrap_error_04.png

 

Text wrap set to plausible values gives the desired result:

text_wrap_error_05.png

If that works for you
have fun

😉

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

Ah thanks.

That shouldn't be a text frame even, that is a background color frame, so i will have to make it a non-text object.

However that will still not switch off the 0 text wrap.

I will find out why I used 0.001 offset and tell it but I am sure I had a reason.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

And the reason I was forced to leave the ignore offset on is that the text disappeared, as you found out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

The answer from @Barb Binder is also correct. Removing the background frame produces the desired result, as does removing the text break.

 

InDesign has some features you should know about:
When two frames are selected and a text wrap is assigned, each of the two frames gets its own text wrap. Therefore, click on your background frame and deselect the text wrap by selecting the left of the top icons (no text wrap) in the text wrap panel.

 

Also: If you click on a graphic frame or an undefined frame with the text tool, it automatically becomes a text frame. You can also undo this. Either via the menu: Object --> Content --> Graphic (or unassigned) or by right-clicking on the frame. For the same option is also available in the context menu.

 

Since your background frame is now no longer a text frame, you should consider how to protect it from such unwanted changes. Try locking it. This can help. But only if the option: "Prevent selection of locked objects" is set in the preferences. So this variant is only conditionally suitable.

 

Or: You could create a new layer below it and move the background frame there. Then lock the layer in the layers panel. That would work.

 

Or: But in my opinion, the better way is this: Create a new master page (called "parent Page" in new versions) and put your background frame there. Then assign this new master page (parent page) to your document page. Working with layers can also be helpful on master pages. As long as you are on a document page, your background frame is now protected from accidental editing.

 

End of this short lesson.

I hope this helps a little.

😉

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

LATEST

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

Hi ~Barb,
Lol. You were much faster.

😄

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines