How to dock the floating tools palette in InDesign CS6 for Mac? Normal way doesn't work

Contributor ,
Feb 01, 2013 Feb 01, 2013

Copy link to clipboard

Copied

In all my CS applications except InDesign CS6 (Mac), I can dock the tools window by the side of the main content panes like any other window: drag it to the edge, and at just the right point, it highlights where it will be docked with a blue outline, and docks when you let go.

I can't find any way to do this in InDesign CS6 (Version 8.0, Mac), however. Unlike every other window, it never gives the option to dock, no matter where I drag it. The only options in the toolbar itself switch between one row vertical, two rows vertical, and one row horizontal. I've also looked in Preferences > Interface and the only options refer to the "Floating tools bar" and give the same one row vertical, two rows vertical, and one row horizontal options as the tool bar itself.

I can't see any option to stop it floating. I've tried on a variety of Window > Arrange settings, and with Window > Application Frame both ticked and unticked, and nothing works. I can make it snap to position in a corner, but it doesn't dock and doesn't stop floating.

It's not just the inconsistency and nuisance of it sitting on top of the documents and not moving with the rest of the window that causes a problem: I'm on a Mac (Lion) and the floating toolbar breaks a normal useful operating system function. In every application except InDesign, when I press F3, the current window shrinks down and I see every other open window, organised by application, with each application's icon floating on top. In InDesign CS6, it's the floating tool bar, not the main window, that shrinks. The main InDesign window stays where it is, awkwardly sat between the icons and my other windows, in the way of the other windows - effectively making it impossible to use F3 to switch to a different other window without switching out of InDesign first.

Here's a screenshot I found online (looks like Windows version of CS6?) where the tools bar is docked: no close icon, slots in neatly alongside the content panes, not treated as a seperate window by the OS.

http://photos.pcpro.co.uk/images/front_picture_library_PC_Pro/dir_354/it_photo_177415_52.jpg

I'm having trouble finding Mac screenshots where it's docked - in most, it's floating awkwardly above the left ruler.

Views

52.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Apr 09, 2013 Apr 09, 2013

Its a strange bug, but I have found a work around.
If you dock another palette (is info, layers etc...) to the left, you can then dock the tool bar to the left of that pallete. You can then detach the pallete and the tool bar will stay docked.

Likes

Translate

Translate
Adobe Community Professional ,
Feb 01, 2013 Feb 01, 2013

Copy link to clipboard

Copied

Turn on the application frame. For some reason, it's off by default.

Bob

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 01, 2013 Feb 01, 2013

Copy link to clipboard

Copied

Afraid I already tried that, and mentioned so in the question:

I've tried on a variety of Window > Arrange settings, and with Window > Application Frame both ticked and unticked, and nothing works. I can make it snap to position in a corner, but it doesn't dock and doesn't stop floating.

I've also tried a variety of timings incase there's anything funny there: like removing and re-adding the tools panel with and without application frame turned on, switching, etc. It just doesn't want to dock for some reason. Also same result maximised as not maximised.

Is it definitely possible to dock the tools palette on InDesign 8.0 on a Mac (Lion)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2013 Feb 01, 2013

Copy link to clipboard

Copied

Sorry about that. I'm not having any issues with that here but you might want to try turning it to two columns and then drag it.

That might kick start it a bit. Perhaps a new workspace would help, also.

If all esle fails, trash your prefs.

Bob

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 01, 2013 Feb 01, 2013

Copy link to clipboard

Copied

Interesting: I tried switching to a workspace where it's docked by default (Book), and it was properly docked (so it's definitely possible on my version/OS). I dragged it out so it started floating, and then couldn't put it back. (while docked, it does fix the F3 bug as expected)

Also, one funny thing that is happening is, about a quarter of the time I drag it into a place where I'd expect it to dock, the cursor turns into the Mac crashing beachball until I move it away again.

I guess this probably a sign something's corrupted. Will try deleting the preferences file when I've got some free time to set things back up again.

Another sign that something is probably corrupted: Ticking and unticking "Enable floating document window docking" makes no difference to anything. Ticked or unticked, I can still dock and undock all windows except the Tools palette.

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2013 Feb 01, 2013

Copy link to clipboard

Copied

I had this identical problem. The latest update fixes it.

Audrey

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 07, 2013 Feb 07, 2013

Copy link to clipboard

Copied

Great, I updated and it now works fine.

Side note - I thought I was on the latest version as Updates... was greyed out and About InDesign said 8.0 - turns out if it doesn't say 8.0.1 or higher, it means 8.0.0. I double clicked on the greyed-out Updates... link and somehow, that made it no longer greyed out. Odd.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 12, 2013 Feb 12, 2013

Copy link to clipboard

Copied

Dammit - this issue has come back. I accidentally knocked the tools bar out of place, and now it won't go back into place. Exactly the same as before, including the spinning beachball.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 12, 2013 Feb 12, 2013

Copy link to clipboard

Copied

try resetting the wokspace.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 14, 2013 Feb 14, 2013

Copy link to clipboard

Copied

Seems like this bug happens when InDesign has been open for a while - I find if the first thing I do after opening InDesign is to try to dock the tools palette, it usually works.

So:

1: Check for updates.

2: If the problem still arises, and if there's definitely no available update, close InDesign and re-open it, then try to dock the tools palette before doing anything else.

(p.s. I like the sound of Wokspace - sounds like a bright open-plan Chinese restaurant )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 09, 2013 Apr 09, 2013

Copy link to clipboard

Copied

Its a strange bug, but I have found a work around.
If you dock another palette (is info, layers etc...) to the left, you can then dock the tool bar to the left of that pallete. You can then detach the pallete and the tool bar will stay docked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 15, 2013 Apr 15, 2013

Copy link to clipboard

Copied

crayz77's tip seems to work. For me, it doesn't give the normal blue preview while hovering that it is going to dock, I had to just hold it right on the left of the screen to the left of the freshly docked random window and let go, and it docked anyway.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 04, 2014 Feb 04, 2014

Copy link to clipboard

Copied

Bob's suggestion above worked for me - thank you.

I went to the Window menu and, all the way at the bottom, I clicked Application Frame. Everything docks now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2015 Nov 05, 2015

Copy link to clipboard

Copied

This drove me nuts.  What fixed it for me was setting Window -> Workspace Layout -> Expanded.

When this was set to "Compact" the files window always floats for overlapping.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2016 Jan 11, 2016

Copy link to clipboard

Copied

You can also drag floating menus all the way to the right side of the application window and a blue line appears on the right indicating it will now be docked. Just release and voila.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2016 Jul 19, 2016

Copy link to clipboard

Copied

Solution - I went Windows>Workspace>Reset

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

Bobs suggestion above worked, but only after i resized my workspace window to be smaller than the application window. AWESOME! I have been trying to fix this for ages!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

None of these solutions work for me. The palettes just float and do not stay with the document. Could you offer any updated advice? Is there something I can click so that they stop floating and just stay with the document? It's been frustrating for me for months and numerous looks on Adobe Support Community. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

You can drag a floating panel into either side and dock into position. When you hover the sides, you will see a blue high light, release panel and it will position into the dock. You can also create and save your own customized workspace, using reset to restore the workspace.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Thanks, Jeffrey. Unfortunately, it doesn't seem to work. I drag the panels next to the document and indeed each seems to magnetically move adjacent but no blue highlight and the panels do not move with the document window afterwards.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Maybe it would help you to see a screen shot:

wmrowen_0-1657316226221.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Then I drag the document over to the right and up a bit. The palettes stay where they were—not moving with the document:

wmrowen_0-1657316321837.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 09, 2022 Jul 09, 2022

Copy link to clipboard

Copied

Enable the application frame.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 09, 2022 Jul 09, 2022

Copy link to clipboard

Copied

LATEST

Thanks, but that doesn't help. Then I get a mostly black screen stuck on my laptop screen that cannot be dragged anywhere. I can drag the document's window from the laptop to my second monitor, but the palettes do not attach to that window. If only there were a button one could press to restore order (and I would never touch it again).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines