• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

How to get rid of all of the options listed in the EDIT WITH option in InDesign

New Here ,
Sep 28, 2023 Sep 28, 2023

Copy link to clipboard

Copied

I just want to see Photoshop appear when I use the dropdown menu EDIT WITH option while working in InDesign. Instead, I'm giving 40 options, most of which are apps that don't exist on my computer. Weird. 

 

Thank you. 

TOPICS
How to , Performance

Views

161

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 28, 2023 Sep 28, 2023

Copy link to clipboard

Copied

That is an operating system function. Set Photoshop as the default and use Edit Original to avoid that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 28, 2023 Sep 28, 2023

Copy link to clipboard

Copied

@BobLevine If the apps not on the computer are also showing on the menu then doesn't it potentially point to some sort of cache on the InDesign end? Trashing of caches and preferences could be tried

https://www.rockymountaintraining.com/adobe-indesign-rebuilding-preferences-cache/

-Manan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 29, 2023 Sep 29, 2023

Copy link to clipboard

Copied

Doubtful, but always worth a try.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 29, 2023 Sep 29, 2023

Copy link to clipboard

Copied

Clearing the cache will not help. It's a MacOS setting and unfortunately you can't change this opening with/edit with!

 

For the Finder, there are some tips to edit these lists, but they no longer work since Monterey (at least) it certainly no longer works under Ventura and newer ones - since any system optimisation tools no longer allow such changes...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 29, 2023 Sep 29, 2023

Copy link to clipboard

Copied

LATEST

If you see apps in this dropdown menu that no longer exist (are you sure? Have they been uninstalled correctly? Or are they still in the Launchpad and Programs folder?), then it may help to make a safe-boot or a terminal hack to renew the Launch Services. Then they would have to disappear from the list...

 

Safe-boot: https://www.macworld.com/article/671817/how-to-start-a-mac-in-safe-mode.html

And the terminal hack:

https://www.lifewire.com/remove-duplicate-applications-from-finder-open-with-menu-2260889

After this restart the finder (right-click the Finder icon in your dock > Click Relaunch)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines