Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Hyperlinks in a typeset URL that breaks at the end of a line

New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied


Hi, folks! This is a bit complicated. I hope I can explain it properly.

 

I have a document in which URLs must sometimes break at the end of a line because they are too long. The problem I describe happens no matter how the break is created (either automatically by InDesign or if I insert hard line breaks). No hyphenation is inserted at these breaks.

The hyperlinks of the "line-broken" URLs do not export properly in a PDF (for print), even if I have manually created each one in the text (Type > Hyperlinks & Cross References > New Hyperlink). So, for example, if I have to break "en.wikipedia.org/wiki/Adobe_InDesign" after the ".org/", the hyperlink goes to the Wikipedia homepage, not the Adobe InDesign entry. I have tried inserting a hard line break (return key) and aassigning each segment a complete-URL hyperlink, but that doesn't solve the problem. I have even tried copying and pasting the "broken" segments of an URL from a plain-text document onto separate lines of text and assigning each one its own complete-URL hyperlink. InDesign still "links them together" with an incomplete URL.

 

They do, however, export correctly if I export as an interactive PDF. But the interactive PDF results in a spread rather than single pages, and it remains a spread even when I specify "single page" view in Adobe Acrobat (or Preview). The document must be single pages.

 

(Tinyurls are not a suitable workaround. And this happens whether or not the typeset text begins with "http".)

 

Can you suggest either how to get the broken-line hyperlinks to behave correctly in a "print" PDF or how to export an interactive PDF in which each "single page" is a spread?

TOPICS
How to, Import and export

Views

50

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 19, 2021 Aug 19, 2021
Just uncheck spreads by selecting pages in the interactive PDF export.

Likes

Translate

Translate
Adobe Community Professional ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Just uncheck spreads by selecting pages in the interactive PDF export.

2021-08-19_11-07-45.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Thank you, Bob, but I don't know where to find what you show me. I had thought there would be such settings somewhere, but I don't have them in the Adobe PDF Presets menu, which is offering only some print-oriented PDFs and the Blurb PDF export, and I don't see them anywhere else (e.g.,  Preferences menu). (I'm on 16.3.2.) 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Oh! D'oh. I have found it. It's only Thursday and it's already been a long week! Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Glad you got it sorted.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

The original post sounds like what happens when Acrobat/Reader "make up" URLs they think they see in the text (an Acrobat setting I always turn off). Are you sure your URLs were getting into the PDF for print? This needs to be turned on -- here's a screenshot from IDCS6.

David

ID2PDF_Hyperlink.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

LATEST

Thank you, David! I will keep an eye on that setting, too, if this happens in the future.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines