Hyperlinks showing up in places they aren't supposed to

New Here ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

I placed some PDFs into an InDesign document, and those PDFs have active hyperlinks. I have since added some new text and moved things around, but when I exported the document and opened it in Acrobat, I still see the original hyperlinks when hovering over text that was originally in those positions. I exported the document without including the hyperlinks or other interactive elements, but the hyperlinks are still active. Some of the hyperlinks in the exported document also link to incorrect web addresses. Since those hyperlinks were from the original PDFs, they do not show up in the InDesign hyperlinks window. Is there a way to get rid of those hyperlinks or edit them? Thanks!

TOPICS
Import and export

Views

62

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 14, 2022 Jul 14, 2022

Acrobat is doing that automatically. You can turn that off in your preferences but that won't do anything for anyone else.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

How did you remove them? Did you cover it up with another object? It will be still visible for Acrobat to see them. 
It is not a technically link, Acrobat tries to make links from text which looks like a link. A placed PDF is like an image. 

Before you place a PDF use the redaction tool to remove parts you don't want to disclose to the end user. Set the redaction color to none to make redactions invisible. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

I either covered them with another object or cropped the PDF. Is that what's causing the issue?

Even if I delete the objects completely, I would still see hyperlinks when I hover over spots where text used to be. I have attached an image explaining my issue. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Try this:

Open the original PDFs in Acrobat Pro, and use Acrobat's tool to remove all hyperlinks from the PDF.

  1. Edit PDF tool panel (right side)
  2. Select the Link tool.
  3. Choose Remove Web Links.
  4. Save the  revised PDF with a new name.
  5. Import the revised PDFs into your layout.

 

Once a PDF is imported into your INDD layout, there isn't much you can do to change it, similar to when we import graphics into our layouts.

 

 

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

LATEST

Acrobat is doing that automatically. You can turn that off in your preferences but that won't do anything for anyone else.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

If those PDFs with the hyperlinks you imported are still imported links then it makes sense that no matter what you do in InDesign the hyperlinks from those PDFs would remain active. Have you tried opening the original PDFs with the hyperlinks and removing those hyperlinks in Acrobat? Then reimport them back into the InDesign document.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines