Hyphenation in InDesign not working (2021, 2022)

New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

I have already read two posts here reporting that hyphenation doesn't work. I can confirm the same problem. Neither 2022 or 2021 versions hyphenate my texts. I thoroughly checked all settings mentioned in the previous posts, to no avail. Not saving as IDML, opening that in 2021… Nothing happens.

 

I work as copy editor in my mother tongue, Catalan, and I also teach typesetting with InDesign in a Master's. Hyphenation is very important to all of us in the publishing area. Previously I had CS6 in my laptop and with that "antique" I could show to my students how hyphenation worked, but that is no longer possible, because I updated the laptop to the last MacOS version, which won't open the CS6 app.

 

The whole situation is preposterous. I just hope someone is reading this. Oh, please, have mercy on us!

TOPICS
Bug , Performance

Views

169

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

The font is missing when I open the file but I can see that the text is hyphenated

Capture d’écran 2022-03-09 à 17.51.24.jpg

Did you try to reset preferences?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

I am also missing the font and the text did not hyphenate. However, when I change the font, it seems fine. I did notice you have the Adobe Single Line composer set, wonder if switching to the default Adobe Paragraph Composer would make a difference on your end. 

And as mentioned by jmlevy, try resetting preferences: https://creativepro.com/rebuilding-indesign-preferences/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 10, 2022 Mar 10, 2022

Copy link to clipboard

Copied

Many thanks for your input. 

Sorry, it didn't work. 

- I've rebuilt preferences and deleted all files in the Caches folder.

- I've applied styles with paragraph composer and single-line composer

Nothing changed.

 

It's clearly my installation, because I can open documents provided to me by clients which have hypenation working normally. If I don't touch any paragraph setting, all goes fine. The moment I set a different typeface or apply a paragraph style of my own, hyphenation vanishes.

 

I attach the same file, now with two languages, typeface Noto Serif and styles with Paragraph Composer

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2022 Mar 12, 2022

Copy link to clipboard

Copied

In the end I had to reinstall InDesign from scratch, whitout preserving preferences nor previous versions.

 

All went back to normal, but obviously I've lost my dictionary customisations: a couple of new languages and updated dictionaries for some of the existing. 

 

Now hyphenation works. We'll have to see how long this lasts if I want to create again those new languages.

 

My suspicion is that the application didn't recognize the "Info.plist" file that I had to "enhance" with a few lines for the new languages, even though I followed the instructions to the letter. Or maybe the problem had an entirely different cause, because I obviously kept a copy of the original "Info.plist" file, and using that didn't solve the problem either.

 

Let's be positive: I can work again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 13, 2022 Mar 13, 2022

Copy link to clipboard

Copied

I realize this is after you have reintsalled everything, but I first opened your file, the hyphenation was not there, but when I forced a recompose (Command-Option-/ or Ctrl-Alt-/), it corrected itself and the hyphenation intstantly appeared.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

LATEST

Thank you very much. I will write it down this tip so as to remember it. I don't preclude that the problem can happen again at some point, because I need those languages I installed sooner or later.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines