I DONT want my tables to flow and break across pages. Please help...

Community Beginner ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

Hello,

My tables are flwoing through my pages. But they sometime break off in the rows and continue on the next page. How do I get my tables to not break?

Btw, I have assigned a table style to all tables. Thanks in advance 🙂

Views

5.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Valorous Hero , Oct 01, 2017 Oct 01, 2017
Unfortunately, it does not seem to be a setting that can be applied as part of a table or cell style! Also, it's under Cell Options, not Table Options. So, select all the rows in the table, right click, go to Cell Options > Rows and Columns, and there you should see the Keep with Next Row option...

Likes

Translate

Translate
Adobe Community Professional ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

Are you asking how to keep it all on one page? If so, make them fit.

Are you asking how to make cells break across pages? I'm afraid that isn't supported.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

Thanks for your answer. I will try to clarify with this sreenshot. just dont want the tables to break as they are in this screenshot. I guess the same way you can do with paragraphs?

dump3.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

That second row will not fit in that space. It's as simple as that.

InDesign will not break a row so the entire row has to fit.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

@BobLevine But can the table fit in the other page then? Like this:dump4.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

I have the exact same problem. In your screenshot there is clearly enough room for the second row to fit on the first page.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

LATEST

Hi Simon,

in the case of Raykurt's screenshot it could be that the second row is just a tiny bit too high to flow into this white space. It could help to set the space before of the table to a different value. A negative one perhaps.

 

Regards,
Uwe Laubender
( Adobe Community Professional )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Valorous Hero ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

If you want to keep all the rows of the table together, go to the Table Options > Rows, and tick the "Keep with next row" checkbox....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Valorous Hero ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

Unfortunately, it does not seem to be a setting that can be applied as part of a table or cell style! 😞

Also, it's under Cell Options, not Table Options. So, select all the rows in the table, right click, go to Cell Options > Rows and Columns, and there you should see the Keep with Next Row option...

Capture.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

If you are going to do this manually, save a couple of clicks and selections and set the Keep Options of the table container paragraph to keep all lines together. That can also be done with a Change All.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2018 Jul 08, 2018

Copy link to clipboard

Copied

Hi Jongware, how exactly can you do it through Find/Replace w Change All?

This is my case:

"Esempio 2.49" has it's own style with "Don't separate from next 1 line"

Next, there's a table with its own style (and Table style and Cell style) that I don't want to split on the next page. The trick to select all rows, right-click and choose "Keep with next row" works, but do I have to do it manually for each one of the 400+ tables in the book? I'd rather kill myself…

Schermata 2018-07-08 alle 11.38.44.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 08, 2018 Jul 08, 2018

Copy link to clipboard

Copied

There is an unofficial, unsupported code to search for tables, and it only works in plain Text mode, not in GREP.

Search for

<0016>

and you'll see a Find Next selects the table in its entirety (not the inside cells of the table, but the 'outer' table). Apply your Keep settings in the Change To format.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines