ID 2022 not honoring space before

Community Beginner ,
May 18, 2022 May 18, 2022

Copy link to clipboard

Copied

Hey folks, I have a super weird issue. InDesign is messing up the space before on a specific style. The space before is set to 2p6 on this header. A few issues happen.

 

  1. InDesign will sometimes add quite a bit of extra space before, well more than 2p6 (and this is not from the previous paragraph style, which has 0p0 of space after).
  2. When I hit enter and start typing, the first few characters will . . . simply not affect the heading position at all; after a few characters, it'll bump the heading down to the incorrect amount (see videos).
  3. Sometimes when I hit enter and start typing, it will initially bump the heading down exactly as expected, but then after a few characters bump it down an additional amount.

 

Very bizarre, and it does not happen in ID 2019 which I am using. But I need to use ID 2022 if at all possible.

 

I created a new InDesign 2022 document and carefully recreated every style I needed just in case there was some random paragraphy style somewhere messing with stuff; no dice. The problem popped up. The problem occurs across other InDesign files using the same font and paragraph styles; the problem persists even when I change fonts, too.

 

Any ideas? I've attached a bunch of stuff.

 

CORRECT SPACING - 2P6:

Screen Shot 2022-05-18 at 5.33.49 PM.png

 

INCORRECT SPACING - 2P6 + ??? :

Screen Shot 2022-05-18 at 5.33.54 PM.png

TOPICS
Bug

Views

91

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 18, 2022 May 18, 2022
Turn off Span Columns in your Subheading A Paragraph Style. I don't know why it would make a difference, since technically, even though you have only one column, it's still Spanning All but it's what's causing your situation.

Likes

Translate

Translate
Community Beginner ,
May 18, 2022 May 18, 2022

Copy link to clipboard

Copied

I should note that I don't notice this with ANY OTHER style at all. It's only this centered style.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 18, 2022 May 18, 2022

Copy link to clipboard

Copied

My guess is that that file has some corruption. I can duplicate the issue although I could do it with other styles as well. When I copied the content to a new file, InDesign put the footnote in the middle of the page which is equally unexpected. See https://helpx.adobe.com/indesign/kb/troubleshoot-file-issues.html

 

Edit: when I remove that footnote (34) the spacing behaves normally again. 

 

~Barb

corrupt.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 18, 2022 May 18, 2022

Copy link to clipboard

Copied

Turn off Span Columns in your Subheading A Paragraph Style.

I don't know why it would make a difference, since technically, even though you have only one column, it's still Spanning All but it's what's causing your situation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 18, 2022 May 18, 2022

Copy link to clipboard

Copied

That was it. Wow, that is bizarre. Thanks Brad!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 18, 2022 May 18, 2022

Copy link to clipboard

Copied

LATEST

Ya, this may be a bug. I was able to recreate the issue on a new file i just made, but using your paragraph styles.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines