• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

ID has stopped working for me (hangs and finally crashes)

Contributor ,
Oct 28, 2023 Oct 28, 2023

Copy link to clipboard

Copied

I am continuing form https://community.adobe.com/t5/indesign-discussions/which-id-version-is-most-stable/m-p/14189780#M54... as my problem turns out to be broader than v19 alone (which was the most likely reason as I reestarted work on a document after upgrading to v19 and that is when my issues began).

 

I have ended up with a completely broken ID setup for what I need to do, it seems and am completely dead in the water.

 

Example of what happens: Open a document. Click a header on page 90 and clear the paragraph overrides. Result: 100% CPU for ages and unresponsive. At this stage this goes on for a while, then ID crashes.

What did not work (suggested in earlier thread):

  • Saving as IDML and restoring from that (as per suggestion of @Manan Joshi)
  • Clearing the version 19 cache and preferences (as per instructions provided by @Steve Werner )
  • Clearing all ID caches and preferences (as per instructions provided by @Steve Werner )

I removed ID v19 and reinstalled v18.5, but I am getting the same kind of problems (which I did not have when I last worked on that document).

 

I restored a backup of that document from the last time I worked on it in June. I opened it from the Finder, which launched v18.5. It took a while but then the document opened. I performed the same action. Again the same hang and then crash. Something is seriously wrong.

 

I started to think in other directions. Two weeks ago I cleaned up my system by removing every old ID version except the latest v19 (and v8 which somehow keeps lingering on in CC). Then I had some other things to do (using Premiere Pro) and just now I wanted to restart working on the document. Did the cleanup do this?

 

So, I checked this behaviour on a second system (MacBook Pro running v19) and the same happens. That system was not cleaned like this one was, so that speaks against that as a reason.

 

I create a completely new user, logged that use in in my CC account: same problem (v18.5, recreated document from IDML). So, broken preferences and caches seem not to be the cause either.

 

I created a completely new (obviously very small, my real work is a >200 pages 74MB documen with >300 images as links), entered some paragraphs, changed one from 'anywhere' to 'next frame' and back, no problem.

 

Another option is that ID is broken after macOS updates. The last time I seriously worked on the document was June. But it woul dbe weird if I was the only one, so I suspect my work in the spring has created a corrupted document then which I only found out now (strange, but possible)

 

My OS is macOS Monterey 12.7.1.

 

Help? I am completely stuck.

TOPICS
Bug

Views

72

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 28, 2023 Oct 28, 2023

Copy link to clipboard

Copied

>Another option is that ID is broken after macOS updates. The last time I seriously worked on the document was June. But it woul dbe weird if I was the only one, so I suspect my work in the spring has created a corrupted document then which I only found out now (strange, but possible)

 

In case you haven't tried this on the document. Try saving it as an IDML: File > Save As > InDesign CS4 or Later [IDML]. Open the IDML in InDesign to recreate it. Some kinds of corruption can be fixed in this way.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 28, 2023 Oct 28, 2023

Copy link to clipboard

Copied

Sadly, this did not help as well. When I opened the resulting IDML and tried my paragraph change action, it happened again. It gave me some new info, though, it takes a few seconds for the system to become unresponsive. If, after the change, I quickly double click some text it still works, but shortly after the system hangs. So, it is something ID does in the background, it seems.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 28, 2023 Oct 28, 2023

Copy link to clipboard

Copied

LATEST

I have checked the only thing that was different and that was I had changed fonts between the previous version and the new one. I changed the styles as first thing when I started working on it a while back, replacing the fonts. Then I worked on it quite a lot without encountering issues.

 

So, I took the edited file, opened it, changed all the paragraph styles back to the old fonts, saved it, made sure all the embedded diagrams (>300) also were using the old fonts, and I opened the file again. I did the same action and now ID does not hang/crash.

 

In other words: I now probably know what probably happens: the font I use triggers a bug. It is either Ophian or Cabin that triggers the bug. First time I encounter a bug while using these fonts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines