Illustrator layers won't import with layers into indesign

New Here ,
Apr 27, 2022 Apr 27, 2022

Copy link to clipboard

Copied

Good afternoon, I have a problem placing a layered Illustrator file into InDesign and I followed all the steps to make the layers visible. The imported file appears as one static layer. now when I try to right-click to edit with InDesign it says I am missing a plugin?????

It also happens with the illustrator files I have. This is so frustrating

I am attaching an image that shows there are no layers.

Thank you in advance

TOPICS
Import and export

Views

105

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Apr 27, 2022 Apr 27, 2022
Illustrator Layers will not 'translate' to InDesign Layers, there both different things. Your screen shot show the InDesign Layers, not the AI layers. If you right-click on the placed Illustrator file you can choose 'Object layers options' to see those Illustrator Layers. Or select the image then choose menu Object > Object Layer Options. Also when you have Show import options on while you place the Illustrator file you can set Layer visibility. The illustration itself then sits, of course, on a...

Likes

Translate

Translate
Adobe Community Professional ,
Apr 27, 2022 Apr 27, 2022

Copy link to clipboard

Copied

You can show or hide individual layers and sublayers, but not the objects on those layers. If you want to show or hide the objects in Layer 1 they will need to be on their own layers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 27, 2022 Apr 27, 2022

Copy link to clipboard

Copied

Illustrator Layers will not 'translate' to InDesign Layers, there both different things. Your screen shot show the InDesign Layers, not the AI layers. If you right-click on the placed Illustrator file you can choose 'Object layers options' to see those Illustrator Layers. Or select the image then choose menu Object > Object Layer Options. Also when you have Show import options on while you place the Illustrator file you can set Layer visibility. The illustration itself then sits, of course, on a InDesign layer, don't confuse the two 😉

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

My mistake. I thought that was a screen grab of the Illustrator Layers panel. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2022 Apr 29, 2022

Copy link to clipboard

Copied

Thank you for taking the time to answer, I did what you said about going to the Object > Object Layer Options it still shows that I have only one layer, the import itself has multiple layers. When I placed the AI file I check show layer option and made them visible. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2022 Apr 29, 2022

Copy link to clipboard

Copied

LATEST

Thank you for taking the time to answer, I did what you said about going to the Object > Object Layer Options it still shows that I have only one layer, the import itself has multiple layers. When I placed the AI file I check show layer option and made them visible. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 27, 2022 Apr 27, 2022

Copy link to clipboard

Copied

What you are showing is the layer panel but it is not the way to show or hide the layers of an Illustrator placed file. You must go to the Object menu > Object layer options.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines