Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Imported pdf looks terrible all of a sudden

Participant ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

I have to import pdf's into InDesign documents almost daily. All of a sudden, just out of nowhere, imported pdf's look terrible: the colors are very hard. When I switch to the high quality preview mode in InDesign the pdf looks good and when I export the document as pdf or print it the imported pdf looks fine too. It's just the preview in InDesign that looks bad and that's annoying when working on the document.

 

Now the easiest 'solution' obviously is to always work with the high quality preview but that hurts performance a bit and well... things used to look good before so I'd like to know what went wrong!

 

Odd thing: when I open an old document with imported pdf's they look fine. So it seems there is suddenly something going wrong with the actual import but I checked all settings and can't find anything odd. Any idea's...?

 

I've added a screenshot of an old document in which I imported the exact same pdf that I had imported a week or so ago: on the left you see how it should look and on the right you see the newly imported pdf. It's the exact same pdf...! As you can see colors are really bad...

TOPICS
Bug, Import and export

Views

357

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Mar 17, 2021 Mar 17, 2021
Have you recently upgarded to the latest version? If so, check your Color Settings, there is a bug in the latest upgrade that can turn off color management—Color Settings get set to Emulate InDesign 2.0 CMS Off.

Likes

Translate

Translate
Adobe Community Professional ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Hi @J van E 

 

Go to View > Display Performance > High Quality.

 

If that fixes it, that setting will work for the current session only. Go to Preferences >  Display Performance > High Quality to make the change for documents that you open.

 

~ Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Thanks, but I already posted that 'solution' myself. 😉 The problem is that I never needed to do this before: I could always work with the regular preview and get a good preview. But now all imported pdf's look terrible. Working on the high quality preview all the time makes things a bit slower and sluggish.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Is this for all PDFs or only some? Is there something different about them? Perhaps they come from a different supplier or were saved or exported differently than others?

 

Here is how I handle images in InDesign. I usually stay in Typical display mode but set the display preferences so in Typical vector graphics are displayed in high resolution. The labels are a bit meisleading, as there is no way to know just from a file extension whether a graphic is a vector or a raster image. PDFs can be raster, vector, or both. InDesign assumes PSDs, TIFs, and JPEGs are always raster and EPS and PDF are always vector.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

As I said, something must have changed because imported pdf's look good in old documents but when I import the exact same pdf into that document the newly imported pdf looks awful. Something has changed and something is wrong...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Was this document created by someone else? The document preferences might be diffferent.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Sometimes images can have a local display level - https://helpx.adobe.com/ie/incopy/using/controlling-graphics-display.html

 

If the object in the old document has an Object high quality display setting then this would be the reason.

 

Just a guess.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

are document types of the book and the PDFs the same (e.g. Print/Print)? The difference of color spaces might be a cause.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Have you recently upgarded to the latest version? If so, check your Color Settings, there is a bug in the latest upgrade that can turn off color management—Color Settings get set to Emulate InDesign 2.0 CMS Off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

WE HAVE A WINNER!!! 😉 You made my day! I just KNEW something had changed somehow! The color settings were all changed indeed and that caused the problem! And I say 'all' because the settings were also changed in Illustrator! And to add to that: I still use InDesign 2020 and afaik there hasn't been an update for that version lately but I did update Illustrator and Photoshop a while ago and it seems this bug also has an impact on older ID versions...! Odd!

 

I also had to change the setting, quit and restart both ID en Illustrator in order for the change to stick: at first I simply changed the settings, clicked OK, but after switching to other programs and back again the settings were reverted again...! Luckily changing them, quitting the programs and then restarting them did the trick.

 

All is back to normal again, awesome! Thanks!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

The upgrade to the latest Photoshop triggered it for me. It sounds like it can be reoccurring, so a solution seems to be deleting or moving the Adobe Color Caches folder. On OSX it is here:

 

⁨Users⁩ ▸ ⁨username ▸ ⁨Library⁩ ▸ ⁨Caches⁩ ▸ ⁨Adobe⁩ ▸ ⁨Color⁩

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Thanks, I'll have a look at that!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Bummer... it's reoccurring indeed: a few times already in this short period of time the color settings had been set wrong automatically again... I saved presets for ID, Illustrator and Photoshop so I can quickly restore my prefered settings but obviously it's a drag having to check the setting multiple times a day...!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

ANd btw removing that color folder doesn't help here. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Try manually setting your Color Settings in all three apps, quit all and then move the Caches>Adobe>Color folder, along with the Bridge folders to your desktop, and restart InDesign. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

LATEST

Sorry, I think the file to delete is inside the Preferences folder not the Caches folder:

 

 ⁨Users⁩ ▸ ⁨username ▸ ⁨Library⁩ ▸ ⁨Preferences⁩ ▸ ⁨Adobe⁩ ▸ ⁨Color ▸ ⁨ACEConfigCache2.lst

 

See this thread:

https://community.adobe.com/t5/indesign/photoshop-update-causes-indesign-color-management-settings-t...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines