Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Importing text... mysterious Character Style application!

Enthusiast ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

I'm importing text from Word.

For some reason, the very beginning few paragraphs are getting a Character Style applied, though the space it's being imported to doesn't contain that style (I've checked by typing).

The source document looks pretty clean.

No idea why this might be happening! A cool mystery but a little... extra.

 

[edit]

Just discovered that if I import the text to a new, unformatted ID doc, allow it to bring in the Word styles, then copy & paste into my working ID doc, all the styles appear to be correct. 🙂 Still, no idea what's going on.

 

Suggestions?

 

thanks

TOPICS
Type

Views

120

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

Hi @turner111, I see you don't have any replies to your post yet so sorry about that! Have you been able to solve this problem? To make sure I'm understanding the problem, it sounds as though when you are mapping Word text into an ID document with preset styles, a Character Style is mysteriously being applied that isn't a part of your preset. But, if you map the same Word text into an ID document with no preset styles, the extra Character Style isn't being applied. Is that right?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

Hi Jain,

Thanks for the note!

Sort of correct.... I think... the style that's being applied is indeed a part of the preset - in this example, character italics - but it's being applied to text when imported that doesn't currently have that style in Word, and into place in ID where it also isn't applied to anything.

For example:

 

Paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style. Italics italics italics italics italics italics italics italics italics italics italics. Paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style.

 

is importing into my working document as:

 

Paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style. Italics italics italics italics italics italics italics italics italics italics italics. Paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style paragraph style.

 

However, it imports properly, with named word styles, into a new ID document.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

Okay. I'm not sure if you are importing a long text (like a manuscript). If so, does this glitch happen in the same place every time, i.e., at the start of a new chapter or in the first paragraph after another style application is used, such as a title? Also, in your Advanced Style Mapping settings, do you show any Style Name Conflicts?

 

JainLemos_0-1634571990583.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Hi - sorry for the delay, just received the next batch of stories...

 

To bring in the Word content, I'm just using command-D to place it into the body.

 

Yes, there are a TON of conflicts when I import directly.

 

However, as noted, if I import it into a new ID doc, then copy & paste it into my working doc, it's generally error-free except where the client either applied default word styles or... get this...

 

The language shows up as being... FRENCH?!? or... ITALIAN? lol.... didn't see that one coming.

Screen Shot 2021-10-22 at 10.54.25 AM.png

Screen Shot 2021-10-22 at 10.56.20 AM.png

 

Well, I've never seen this before! I'm assuming I can clear it by selecting text (or ALL text in the document) and changing it to English: USA.

How little I know about InDesign... 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

If using Windows, try this and see if it makes any difference:

In Word, select all the text and press Control-spacebar--this will remove all formatting except for paragraph styles, including character styles and any manually applied character formatting. See if the import problem still occurs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Thanks - using a Mac, but I'll look for the equivalent & try it out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

On the Edit menu, click Clear and then select Clear Formatting.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

>>Just discovered that if I import the text to a new, unformatted ID doc, allow it to bring in the Word styles, then copy & paste into my working ID doc, all the styles appear to be correct.<<

 

That brings two things to mind...

  • Your current ID document has some styles by the same name as the Word doc, or
  • Your current ID document is partially corrupt; consider saving it a an IDML file and then reopening it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

"Your current ID document has some styles by the same name as the Word doc, or"

Yes - that's intentional - it applies the ID styles when imported.

 

"Your current ID document is partially corrupt; consider saving it a an IDML file and then reopening it."
Hmmm... I may give that a shot!

 

thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Long shot, but knowing how most Word users operate, any possibility the original Word text had the style applied, then locally formatted to remove the italics?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Hi Peter - in many cases, yes, they applied "additional" (word default) styling like italics.

However, even in cases where there is no default styling applied, I'm getting these sections of text highlighting an needing to have + formatting stripped.

Now, if we could get them to stop hitting a space or two before every return, and double-returning every paragraph 😉

It's kind of endearing, actually.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

LATEST
quote

😉

It's kind of endearing, actually.



Yeah, right...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines