• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Imports from Illustrator are pixelated

New Here ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

I'm importing some images from Illustrator into an InDesign document, and no matter what I do, they end up being pixelated. I've looked online for some solutions, and here's a list of things I've tried that have helped but not solved the problem: 

  • Scaled up the vectors in Illustrator so that all of the images are at least twice the size I need them to be in InDesign (I need them to be about 1in by 1.5in in the file, and they're all at least 2in by 3in) 
  • Changed the Illustrator export to be 300ppi 
  • Changed the Display Setting in InDesign to be "High Quality Display" 
  • Changed the Compression settings in InDesign to be "Lossless" instead of "Lossy" 
  • Changed the export in InDesign to be 300ppi 

Can anyone advise on what may be going wrong here? What can I do to fix this issue? 

TOPICS
Import and export

Views

144

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

They're pixelated when you're viewing them at High Resolution in Indesign, or they're pixelated upon output? Not sure why you're messing with exporting from Illustator - just place the .ai file in Indesign. Are there raster images placed in the Illustrator file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Hi! I've been exporting from Illustrator because I have multiple artboards in Illustrator that I will need to be separate objects in InDesign. When I tried to insert the .ai file, it would only insert the first artboard. Is there a way to insert all of them? If so, I'll definitely just do that! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Hi there,
on importing/placing the Illustrator file in InDesign hit the Shift key, alternatively activate the Import options in the file dialog. After you click place you get a second window, where you can specifiy which artboard you want to place.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

Hi @alexcorb ,

 

Sorry to hear about the trouble. Please share a few more details like:

 

  1. The version of InDesign & OS.
  2. Is this happening with a specific file or multiple files?
  3. Please share a few screenshots.

 

We're here to help, just need more details.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

What file type do you use to import into InDesign?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

You say that you are scaling up vectors in illustrator. A vector file will never pixelate. It can be enlarged or reduced without any loss of quality. So it is more probable that you are exporting your Illustrator files as pngs, jpegs or some other raster format and thus prone to pixelization if enlarged. You need to make sure that your illustrator art is actually vector to begin with. You can find this out in Illustrator by going to the Outline mode (View>Outline). If you see line drawing in that mode then the art is vector and not resolution dependent. If all you see is an empty box then the art is raster and will pixelate if used at a larger size than it was created at. If the art does turn out to be vector then save the file as either .ai or pdf. Either of those formats will retain the vector characteristics and should not show as pixelated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Transparency pixel effects have indeed a pixel resolution in vector files. Those can pixelate if increased in InDesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

Hi @alexcorb:

 

Where, exactly, did you specify High Quality Display? In the Object menu, it controls the view of only the selected object, in the View menu, it controls the view for all objects in that session and in Preferences, it will impact all documents opened from that point forward. Very confusing. 

https://www.rockymountaintraining.com/adobe-indesign-display-performance-controls-theyre-everywhere/

 

~Barb

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

I also wrote an article here

 

https://creativepro.com/high-res-image-look-low-res/

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Hi @alexcorb ,

please share a sample Illustrator file.

We'll look into this case…

 

Thanks,
Uwe Laubender
( Adobe Community Expert )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

LATEST

My two-cents, ... .  Do you check for document errors?    To some, the images placed in the ID document may appear as 'pixelated' (definitely not a clean resolution) until the InDesign knows where the link is to the image-file(s).  If you move the image files, after working on the ID document, without re-linking the image-file(s), ... it ain't pretty, anymore.  I had that happen once, a while back.

Hope your issue was resolved!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines