Indesign 17.1 slow performance when editing text frames

Community Beginner ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Hello,

 

There are many posts like this, I'm sure, but my latest version of indesign (17.1) seems to be running painfully slow when I try to edit certain text frames in certain documents. Even selecting a frame will cause lag. 

 

It seems to only be happening on some specific ones. Sometimes I'll have to issue on a frame that has an effect applied to it (like a diffuse dropshadow). Copy-pasting the text into a new frame seems to fix it, but not always. Reapplying the master to the page also seems to fix it, but the slowness tends to return after a while. 

 

I'm up to date with everything, running the latest Mac OS Monterey 12.1, and have tried reverting to a previous version of indesign, re-installing it, turning preflight on and off, changing the display performance to typical display, not being in overprint preview, previewing in GPU mode, ... Basically, all the good stuff after scanning the internet for solutions. 

 

Anyone else with similar issues? Thanks!

 

I'm using an iMac 4,2 Ghz, Intel Core i7, 32GB RAM. 

TOPICS
Bug , Performance , Print , Type

Views

39

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

You probably tried all this:

https://community.adobe.com/t5/indesign-discussions/reset-indesign-preferences-and-other-troubleshoo...

But have you investigated for a corrupt document?

Further, adding drop shadows to all the text will certainly slow things down.

Mike Witherell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

LATEST

As Mike noted, any effects applied to a text object can create long pauses and delays when they are edited. Make sure no effects are active until the very last stages of design.

 

If you have a style that uses text distortion (width or height other than 100%), it can cause similar delays.

 

And if you have a style using a GREP style, there will be a pause pretty much every time you change the text as the GREP function runs.

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (v2 now on Amazon!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines