Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


InDesign 2020 Slow Performance

Community Beginner ,
Jan 16, 2020 Jan 16, 2020

Copy link to clipboard

Copied

Hi,

 

I've been having problems with inDesign for the past few months. Everything is a second or so behind... Everytime I move an image or or text box there is a lag of around half a second. The hand tool and zoom tool are also extremely jumpy. I'm aslo getting a spinning wheel for very simple tasks.

 

This problem seemed to come out of no-where, I have a very powerful machine (spec below) and have other users in the studio running the same version of indesign with no problems at all.

 

{Renamed By MOD}

I've tried the following:

 

  • Working offline
  • Restarting in safe mode
  • Reinstalling software
  • Turning anti virus off

 

Any help would be greatly appreciated as neither myself or our IT support can figure this out

 

Cheers

 

Liam

 

Processor - 3.7 GHz Quad-Core Intel Xeon E5

Memory - 64 GB 1866 MHz DDR3

Graphics - MD FirePro D300 2 GB

 

Indesign 2020 - 15.01

 

 

 

TOPICS
Performance

Views

20.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Aug 18, 2020 Aug 18, 2020
Morning all, Thanks for all of your replys over the last year. I finally found a solution to this problem! After reading through the comments, I noticed a few people had success changing the colour profile from their monitor to Apple RGB or Colour LCD. This didnt work for me when I initially tried it, but after trying out a few more colour options today I found one that works (sRGB IEC61966-2.1). Changing to this colour setting (in preferences/Display) instantly changed inDesign from being laggy...

Likes

Translate

Translate
New Here ,
Jul 02, 2020 Jul 02, 2020

Copy link to clipboard

Copied

This is the exact same bug we had with InDesign CS6 with the initial release. Now the June 2020 release has the same problem.

 

All of our users (Windows 10) on different models of desktops and laptops have experienced this problem. Renaming the Document Fonts folder to just Fonts (or deleting it entirely) fixes the issue for now. Adobe needs to fix this.

 

WIth one file open, the problem happens but is not severe. With two files open (even if they are single page documents), InDesign can hang for 10 seconds to over 3 minutes whenever anything is done (click a menu, select an object, etc.) 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

Taking the fonts out of the documents folder and deleting the empty folder has fixed the problem I've been fighting for months. We shouldn't have to do this with every package!

We all pay quite a bit for Adobe software and it seems like Adobe should have fixed a problem that has been going on for many months causing headaches and loss of productivity to so many people!

I was having some problems with Acrobat DC crashing for a while, especially when packaging in InDesign. For the most part, that problem seems to have been fixed, but I'm not positive it's fixed completely. It seems like I still have problems with Acrobat DC occasionally.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2020 Jul 09, 2020

Copy link to clipboard

Copied

Holy crap - I can't even begin to believe that this is what has been causing the issue for me. Tried everything - deleting prefs, changing color profile to sRGB (which seemed to kinda help, but still was getting lag) so finally came across this post and BOOM, no lag whatsoever. Thank you for taking the time to post this solution because I was literally minutes away from giving up. 

 

For context, I just got a Microsoft Surface Studio 2 literally less than 2 months ago and hadn't experienced any issues until today. Up until today, I had opened up to 4 INDD files (none under 75 pages) at once and experienced no issues until today when for the first time I opened not one but two package files and boy was it a shiz-show. I would have to wait sometimes up to 10 seconds when clicking between the two projects and I knew something was just not right... not on this fresh of an install. 

 

Anyway, thank you guys again for keeping me from setting my new computer ablaze.

 

Why the hell hasn't adobe come up with a fix for this issue? Pretty crazy that something so simple could turn my computer in to a bowl of peanutbutter.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 24, 2020 Aug 24, 2020

Copy link to clipboard

Copied

PROBLEM SOLVED: I DELETED THE "FONT FOLDER" FROM THE DOCUMENT FOLDER (THIS IS CRAZY !!!)

I'm a graphic designer and I've been using InDesign since the first version and I've never had any problems with this program until CC2020. I have been wasting time and unnecessary energy for months trying to understand the Indesign slowdown. It slows down to me when I use multiple files together to work in multillanguages (which is normal for me) specifically with the copy and paste between files (tool text); two open files are enough to cause enormous discomfort that has afflicted me.
So THANK YOU, THANK YOU and THANK YOU again to Kate_Bee, I never thought that deleting the Fonts folder could make Indesign come back as it should !!!
But I wonder: but why ???? why does adobe not solve this big problem? for us graphic designers who work on times it is not possible to slow down for this.
Good job everyone!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

OMG! You're a lifesaver. It worked here.
Thanks for sharing. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2020 Aug 25, 2020

Copy link to clipboard

Copied

That is so crazy that switching from 4k to 2k solved the problem!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2020 Apr 26, 2020

Copy link to clipboard

Copied

Hi all,
Its been a while since I last checked in on my initial post. I've never found a solution to this problem, but from what I can gather from some of the helpful comments below - it would make sense that the problem lies in the 4k monitor. Our IT guy came in and ran my machine off one of my colleague’s iMac displays and it worked perfectly. Its crazy that Adobe don’t have a solution to this.
Unfortunately turning my colour settings back to Apple RGB didn’t work, but I'm glad its working for some. Can I ask the people who are experiencing the same problems what monitor you're using? Mine is LG UltraFine Display
Cheers

Liam

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 26, 2020 Apr 26, 2020

Copy link to clipboard

Copied

I can't think of anything else other than the cable and/or connecting type (HDMI v Displayport). Saw a few people solve it via this path.

 

My Monitor is a Samesung U32J59x.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 16, 2020 May 16, 2020

Copy link to clipboard

Copied

Just wanted to add my experience on this. I've had big lagging problems with inDesign since I started working on a rather big job around January 2020. The problem was the same on a mac and PC, both of wich has good specs, everything updated and so on, so the frustration has sometimes been, well, you know. I did see a tip a couple days ago that actually has helped a lot, and maybe this can be helpful to others as well. The 'trick' is to choose classic standard workspace(!). It was said to have something to do with linking and online services or something like that; I actually don't know, and it really does not matter either as lang as it works, right? 🙂 It is clearly, undoubtedly, a bug (a huge one) in inDesign for the moment, and we must only hope that they will find a way to solve this very strange and annoying behaviour very, very soon ... I've been using Adobe since version 1.0 of most of their softwares, and has always been a huge fan, but now they are testing me ... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 16, 2020 May 16, 2020

Copy link to clipboard

Copied

Which version of InDesign 2020 are you on currently? I was just wondering whether the recent update (15.0.3) has improved things.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 18, 2020 May 18, 2020

Copy link to clipboard

Copied

I have 15.0.2 right now, so I will check with the newest version and give feedback. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2020 May 24, 2020

Copy link to clipboard

Copied

Now with version 15.0.3. So it seems my problem is not gone, but it can be just fine for a long time, and suddenly it is back. For me it is a bit different than what others have reported. It is at its worst when I try to edit a text box with some text in it from before. I have to do this all the time, due to corrections in the text. Even when I try to 'force' my tool to be the text tool, either by just hitting 't', or by clicking on the 'T' in the tool box; inDesign (it) insists on me using the move tool (v); which is definetely not what I want. If this did not constantly cause the spinning wheel, I could have lived with it; but this takes a lot of time (it adds up), and is really annoying. I try to quit and restart several times; and to me it seems that this sometimes helps; but I don't know if it is the restarts, or something totally different that makes it work again (for a time) ... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2020 Jul 01, 2020

Copy link to clipboard

Copied

Thank you this helped! I think also coupled with installing the font in the system and not just reading it off the font folder. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 01, 2020 Jul 01, 2020

Copy link to clipboard

Copied

Hey there, I would suggest deleting your 'document fonts' folder from your packaged folder.

It took me and my IT team a month to work that out but all issues fixed and back to normal after doing that. Good luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Thank you! I know this thread is old, but my indesign started lagging. When I switched to classic workspace it sped back up! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 16, 2020 May 16, 2020

Copy link to clipboard

Copied

I've found two issues that will cosistantly cause slow InDesign Performance for me.

  1. The first usually happens in files with lots of high-resolution pixel images and/or complex vector images. If your Display Performance is set to High Quality Display and everything slows down, change to Typical Display instead.
  2. If you have a complex custom Preflight running in the background, and you get the spinning beachball of death, turn off Preflight (in the Preflight panel), to see if everything speads back up.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2020 May 24, 2020

Copy link to clipboard

Copied

I have turned Preflight 'off', just to be sure (but I don't think that is the problem), and I always have my display setting on 'typical', which has been the standard for a long time now. My PC is also very powerful, as the OP, so might it be that inDesign has a problem with some of the newer processors or something? I have 24 cores for example ...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 24, 2020 May 24, 2020

Copy link to clipboard

Copied

InDesign uses I believe a maximum of two cores, worse: at PDF export just one. So here the single core speed is more important.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 03, 2020 Jun 03, 2020

Copy link to clipboard

Copied

If you're working from a packaged folder try deleting the document fonts folder.

Worked for me after 1 month of lagging!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 04, 2020 Jun 04, 2020

Copy link to clipboard

Copied

Yes, noticed that as well. If the fonts are present in my system but also present in a Document Fonts folder from a packages, opening is slow and using the Text tool, in the beginning, is sloooow, it lags. Removing the folder and it is fast again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 04, 2020 Aug 04, 2020

Copy link to clipboard

Copied

Come on Adobe, we're all having this problem and it's been reported. We've done half the work for you. Fix the packaged fonts issue. 

 

After updating to 2020 on a Windows 7 machine, I was struggling with lag when more than one file was open. I only work with packaged pubs for organizational purposes. I called Adobe and talked to a rep (for a long time) and we tried a bunch of things. While troubleshooting, I unknowingly opened an unpackaged publication and was convinced that all of the things we had tried had fixed the problem. After figuring out that it was still broken, I uninstalled 2020 and went back to 2018 (I bet many PC users have gone back to previous versions). My employer upgraded my computer (it was due anyway) and I reinstalled 2020 on Windows 10. Same problem!  I asked another user with totally different hardware and settings and they had struggled with the problem before reverting back to 2018.

 

Adobe, you can duplicate this in your lab right this moment: using Windows OS and InDesign 2020, open more than one .indd file within packaged folders so that it uses the packaged fonts. Fix it please!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2020 Aug 04, 2020

Copy link to clipboard

Copied

Frankly, my experience has been complaining here to Adobe is like screaming into an empty wishing well. They're non-responsive, their solutions don't work, and you're better off just relying on other members on this board to waste their valuable time trying to fix a problem they didn't create. Not to be a downer, but Adobe kind of sucks for getting any type of help. 

 

Ever. 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2020 Aug 17, 2020

Copy link to clipboard

Copied

I have a graphic design agency and I pay for three Adobe licenses. I've read through a lot of threads pertaining to the InDesign slugishness issue, and my shop is expereincing the same issue (frustrating and costs us a time). I see several posts throughout the subbort community, some marked resolved by Adobe, but I don't see one clear definitive answer or solution. I agree—why are we spending our billable hours trying to track down an issue that should be corrected by Adobe software developers, and then paying for our licenses on top of that? I'm a patient person but this sounds like a double whammy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Aug 17, 2020 Aug 17, 2020

Copy link to clipboard

Copied

For what it's worth, as one of the people that's been touting the colorspace setting, I've found a similar but much better solution: simply switching from Apple RGB to Color LCD.

 

My monitor seems to have come with colorspace presets, or maybe Catalina recognized it. It's a Samesung U32J59x. 32" 4K connected with a fast DisplayPort cable to my 2010 Mac Pro. The lag was there from the start. What solved the lag for me and others was switching from the Display Profile selected by default (U32J59x—which was almost perfect out of the box) to Apple RGB, which was quite differernt and much darker overall. But I found that Color LCD was the exact same as the U32J589x, but with no lag.

 

So I now have the expected speeds and color correctness. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Aug 17, 2020 Aug 17, 2020

Copy link to clipboard

Copied

Liam, because of your card, I suspect you have a "trashcan." Found this, which suggests your card may not be supported by Adobe anymore, while your Mac Pro's CPU is still powerful enough: https://community.adobe.com/t5/lightroom-classic/mac-pro-2013-gpu-problems-amd-radeon-hd-firepro-d50...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines