Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


InDesign 2021 running extremely slow on Mac Big Sur

New Here ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

Hello,

InDesign started running extremely slow (get spinning beach ball) for me even when making edits to simple documents with mainly copy. Looking for help.

Running 2021 InDesign v16.4 on MacOS Big Sur 11.6

Additional notes:

- I tried reinstalling InDesign but still have same issue

- Seems like it started happening when Box Drive updated to 2.24.193 (the InDesign files I work on are accessed online through Box Drive). As a workaround I make my InDesign files available offline. Seems to help some but still have slow performance issues.

- Seems worse (slower) when I use Apple's sidecar feature to use my iPad Pro as a second monitor so just using my MacBook Pro screen now.

- Also seems worse if I have Microsoft Excel open (when cutting and pasting from Excel into InDesign tables)

- It's driving me crazy

TOPICS
Bug

Views

93

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about the trouble you are facing. I would request you to try and check a few things and let us know how it goes:

  • Please check if turning off the internet help resolve the issue?
  • Are you using TimeMachine? If yes, please check if turning it off/ disabling it help resolve the issue?
  • Please check if turning off preflight  (Window > Output > Preflight > Deselect the checkbox) help resolve the issue?
         Anshul_Saini_2-1634855442211.png

     

  • Please try different Display options (View > Display Performance) in InDesign. I recommended working on Typical Display.
  • Please try turning off GPU performance from InDesign preferences (cmd + k > GPU Performance > uncheck GPU Performance and see if that helps?

 

We will be looking forward to your response.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

I see the staff are looking into it, but can offer some other assistance to try and lighten the load on the processing that ID has in the meantime.

In the pages panel, turn off the previews (or if they need to be there, make the thumbnails small) - any time a change is made, InDesign redraws the previews.

If GREP styles are in use, know that the larger the job, the more text that ID has to check to see if the text criteria meet the GREP styles to apply the styles, so use them sparingly.

Effectively, there is a trade-off - any service that ID is using that gives immediate feedback that is document wide (such as the two above) have to be applied to an entire document, and this can take time. Turning off these features might make the software go faster, but at the expense of turning off a useful feature. I feel the frustration, believe me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 23, 2021 Oct 23, 2021

Copy link to clipboard

Copied

Have a look into fiollowing settings:

  1. Do your text frame the Balance Column Setting turned on? I would suggest, work only with objedct styles and turn off balance columne in the style during work. At the end turn it on again in the style. Therefore it is very important to work with Object Styles to make such settings on a global base.
  2. Did you turn on Live Preflight? It is found on the bottom of the document window. Turn it of for all documents and turn it on at the end.

 

In my experience these 2 settings slow down InDesign in a massive way. Another factor is the use of EPS. Replace them with PDF/X-4 or AI files. Don't use EPS any more. 

Another problem could be an external harddrive. When it gets to sleep it causes InDesign to get the rainbow wheel. If you do not need it, turn it off or disconnect it.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2021 Oct 25, 2021

Copy link to clipboard

Copied

I've tried all the of the suggestions but still having very slow performace and spinning wheel. Some documents worse than others. And more so when multiple documents open. For example, if copying text from a PDF or Word file then pasting in InDesign, or copying data from Excel spreadsheet and pasting into an InDesign table. Not positive yet, but thinking the slow down is due to working on files on latest version of Box drive 2.24.193.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

LATEST

Thanks for trying the steps. I'd recommend you to connect with our technical support team. The team here would be able to perform remote troubleshooting and assist you accordingly.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines