InDesign 2022 / 17.0.1 Display is glitchy

Explorer ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

I'm having an issue where the screen doesn't refresh right, whenever the view is changed everything gets glitchy. This is running InDesign 2022 /17.0.1 on a Macbook Pro with macOS Monterey 12.0.1. This seems to happen regardless of if the GPU performance is checked in the Preferences or not. This happends on an external monitor (an Apple Thunderbolt display through a Thunderbolt 3 (USB-C) to 2 Adapter) I've restarted everything. Screenshot attached. 

 

There's a video I made here as well that shows what goes on: https://vimeo.com/647118843

 

barrya_0-1637197402496.png

 

TOPICS
Bug , Performance

Views

811

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I am having the SAME issue.

 

Running InDesign 2022 / 17.0.1 on a MacBook Pro (16-inch, 2019) with macOS Big Sur Version 11.6. I though I could do with a reboot, but this didn't help. I'm running through an external disaply as well (DELL UP3216Q) via USB-C to miniDP. 

 

Screenshot atached. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I, too, am having the same issue! M1 Mac mini, latest macOS Monterey, inDesign 17.0.1 running a Dell 42" monitor. Currently unusable for me. I have had to use my Intel MacBook to drive the monitor (works fine) in order to get my conference brochure out last night. Would love a resolution to this.

 

Mike

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I can report that I resolved this issue for me (in the easiest way possible, too). I rebuilt the cache and preference files by restarting InDesign and holding down Shift-Option-Command-Control. Of course lost all my preferences but gained a non-glitchy artboard, but I'll take it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Hey, thanks for that. That's a bit embarrassing to be reminded of something I should have thought of (troubleshooting basics). I'll give that a try and report back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I was excited to try such a simple solution, but sadly it didn't work for me. As soon as I clicked into a text box, it went all wonky again, and had weird display issues, including skewing text, duplicating text, and other issues.

 

Phooey!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Alas, for me, this didn't work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

I tried this in combination with the UI Scaling set to minimum, as noted below, and am so thankful it worked. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

Any idea how to do this on a Dell? I'm beyond frustrated with the glitching. I'm about to go back to 2021 version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Hey, everyone. Check the User Interface Scaling under Preferenes. I just notice when viewing actual size (100%) my project was not represensted at the correct size - it was too large. I turned on the ruler and noticed, yup, things are scaled here; the inches are very large inches.

 

I moved the UI scale to the smallest setting (probably meaning no scaling) and the project now displays 1:1 on my screen (as measured by my handy ruler), and the glitchyness seems to be gone. In fact, everything looks as it should now.

 

Odd, though, as in Illustrater (v26.0.1), the UI scaling is not at the smallest setting, and the ruler scale is correct, 1:1 on the screen. Plus no glitching. (shrug).

 

Screen Shot 2021-11-19 at 9.32.53 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Cautiously optimistic, but that seems to have fixed things (at least for now). Thanks for the info!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I can report that I did set the UI to be larger in that setting - and that is when this started happening to me. The preference reset fixed it as it reset that back to normal I suppose.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

For me, it was the exact opposite! The preference reset didn't help, but the UI Sizing seems (after half an hour of use) to have fixed things. Woohoo!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I think the same thing was achieved in either case, as @barrya alluded to. Must be at the smallest setting for you now, barrya? When I clicked the More Info link under that preference, it said InDesign will automatically set the UI scaling to best suite the resolution of your monitor unless you set it manually. Perhaps in @mikes38487167's and my case, our monitors promted InDesign to scale up (mine is a 30" 4K and everything is quite small by default since it isnt' a proper Retina display). Anyway. Glad we're onto something here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I just set the UI Sizing in User Interface Scaling up to the medium setting and can confirm the glitch returned. Setting it back -- goes away. This is on an @1x Apple Thunderbolt monitor (while the Macbook Pro is a retina screen).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

Thank g0d this worked. What a nightmare! Adobe’s support, albeit trying to be helpful, blamed it on macOS.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

Unfortunately this doesn't work for me... 😞 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

Thanks so much for posting this solution. Solved my glitchy screen problem, which essentially made Indesign unusable.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

Now I just need to break out a magnifying glass to view the UI again.

 

-Adobe, do you test your products? Really?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

I checked and my settings are all set at small and still having the glitching. Soooo frustrating.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

This did the trick for me. I needed to match my UI scaling with my display size. Once I did that it took care of the glitches I was seeing. Kinda feel stupid over something so simple.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

LATEST

this worked for me! Thank you!!!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

I'm having issues (using on a Dell, not MAC) but a slightly different glitch. My problem is within the various boxes (text or object). Sometimes text gets cut off. Sometimes an object box's frame shape is off. It's bizarre and totally random. I'm attaching a sample of a text issue. I drew yellow arrows to point out the issues. The text in the white area is all in the same text box with columns. The issue in the yellow box is a completely seperate text box but still glitchy. If I scroll down to the next page and come back up, it sometimes fixes it but not always. Or it'll fix the original problem but there will be a new glitch in a new area. It's driving me nuts and I'm thinking about just going back to InDesign 2021 until this is fixed. I need to know that what I'm looking at is in the right place and looks correct. Sigh.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

That definitely looks like a similar display glitch we have been encountering. It may be a specific issue with Dell displays or Dell display manger as others have mentioned these monitors, and my issue was with a Dell U4021 on a Mac mini. If I didn't find this thread that solved the issue for me, I would have reverted back to an earlier version of InDesign, as the issue is maddening. Waiting for an InDesign update might be the easiest solution that doesn't waste any more time hunting for a fix.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

There could be some Windows scaling setting. I don't run CC on Windows, but perhaps this is a compbination of the settings in InDesign and Windows. Screenshot attached with Windows settings(???)Screenshot 2021-12-09 07.45.19.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines