Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


InDesign CC 2019 Unusable on Mac OS Mojave 10.14.3

Community Beginner ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Hello,

I'm a longtime InDesign user who is frustrated at the sluggish performance of v. 14.01 on my 2017 MacBook Pro running Mac OS 10.14.3.

Currently, I'm working on a 100-page 6x9 book. Every time I do the most basic thing, like removing a blank line or changing the font in a paragraph style, InDesign produces the spinning wheel for 20-40 seconds. CPU usage is only 15% (undoubtedly because Adobe refuses to enable multicore support), but the app is unusable. To help speed things up, I switched to "Fast Display," turned preflight off, switched between GPU/CPU acceleration, and deactivated most of my fonts. I also exported my project to IDML and reimported it (didn't solve anything), as well as exported it to Word and reimported (also didn't solve anything).

This must be a bug, right? Or am I missing something?

Thank you

Views

3.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Apr 04, 2019 Apr 04, 2019
Hello,After many weeks of frustration and troubleshooting, I found the problem on my end was caused by one of the options in Document Footnote Settings, which is “Span Footnotes across Columns.” This setting makes the page layout much more complex and Is apparently poorly implemented by Adobe. For me and many others, it causes Indesign to come to a halt when working on books with a good number of footnotes (my document had 200+.)If you are experiencing the same issue, try turning it off and see ...

Likes

Translate

Translate
Adobe Community Professional ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

When you make a change do you see the status bar at the bottom chewing on something specific? Example "Reading XX.psd"?

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Thanks for your response. No, I don't see anything out of the ordinary other than "Basic (working)" and "Checking."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Turn off your preflight and see what happens - "Checking" means your preflight profile is actively checking your document.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

I tried that earlier and just now again, but the problem persists. I just tried changing the font in a heading paragraph style... spinning wheel for 30 seconds before I could do anything!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 27, 2019 Feb 27, 2019

Copy link to clipboard

Copied

You could try resetting preferences when you start ID. Hold shift+CMD+OPT (mac) or shift+CTRL+ALT (win) before the startup screen appears.

Also, are you using any character or paragraph styles in the document?

If yes, are you using GREP or nested styles that could be cascading small changes?

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

Thank you for your continued follow up and willingness to help.

Yes, I have Paragraph and Character styles, but nothing excessive. The whole document is 91 pages. I made a video demonstrating the problem here:

Adobe InDesign CC 2019 UNUSABLE on MacOS Mojave (91 page book) - YouTube

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 01, 2019 Mar 01, 2019

Copy link to clipboard

Copied

Hi Paul,

Sorry to hear about this. I would like to know if the suggestions shared above worked for you? If not, could you please check how it works on other files?

Did you try resetting preferences for InDesign? If not, please try the steps shared here: Set preferences in Adobe InDesign. Resetting preferences will remove all the custom settings and InDesign will launch with default settings. You can also take a backup of the folder in case you want to. Location is mentioned in the article.

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

Try to check the performance by turning of the GPU.

Indesign CC > Preferences > Performance > GPU and animated zoom

Validate the fonts in your system by using font book of your MAC

Check with other indesign document to check whether its file specific error or the application  get hang with every indesign file

Try with IDML format of your file

Try with the Indesign version 13.1 . Whether that works fine or not

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2019 Mar 01, 2019

Copy link to clipboard

Copied

Hi ibnabouna,

In an ideal world, you should be able to just change the size of the body text for an entire book and see the result immediately.

In reality, though, InDesign isn't quite that optimized, so there are many different things one has to learn to avoid doing.

Having said that, I regularly work on 400 and 500 page books, all in a single file, and see very little lag, even when making drastic changes such as changing the point size of the body text.

First, though, things like having an 8-core processor make no difference since as you mention, InDesign is not able to use more than a single core.

Have a huge amount of RAM also doesn't really make a difference. A 90-page all-text book such as yours isn't going to be needing more than 1 or 2 GB.

Changing the display performance is also not particularly meaningful despite the prominence it gets in the UI and Preferences. High-quality display can cause a small redrawing lag.

So, what are things to avoid? You didn't show us in the video anything but a single page of the file, so here's a general list. But it's always going to be a question of how the document is constructed:

(1) Avoid a single long story with loads of footnotes that is not divided into smaller parts. Are all the 90 pages a single chapter?

(2) Do you use the span/split columns feature? This can be really slow, and is best turned on only as a final stage when there are hardly any more changes to make.

(4) Columns. Are any text frames set to multiple columns? Multiple columns in combination with vertical justification can also cause a slow down.

(5) How did you import the text in InDesign. Depending on the source, there can sometimes be really weird hidden formatting that slows things down (for instance, RTL and LTR markings on every single space, for those working in RTL contexts). So did you clear all overrides throughout the document at some stage to make sure to get rid of this?

Just a few suggestions. It's a question of knowing the strengths and weaknesses of the tool and avoiding the weaknesses.

Ariel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2019 Mar 05, 2019

Copy link to clipboard

Copied

I have exactly the same problem, only I am just working on a 690 x 120 px webbanner!

I even reinstalled the app with the "delete all prefs" option, and the problems persists.

Mac OS 10.14.3. Indesign 14.01. iMac 27" with a 3.5 Ghz i7 and NVIDIA GeForce GTX 775M 2048 MB graphics.

That should be plenty!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 06, 2019 Mar 06, 2019

Copy link to clipboard

Copied

Hi John,

Sorry to hear about this issue. Please check how the application works in the Root account(How to enable the root user on your Mac or change your root password - Apple Support )? Is the issue related to a specific document(s)/asset(s)? If yes, can you please share the document(s) /asset(s) with us?

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

Same problems for two weeks : Indesign is very slow to reaction. I click on item (texte, image, guid,… or the interface element) and indesign freeze, the beachball turn 20-30 seconds and indesign is deblocked… for many few second and freeze again !!!!
It's very inaceptable, unusable and frustrating !
Same problem on five machines (iMac Late 2015 - High Sierra and Mojave).
Five designer multiplyed by many unproductive time !!!!

I test all solutions:

  • uninstall Rightfont, Skyfont, Unactivate all font on Font Book,
  • CPU or GPU switch,
  • uninstall indesign,
  • remove all pref,
  • empty cache,
  • launched OnyX and clean OS,
  • repare authorisation,
  • uninstall fully all CC App (with ACC Cleaner Tool)…

Other single convergence, our network.
I unplugged the NAS SMB (v1 and v2) and indesign has become usable again !

Are reconnect my NAS via AFP and is OK.

I specify, indesign did not call file on the network, the work and the linked files are local.

Regards,

André

Config :

iMac Late 2015 4 GHz Intel Core i7 + 32 Go 1867 MHz DDR3 + AMD Radeon R9 M390 2048 Mo

High Sierra/ and Mojave

Adobe CC 2019 (indesign 14.0.1)

NAS SMB support 1 and 2

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

ERRATUM :

The AFP connection to the NAS finally causes the same problems.

My NAS infos :

QTS TS-651 version: 4.3.6.0883 (2019/03/16)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 04, 2019 Apr 04, 2019

Copy link to clipboard

Copied

Hello,

After many weeks of frustration and troubleshooting, I found the problem on my end was caused by one of the options in Document Footnote Settings, which is “Span Footnotes across Columns.” This setting makes the page layout much more complex and Is apparently poorly implemented by Adobe. For me and many others, it causes Indesign to come to a halt when working on books with a good number of footnotes (my document had 200+.)

If you are experiencing the same issue, try turning it off and see what happens.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

LATEST

This problem persists. Anyone have an idea how to have a workable footnotes function that allows one to have footnotes span without having to wait for aeons each time you make a change? 🥺

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines