InDesign CC 9.2 - New Hyperlinks panel - Unresponsive, Slow, Crash

Participant ,
Feb 17, 2014 Feb 17, 2014

Copy link to clipboard

Copied

Hello,

Theoretically the new Hyperlink panel is a good improvement. However, I work with files with several hundreds hyperlinks. Once I open the Hyperlinks panel in such a file, the InDesign program stops responding. I suspect the Hyperlink Check Service (to see if hyperlinks are active) is way too slow and does not scale well. Bug report is sent, but I wanted to know if anyone has the same problem.

This process should be a background process. It is not acceptable that the whole program becomes unresponsive because of a single-core being busy.

Sometimes the result of the check is faulty as well. The icon shows red, even if the hyperlink clearly works. This happens if the link does not end with a / in InDesign but it comes back like that in the browser, for example.

Thanks for reading and I hope this gets fixed soon.

Views

14.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 100 Replies 100
Participant ,
Feb 19, 2014 Feb 19, 2014

Copy link to clipboard

Copied

Any ideas?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 19, 2014 Feb 19, 2014

Copy link to clipboard

Copied

Can you give us some of the hyperlinks for which it is showing red but the hyperlink is actually working.

Regarding the slow performance issue we regret that you are facing the issue. We are aware of one such issue and are currently working on it. The bug that we are aware of is typically for hyperlinks which have there destinations in other InDesign files, InDesign apparently opens these files in the background to check for the statuses which causes this delay. If you had these files opened it would work faster.

If you are sure that you dont have any hyperlinks which refer to Hyperlink destinations in other documents can you please let us know the approximate number of hyperlinks that you have in the document.

We would like to further investigate the issue and your help will be most appreciated.

Thanks

Javed

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 19, 2014 Feb 19, 2014

Copy link to clipboard

Copied

Some hyperlinks that end with / are not recognized.

The performance is a problem when the checking is running. I think it should run in the background. This is how many hyperlinks I have:

Unbenanntes Bild.png

Quite a lot.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 19, 2014 Feb 19, 2014

Copy link to clipboard

Copied

Hi Aloof,

Thanks for sharing the screenshot with us. Based on your screenshot i created a document having more than 1000 URLs i did see some red lights for the URLs though the URLs were active, thats one issue we are investigating.

I did not though face any performance issue.

It would be really helpful if you can share the file you are facing the issue in with us.

Please send the same to sharewithid@adobe.com , also please mention the platform you are working on and a brief of the problem, and please write in forJaved in the title.

Thanks

Javed

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 26, 2014 Mar 26, 2014

Copy link to clipboard

Copied

Hey I wanted to let you know that the problem still persists after the newest InDesign update. Your collegues did not respond at any point to the issue at hand. They say it works, that's it. Meanwhile I can't work on my document because InDesign is simply unresponsive. The whole auto-checking process completely clogs InDesign! Make it a background process finally.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 26, 2014 Mar 26, 2014

Copy link to clipboard

Copied

The issue is with the auto-checking issue. It really clogs the program completely. It takes more than thirty minutes to check the status of the links here. Meanwhile the program is unresponsive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 26, 2014 Mar 26, 2014

Copy link to clipboard

Copied

Hi Aloof,

In this update 9.2.1 we fixed a few crash issues with the hyperlinks panel.

There is one issue where the hyperlink panel gets slow when the destinations are on other documents which we are aware of which is not yet fixed and we are working on it.

I tried creating many urls as you had mentioned but was unable to get the issue.

It would be nice if you could share the document you are facing the issue in with us via the mail

sharewithid@adobe.com

Thanks

Javed

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2014 Apr 29, 2014

Copy link to clipboard

Copied

I am experiencing a similar problem, but in my case the program CC 9.2.1 not only stops functioning completely if the hyperlinks panel is open, it also seems to have created hundreds of false hyperlinks with names like .4621.1

Force Quit is the only way out.

Clearly there's a major problem here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 30, 2014 Apr 30, 2014

Copy link to clipboard

Copied

@Ariacat – hmm. I would not call them "false".

Hyperlinks with names like ".4621" (a dot at the start of the name) indicate, that they are part of a Table of Contents (TOC).

Every time you are building an automatic TOC hyperlinks with names like this are generated and present in the document.

However, usually they are set to invisible and hidden and should not be listed in the Hyperlinks Panel.

Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 20, 2014 May 20, 2014

Copy link to clipboard

Copied

Mohammad,

It is true that the .6821 etc. hyperlinks are from a TOC, but they should NOT be invisible in the hyperlinks panel. It seems the larger overall problem here may have to do with ID trying to verify the links, but it can take minutes to alter even one link. Something is definitely VERY wrong here and has rendered the program unusable for any project that includes hyperlinks. I have returned to CS6. It would be nice to get an official response from Adobe on when this will be addressed. I'm paying rent to Adobe to have working software, and the plumber needs to be called NOW. I will be contacting customer support to request a refund for every month this continues to render the program entirely unusable. Obviously, I'm not the only one experiencing problems with the hyperlinks, and I encourage them to do the same.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2016 Jan 11, 2016

Copy link to clipboard

Copied

I updated INDD at work on Thursday and on Friday encountered this problem. So not finding a solution, I've asked IT to downgrade me this morning. However, I thought you all should know that over the weekend I worked on my file on my home computer which is also running INDD CC and did not have the problem. So maybe it's got something to do with running on a network? I have no idea, but something for you to think about.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 01, 2014 May 01, 2014

Copy link to clipboard

Copied

I ran into this problem today. When the hyperlinks panel is opened, everything slows down. It used to take me about 2 hours to insert the links into my publication. Today I spent over 5 hours doing it. Mostly looking at a spinning pinwheel or watching a column of text slowly re-render. Thanks for the lesson in patience, Abode. Hopefully it gets resolved soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 18, 2017 Apr 18, 2017

Copy link to clipboard

Copied

Same here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 07, 2014 May 07, 2014

Copy link to clipboard

Copied

I am having the same exact issue. I timed it... it took 34 minutes to create a new hyperlink.

I've been (happily) using this version for a few weeks and this just started happening yesterday.

Apparently I already have the latest update (9.2.1).

I'm on a deadline and can not work this way... !!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2014 May 25, 2014

Copy link to clipboard

Copied

I am also experiencing this issue (InDesign effectively crashes when I try to insert a hyperlink) ad I have the latest version/update. I am working on a document that had existing hyperlinks and there were only about 30 max. So if it is doing 'background checks' surely it shouldn't take that long?? But I really think it's just a bug and isn't working, rather than 'doing' something.

Is there a resolution to this yet? It renders the whole program unusable 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 04, 2014 Jun 04, 2014

Copy link to clipboard

Copied

I am also having this problem with Indesign CC 9.2.1. Has anyone found a solution or workaround?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 04, 2014 Jun 04, 2014

Copy link to clipboard

Copied

I finally deleted and re-installed the program. Now it’s working just fine…

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 04, 2014 Jun 04, 2014

Copy link to clipboard

Copied

Thanks. That seemed to work for now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 05, 2014 Jun 05, 2014

Copy link to clipboard

Copied

The re-install was short lived fix. I am back to the same spinning pinwheel and an unresponsive Indesign application.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 03, 2014 Jul 03, 2014

Copy link to clipboard

Copied

Same problem for me in InDesign CC 2014. Infuriating.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jul 03, 2014 Jul 03, 2014

Copy link to clipboard

Copied

I have not experienced this problem with cc2014. I did start with a fresh set of preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 04, 2014 Jul 04, 2014

Copy link to clipboard

Copied

Exact same problem, and yes, very frustrating. I have 50 chapters in my book, and this problem appears in two of the chapters.  One of the chapters that has the most hyperlinks (about 100, 40 to external URL, 60 text anchors) is unresponsive, one with about the same number is fine.  I am "stuck" until this is fixed. Bad problem to have.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 04, 2014 Jul 04, 2014

Copy link to clipboard

Copied

I assume you're using CC 2014 too? joev said he didn't have it with the new version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 04, 2014 Jul 04, 2014

Copy link to clipboard

Copied

Yes, I am running CC 2014 9.2.2...

I had no problems with the identical files with the previous (non-cloud) version of InDesign.  I rebooted my computer, tried to load that one chapter, and at this point it will take hours, if it loads at all.  It appears to be checking each link--so far I have three greens, but two reds to my external hyperlinks.  I'd place a bet that the reds aren't really reds, that it is an issue with InDesign.  I have another chapter with about two-thirds of the hyperlinks, it "crawls" but it does work.  One other chapter approximates the one that has the problem, but it runs fine.  The other 48, each with 50-100 hyperlinks, work as expected.

This is the first time I've had (major) problems with an Adobe product.  Would it help the cause if I open a service ticket with Adobe, or is this already under review?  Thanks...                                        

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines