Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


InDesign CC2018 Hyperlink Issues

Community Beginner ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

Is anyone else having issues with the hyperlinks menu? When using the "convert urls to hyperlinks" function, it comes back with 0 hyperlinks found (when there are many), and when it does find them, it now includes punctuation. Additionally, it seems to lose a chunk of the functionality when you close the document, even after being saved. This is all stuff that worked correctly with previous versions. I have the same issues on my work computer (Windows) and my home system (Apple). Can anyone assist? It's getting to be ridiculous to go through each URL one by one when there are docs with hundreds. Thank you!

Views

471

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Oct 26, 2018 Oct 26, 2018
As far as I know, this is not a known issue. Try uninstall / reinstall InDesign using the Adobe CC Cleaner Tool. Use the Creative Cloud Cleaner Tool to solve installation problems Alternatively, you might try deleting the cache files first. Some people have been able to fix problems by deleting the cache files.On Mac, close InDesign. Go to the User Library folder in which InDesign's cache files are stored. It may be a hidden file. The path is normally User > Home folder (looks like a little hous...

Likes

Translate

Translate
Adobe Community Professional ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

I'm not able to reproduce this issue in InDesign CC 2018 or in InDesign CC 2019.

Are the URLs showing up in the Hyperlinks panel?

You could try resetting preferences Set preferences in Adobe InDesign and if that doesn't work you may need to reinstall InDesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

The URLs show up. It's happening in two totally different environments, on two independent systems. It's also happening with a coworker. It's mostly with the "Convert URLs to Hyperlinks" function. If the URL is included at the end of a sentence (i.e with a period at the end, like http://www.google.com.) it includes the period at the end as part of the hyperlink. I then have to go in manually and fix the issue. It also freezes up consistently when using the hyperlink functions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

I tried the command again with InDesign CC 2018, using your tip that it happens when the URL is at the end of a sentence and followed by a period.

I still can't reproduce the issue. It is working fine on my computer.

What happens if you click the green dot in the Hyperlinks panel to test the hyperlink -- does it go to the correct URL destination?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

When I click on the dot next to the hyperlink, it does not go to the correct URL. It includes the punctuation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

On my computer, InDesign CC 2018 is not including the period at the end of a sentence when creating a hyperlink. I'm using InDesign 13.1. Make sure you have the 13.1 update installed (under the Help menu choose About InDesign). If you don't, then launch the Creative Cloud app. One way is to choose Updates from the Help menu. If you already have 13.1, then try deleting preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

Both systems are running 13.1. I removed the preferences from the Mac, which seems to have fixed the program's inability to find links, but the punctuation is still being included.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

As far as I know, this is not a known issue. Try uninstall / reinstall InDesign using the Adobe CC Cleaner Tool.

Use the Creative Cloud Cleaner Tool to solve installation problems

Alternatively, you might try deleting the cache files first. Some people have been able to fix problems by deleting the cache files.

On Mac, close InDesign. Go to the User Library folder in which InDesign's cache files are stored. It may be a hidden file. The path is normally User > Home folder (looks like a little house). Select the Home folder. Press down the Option key and choose Library from the Finder Go menu. Library should appear in the Home folder. Inside the Library folder find the Caches folder. Inside the Caches folder find the Adobe InDesign folder and delete it.

The cashes files are usually also hidden on Windows. Go to the Control Panel and open Folder Options and click on the VIew tab. Select Show Hidden Files and Folders  in advanced settings. Delete the folder at the end of the path C:\Users\[User Name]\AppData\Local\Adobe\InDesign\Version [#]\<Language>\Cache.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Thanks, Barbara. Reinstalling seems to have fixed the home computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

I'm glad you were able to fix it on your home computer. Any luck with the Windows computer?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

LATEST

I have the same issue on:

InDesign 16.4x64 Windows 10.

 

There's other threads with many more people experiencing this issue. The answer from Adobe cannot be reinstall each time! That takes a while to set things up again after  - good luck explaining that to my client, or do I sacrifice my evening because Adobe won't fix the bug in software that costs hundreds each year?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines