Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Indesign changes my keyboard input language

New Here ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

Hi. I have a text box that has two paragraphs - one in english and one in hebrew:

alonemanuel_1-1635678371575.png

 

When the caret goes over the text* in English, it changes my keyboard input to English, and when I go to the text in Hebrew, it changes it to Hebrew.

 

* to be more accurate, when I place the caret somewhere in the English/Hebrew paragraph, it doesn't change my input language. Only when I move the caret (with the arrow keys, for example) it will then change the input language.

 

All these changes are a burden and make my work extremely slow, and I've never seen an app that changes your input language for you.

 

I haven't found any info on this issue, so I wonder if it's a bug.

I'm using Indesign 2022 on my Windows 11 laptop.

 

Thanks!

 

 

TOPICS
Bug, Type

Views

45

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about your experience. Do you see this behavior in a specific document? Have you tried resetting preferences of the app? if not, please try that and let us know if it helps.

This information would help us assist you accordingly. Looking forward to your response.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Hi, thanks for the reply!
I have tried resetting the settings and it still occurs.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

LATEST

I don't know if it's a bug, so much as an expectation.

 

InDesign expects if you want to add/change/edit English text that you'd likely want to do that with English characters. I suspect it has the same expectations for altering/adjusting Hebrew text with Hebrew characters.

 

The workaround I've used when working with multiple languages is to assume the language I'll get from the start of a paragraph will associate with that given language, and remain that way until I hit the return for the next paragraph. While I haven't created English/Hebrew documents, I have done so for English/French, English/Spanish and English/German documents. And that when I first create/click into a text frame or hit the return for the next paragraph, it will use the language version assigned to the InDesign installation.

 

When InDesign provides the wrong answer for my needs, I just copy/paste a text fragment from my document with the language characters I want, then highlight it and replace it with fresh text for my chosen language.

 

This may not be the most elegant solution, but it works for me. Hopefully it will be helpful for you too.

 

Good luck,

 

Randy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines