InDesign creating overset type for every hard return

Community Beginner ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

Version: most current, 16.2.1

System: 2020 iMac, OS Big Sur (latest)

 

I'm an experienced Illustrator user trying to learn InDesign, and something is going wrong with text importing. Using File --> Place, any document I import creates overset type with every hard return (paragraph break). 

 

I've tried multiple file types to import (Word, InCopy, Rich Text). I created secondary files that I typed myself to ensure that special characters weren't causing it. Based on another thread, I confirmed that it's not a colum break or other special character causing the overset type - it is any hard return as typed directly from my keyboard. 

 

I tried importing these same files into Illustrator, with no issues. If I cut the copy from the original documents and paste it into InDesign, it works - the issue occurs when using File --> Place. 

 

The attached screenshot just shows that paragraph breaks cause overset type, while column breaks don't. Maybe this is a simple newbie issue, but I sure can't figure it out. Thanks in advance for any advice.

 

1.png

TOPICS
How to, Type

Views

53

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 13, 2021 Jul 13, 2021
It's best to use InDesign Paragraph (and Character) Styles to format text.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

There is a difference between the Enter key on the number pad (column / frame break) and the Enter key on the main keyboard. I'm guessing you're using the former and not the latter.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

Sorry, I should have specified this better in my post. 

 

I'm using a standard Apple keyboard without a number pad (there is only one return key). This is creating paragraph break characters when the text is viewed in story editor. 

 

Oddly, if I create column break characters manually, these do not cause the overset type issue. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

It's best to use InDesign Paragraph (and Character) Styles to format text.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

LATEST

Thank you - I knew I had to be overlooking something, and this solved it.

 

For anyone pulling this thread up in the future, based on this I checked my paragraph styles panel. InDesign was importing some sort of custom style (labeled Body). When I switched the frame to the default style, Basic Paragraph, it solved the issue and the document is good to go for me to build my own styles and format everything. 

 

Thank you very much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

Hi davey5FB9,

hard to tell what's going on without looking into the InDesign document.

 

Could you provide a sample document with one text frame only with the overset?

Just 10 lines before the overset and 10 lines of text that is actually overset.

 

Put it on Dropbox or a similar service and share the download link.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

I embedded your screen shot into the text so that people don't have to open it to see it. 

 

You do have a hard return character ¶ above the overset text, but all of the ingredients are a single paragraph—see the line break character at the end of every line? Check your Keep Options—you must have something enabled that is telling InDesign that if all the ingredients don't fit, go to the next page or column (i.e., Keep lines together). You could also just change those line breaks to returns by searching for ^n and replacing with ^p.

 

~Barb 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

quote

Using File --> Place, any document I import creates overset type


By @davey5FB9

Do you mean overset text? Overset text is when your text box is too small to hold the text. But a frame break can be also forced in the paragraph styles (start a paragraph in a new frame).

Abambo_0-1626203520151.png

If you close the story editor and look at the text frame, you see that + sign, showing that there is more text than the frame can hold. You may expand your frame, or you may direct your text into a new frame, depending on what you want/need to do.

 

See here: https://creativepro.com/tips-fixing-overset-text/

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 13, 2021 Jul 13, 2021

Copy link to clipboard

Copied

@davey5FB9 As others have suggested, you need to use paragraph returns after each ingredient instead of a forced line break, and then set your paragraph styles to the line spacing you desire. (I also note that you need another paragraph return before the ingredient 1/2 cup coconut milk which is run on to the coconut cream.) You can use find/replace to change the marks quickly. Also check the other settings in your paragraph style keep options and the text box alignment settings (try top first). Finally, if you are getting the overset text mark but there is no text to set or the text loading is a repeat of what has already been set (i.e., the load place cursor is overloaded so to speak), then try saving your document as an .idml document, open that and resave to .indd to see if it clears the overset. Let us know if any of these solutions help!

 

JainLemos_0-1626203452276.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines