Indesign Explorer File Icon MISSING

New Here ,
Feb 25, 2022 Feb 25, 2022

Copy link to clipboard

Copied

Hi All, I'm on a new machine and recently installed CC. The problem is Windows Explorer any indesign.indd file is missing the Indesign Icon, instead showing a generic white document. Files for all the other Adobe apps are fine. I've tried:

  1. Re-associating .indd files with something else and then back to InDesign
  2. Uninstall / reinstall InDesign
  3. Delete the windows icon cache "C:\Users\username\AppData\Local\IconCache.db"
  4. Renaming "C:\Program Files\Common Files\Adobe\Shell\CC.2022\icons.dll (& idicons.dll) to icons.dll.bak etc. But can't seem to find an alternative version to replace them with and it didn't make any difference anyway.

    Any ideas? This is annoying because it makes it harder to spot when you're looking for an InDesign file.
TOPICS
Bug

Views

129

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

Thanks for the suggestion. But it didn't work sadly. My registry entries didn't look the same as the one's Anshul shows, as I had a = InDesign.exe, plus the others two I'd tried, b = acrobat, c = notepad etc. Then MRUList = abc (i.e. look for InDesign first). As there was nothing else to try I deleted a, b, c and MRUList and restarted. This obviously didn't fix anything, but I then reassoiciated .indd (Open With / Always) to InDesign. Now the registry looks like this:

Andyred3d_0-1645889990813.png

But still the file icons are blank rectangle for .indd files...

Any other ideas?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

Nope. I gave up.

I'll live with it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

Also I don't have a registry entry for .idml only .indd

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

@Andyred3d No reg entry for .idml? In Windows Settings, under "Choose default apps by file type," if you scroll down to .idml, what does it show? Can you open and save an .idml document successfully with InDesign?

 

JainLemos_1-1645909820647.png

JainLemos_2-1645910136302.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2022 Feb 28, 2022

Copy link to clipboard

Copied

Well this is the weird thing. I swear that .idml wasn't in the list... But now when I look it is. I wonder if by checking the file association, it caused Windows to create the registry entry.

So the other odd thing is it does know that .idml is associated with InDesign...

Andyred3d_0-1646053955207.png

But this isn't in the registry entry (which just has the blank "Default" key):

Andyred3d_1-1646054345630.png

 

This is also the same for Photoshop. And even stranger there isn't an entry for .AI, although both .PSD's and .AI's show the correct file icons.

Andyred3d_2-1646054535667.png

 

I don't know if this is relevant, but this is brand new computer (I have installed Illustrator but I haven't opened an .AI file yet) and is running Windows 11 (build 22000.527).

I wonder if Windows 11 handles this is in a slightly different way, that these file associations are stored in a different bit of the registry?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 28, 2022 Feb 28, 2022

Copy link to clipboard

Copied

Sure, it could be Windows 11. But I had a similar problem with icons not sticking awhile back using Windows 10. I wouldn't worry about the reg entry too much if your icons are now appearing correctly. If you can open and close an .idml document, that's all that's needed. What you might want to do is tell Windows you want ID to open that file extension always. I know it doesn't always “stick” but it's worth trying again. I kept at it and eventually it submitted.

 

JainLemos_0-1646073616331.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2022 Feb 28, 2022

Copy link to clipboard

Copied

Hi Jain, thanks - it's the .indd, not the .idml that is the problem, as we don't use .idml very often.

I originally mentioned it as replying to the instructions provided in another post that said I should look for the .indd and the .idml entries and I just commented that I didn't even have an .idml entry.

My .indd icon still isn't working. Windows knows what file it is correctly, but won't show the icon. Wierdly, as per the instructions in Ansul's post (he's an Adobe employee), .indd is set correctly in the registry, but doesn't work. Whereas the .PSD and .AI are not set correctly (they have no link to their .exe files) but they are both working... "Blimey governor, it's all flamin' topsy turvey with no sense to any of it!"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 28, 2022 Feb 28, 2022

Copy link to clipboard

Copied

LATEST

Blimey, all! Okay, I just thought it was strange when you said there was no .idml reg entry. Did you look on any Windows 11 boards for instructions on how to rebuild your icon cache? It's done with the CMD / Run as Administrator method. That does take time if you have a lot of programs, so plan for that. Not sure what else is going to work. But I did have the problem as well, and eventually the icon started showing up. It might have been when I updated to the next version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines