InDesign ignores Mac application switcher

New Here ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Hi all,

 

I’m having constant issues bringing InDesign to focus on my Mac running Big Sur - now with InDesign version 2022 but the last few versions, same.
 
When I use command-tab to invoke the Mac application switcher, InDesign won’t come to the front. All the other apps do respond as expected.
 
When I click on InDesign on my Dock, sometimes the InDesign menus appear at the top of the screen but the already-opened document does not come to the front. Sometimes InDesign completely ignores the click. Sometimes I have to click a document window of another application, or click on my desktop, then click back into a visible part of an open InDesign document to bring it to focus. Sometimes I have to invoke Mission Control to get back to my open InDesign document(s).
 
None of this is a hard stop, but it’s incredibly annoying.
 
Any fixes?
 
Paul Wilson
 
TOPICS
Bug , Performance

Views

32

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Sounds like the OS isn't responding rather than InDesign.

I don't know if this helps you
https://apple.stackexchange.com/questions/408063/big-sur-unable-to-focus-any-app-or-make-mouse-keybo...

 

It seems to be related to the Touch ID sensor.

 

Or I'm wondering now if it's something to do with InDesign Preferences>Interface 

Maybe turn off Enable MutliTouch Gestures

 

And see if setting the UI scaling to small or large makes a differences.

 

For InDesign you could try

 

There's a few fixes you could try that I have saved for situations like this

 

----

Try resetting your preferences:
The easiest way to reset everything is to delete the InDesign preferences: as soon as InDesign starts to boot hold down Shift, Alt, Ctrl (and Apple/Cmd if working on a Macintosh). A dialog will appear asking to delete the InDesign Preferences, select 'Yes' on this dialog.
Further info and instructions here if needed:
https://helpx.adobe.com/in/indesign/kb/indesign-preferences-support-file-locations.html

 

 

---

Reinstalling rarely fixes everything - you can do a complete reinstall using the
Creative Cloud Cleaner Tool https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

 

--

Try turning off the GPU Performance in the InDesign settings.

See if that helps

 

 

-----------------------

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

LATEST

Have you updated to 17.1? I don't know if that will fix it but it's worth a try.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines