InDesign indexing driving me crazy

New Here ,
Jan 17, 2022 Jan 17, 2022

Copy link to clipboard

Copied

I am so frustrated and disgusted with the indexing feature of InDesign. When creating a reference, the default type is Current Page. If I click on Add All and done I see a list of each individual page the reference is on with a comma between each page number. If is select any other type, the reference the individual page numbers have been replaced by a range of pages which is not what what I want.
Also, using the keyboard shortcut to format names last name first does the same thing. 
And forget about trying to italicize anything in the index. When the index is regenerated they go away. 

TOPICS
Feature request , How to , Performance

Views

236

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Adobe Community Professional , Jan 18, 2022 Jan 18, 2022
Hi @HeathenHarper: Let's start with the italics. When you add an entry, add a delimiter around the text you want in italics. Following the other thread, I typed in <i> in front of Empire and </i> after before adding the reference.  When you update the index, the codes will wrap around the word as you see below. Now you want to italicize the content and hide the codes. Create two character styles: Emphasis: set to Italics and Hidden: set to type size 0.1pt and Color None. (There are oth...

Likes

Translate

Translate
Adobe Community Professional , Jan 18, 2022 Jan 18, 2022
Ok, @HeathenHarper: Last question. (BTW, we highly recommend one question per post because it is easier for us to follow, for you to follow, and for others who need the same answer to locate it without having to dig through other things.) One problem I’m having is with proper names, formatted last name, first name. Let’s say the name is Mary Smith. If I put her in as a reference and click the Add All button I get all the pages on which her name appears throughout the book. If I highlight her n...

Likes

Translate

Translate
Adobe Community Professional , Jan 19, 2022 Jan 19, 2022
Hi @HeathenHarper: I can't tell from here, but probably. You will have to double check the markers in story editor view. Or save as, remove and test. If it fails, restore and then check the markers.  ~Barb

Likes

Translate

Translate
Adobe Community Professional ,
Jan 17, 2022 Jan 17, 2022

Copy link to clipboard

Copied

Hi @HeathenHarper:

 

1. Italics in an index—add markers around the words that need to be italicized and set up a grep style to change them to italics. See https://community.adobe.com/t5/indesign-discussions/making-individual-words-italic-in-index/m-p/8778...

 

2. You don't want pages separated by commas and you don't want page ranges—what do you want?

 

As a general tip, be wary of using the Add All to add every occurrence of a word. For example:

Dogs, 2, 5, 15, 30, 31, 32, 55

 

Consider using subtopics:
Dogs

  Caring for, 2

  Feeding, 5, 15

  Lifespan, 30–32

  Washing, 55

  

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

Thank you for your quick reply.

1. I am attempting to understand the link you have included. It’s unfortunate that the indexing feature is so arcane and poorly documented.

2. In most cases I want the individual pages separated by commas, but I do understand about using subtopics where appropriate.

2b. One problem I’m having is with proper names, formatted last name, first name. Let’s say the name is Mary Smith. If I put her in as a reference and click the Add All button I get all the pages on which her name appears throughout the book. If I highlight her name and use the keyboard command + option + shift + ] the name appears reformatted in the index tab, but it only shows the current page the name is on and there’s no way I know of to get it to show all of the other pages. Is there some way to do this?

Thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

Hi @HeathenHarper:

 

Let's start with the italics. When you add an entry, add a delimiter around the text you want in italics. Following the other thread, I typed in <i> in front of Empire and </i> after before adding the reference. 

 

indez1.png

 

When you update the index, the codes will wrap around the word as you see below.

index2.png

 

Now you want to italicize the content and hide the codes. Create two character styles: Emphasis: set to Italics and Hidden: set to type size 0.1pt and Color None. (There are other variations on Hidden but you can see how those settings look in the my final screen shot.) 

 

Create two GREP styles as shown below on Index Level 1 (or whatever level you are working on):

  • Assign Emphasis to <i>.+?</i>
  • Assign Hidden to </?i>
    index3.png

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

I wish I could say this was working but it isn't. I've been through the process a number of times and it's not happening. Here's a screen shot. The opening <i> disappears, the reference moves to the symbol section, and the closing tag <i/> displays. I'm mystified.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

I'm showing you <i>...</i>. You are showing me <i>... <i/>.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

I caught that and it resolves fixes the italics problem. But now there are two additional ones. The references have moved to the Symbols section and all the commas between the page numbers have disappeared.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

The references have moved to the Symbols section

  • There is a sort column to the right of the top. Add the appropriate letter(s). Update the index.

 

all the commas between the page numbers have disappeared

  • Commas between page numbers are controlled in the Entry Separators in the Generated Index dialog box: Between Page Numbers.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

Thank you for your continued and timely help. The comma separators were actually specified in the Generated Index dialog box. Interestingly, adding the appropriate alphabetical letter to the italicized entries fixed their disappearance. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2022 Jan 22, 2022

Copy link to clipboard

Copied

I thought I was done with this, but I finally have to admit defeat. Thankfully, I saved an earlier version of my document otherwise I'd be hosed. Adding the HTML code for italics around index entries resulted in the commas disappearing between the entry page numbers even though they are specified in the Generated Index dialog box. Deleting the HTML was never able to bring them back. I'll have to find an alternative solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2022 Jan 22, 2022

Copy link to clipboard

Copied

Hi @HeathenHarper:

 

I didn't chose <i>...</i>, that came from the other thread. I just referenced it so that you could follow what was written since it clearly worked for the person asking that day.

 

The concept here is that you can place any character around what you need to be italic: for example *italicize what is inside* and then use GREP to hide the *s and make the text inside italics. While <i>...</i> happens to be the old 1990-era HTML code for italics (these days we use classes), that wasn't adding any HTML. It was simply marking the beginning and end of the italics.

 

Commas between numbers are controlled by the Update Index dialog box, unless perhaps you have a typo in your GREP that is inadvertently hiding them. You can see both the italics and the commas in my screen shot, above. 

 

~Barb

 

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2022 Jan 22, 2022

Copy link to clipboard

Copied

I don't see an "Update Index dialog box" anywhere. The index panel has a Generate Index option which contains a check box for replacing the current index and a second option to Update preview. Would you please clarify? Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2022 Jan 22, 2022

Copy link to clipboard

Copied

LATEST

My apologies. I was answering  on my phone. The generate index dialog box is where you go to update the index. They are the same place.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

On to the second question, but I need clarification. 

 

First you said:

I see a list of each individual page the reference is on with a comma between each page number.

Then you just said:

In most cases I want the individual pages separated by commas

 

Isn't that what you said you are getting? Screenshots go along way and helping us understand a problem. 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

Yes, that's what I'm saying.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

@HeathenHarper, I can likely help but I need screen shots. You seem to be saying you "see a comma between each page number" and also "you want the pages [page numbers?] separated by commas". I don't understand what you need here.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

Ok, @HeathenHarper:

 

Last question. (BTW, we highly recommend one question per post because it is easier for us to follow, for you to follow, and for others who need the same answer to locate it without having to dig through other things.)

One problem I’m having is with proper names, formatted last name, first name. Let’s say the name is Mary Smith. If I put her in as a reference and click the Add All button I get all the pages on which her name appears throughout the book. If I highlight her name and use the keyboard command + option + shift + ] the name appears reformatted in the index tab, but it only shows the current page the name is on and there’s no way I know of to get it to show all of the other pages. Is there some way to do this?

I think you are asking to reformat Mary Smith to Smith, Mary and locate all occurrences with the Add All button? Is that correct?

 

From the online help (emphasis mine):

For proper names that you want indexed by the last name, press Shift+Alt+Ctrl+] (Windows) or Shift+Option+Command+] (Mac OS).

An index marker using the default settings is added at the beginning of the selection or to the beginning of each item selected. 

Translation: this shortcut only indexes that single occurrence. 

 

Use copy/paste as the workaround:

  1. Use your shortcut to index the first occurrence of Mary Smith as Smith, Mary.
  2. Edit > Story Editor
  3. Select and copy the index marker and the words Mary Smith to the clipboard
    index5.png
  4. Edit > Find/Change
  5. Find: Mary Smith
        Change: ^c
  6. Change All, but make sure you don't get two markers in front of the first occurrence. If you do, just delete one in Story Editor.
  7. Update the index.
    index6.png

 

^c is the metacharacter in a Text F/C for pasting the contents of the clipboard with formatting (remember, you copied the marker along with the words Mary Smith), so this is pasting the correct marker in front of all occurrences of Smith, Mary. 
index4.png

 

Finally, I totally understand your frustration with InDesign's indexing. Lots of InDesign features have been improved over the years, but indexing has largely remained the same from the beginning and I agree that it could use some love.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Okay, I now have the name reformatted as Smith, Mary. In my index I'm seeing both Mary Smith and Smith, Mary. Is it safe for me to eliminate the Mary Smith reference?

 

Thanks again for all your help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Hi @HeathenHarper:

 

I can't tell from here, but probably. You will have to double check the markers in story editor view. Or save as, remove and test. If it fails, restore and then check the markers. 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

While these workarounds do work after a fashion, they are also causing frequent crashes of the application. The book I'm working on is 180 pages and there are over 200 entries for the indes. What I expected to be a straightforward feature has become a nightmare.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

I give up. I'm having limited success adding italics and cross-references, but when I try reformatting names with the last name first, the application refuses to save or crashes. At this point the only solution I can come up with is to do as much as InDesign will allow me to do, save the index pages as PDFs, edit them in Acrobat, and eventually replace the index itself with the edited PDFs. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Thoughts on the system crashes:

  1. Be sure your computer exceeds the minimum system requirements
    https://helpx.adobe.com/indesign/system-requirements.html
  2. Make sure InDesign has the current patches installed
  3. Be wary of InDesign on an M1 Mac. There are still issues to work out. 
  4. Break long InDesign files into sections or chapters and pull them back together with a book file. 
  5. When InDesign begins to behave erratically, rebuild the preferences/cache
    https://www.rockymountaintraining.com/adobe-indesign-rebuilding-preferences-cache/
  6. When a file begins to behave erratically, save it as .idml. Close, reopen and resave as .indd.

 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines