Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Indesign not remembering window size (Again)

Participant ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

This seems to be a perennial issue for indesign. When I open the app it opens as large as the screen every time. Then I resize it and sure enough on relaunch its back to full screen. Its not world ending but its super annoying and appeared on the 2022 release.

 

Please fix it.

 

Also when is spell check that thing on computers since 1990 coming to this forum?

TOPICS
Bug

Views

174

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

This is a user forum. We don't have the power to "fix" InDesign programming, as we're end users just like you.

 

We're not without skills to help, though. Given more information, we can come up with a better answer than "Sir, this is an Arby's." Honest.

 

We may be able to offer some assistance with your application window issues, though, if you can let us know what operating system you're using, what version of that operating system that is. There are some tips we may be able to offer that may or may not help you. But on that count, we can try to lend a hand.

 

As for your question about spell checking, I don't fully understand. Spell checking has been built into InDesign since it was introduced in 1999. And it works pretty good, if you ask me.

 

If you'd like to report a bug within InDesign, you can do that by using a form you can get to through this link.

 

This probably wasn't the response you were looking for. But hey — we are willing to help as we can. If you can share more information with us, maybe we can be of assistance.

 

Randy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

Hi @garethirwin1234:

 

You can click the ABC button on the toolbar to identify misspelled words in your posts.

 

~Barb

 

71FA60F6-8121-4A72-A4A2-1D08D22ECD8E.jpeg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

In response to the first part of your question, sizing the window. I assume that you are talking about sizing down the application window with the Application Frame active (Window>Application Frame). Try doing the resizing with no document open and then immediately quitting the program. Setting a preference with no documents open and then quitting will usually "lock-in" a preference as the default when you next launch InDesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

@Bill Silbert I have attempted this suggestion and this did not work. Opening the application regardless of whether or not there is a file being opened causes it to be full screen upon opening. Using the restore window button causes the window to be approximately 3x the size of my monitor which is extremely inconvienient to resize. Opening it without a file, resizing window, and shutting it down did not keep setting when reopened with or without a file. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Let me ask a dirty question: Are you using a laptop that you connect to, or have connected to, an external monitor?

 

If so, I believe I may be able to help you with your problem:

 

  1. Open InDesign on your laptop, without the external monitor connected. You want to be working with your smallest screen you use with your system, and that's generally the one on your laptoip. It will open with the window maximized.
  2. Turn off the maximized setting to make the InDesign application window appear three times too large for your laptop screen.
  3. Mutter and cuss a little (optional step
  4. Generally, by default the upper-left corner of the application window will appear in the top-left corner of the laptop screen. If not, go anywhere you can actually see an edge to the application window. Put your cursor at the corner of the application window to the point where you see the diagonal double-sided arrows which will allow you to adjust the application window size.
  5. Hold the left mouse button down and drag toward the opposite corner of the laptop screen, leaving enough room to be able to grab the title bar for the window. Release the mouse button.
  6. Place your cursor in an empty part of the top of your application window. Hold the left mouse button down and drag the application window up and to the left so the upper left corner of the application window is in the upper-left corner of the laptop screen.
  7. If you still don't see the entire application window, repeat steps 4 through 6 as necessary until you can see the entire application window on the laptop screen. Muttering and cussing is near-mandatory here. Fine tune your application window to appear as you'd like it on your laptop screen.
  8. Leave your InDesign application window open. Shut down your system. Do not select the restart option; shut down your system. If your system asks you to shut down your application windows manually, ignore that. Let the computer shut down all application windows.
  9. Start your computer again. When the desktop appears again, wait a minute or so for everything to start and open correctly. Then open InDesign again. It should now open at the window size you'd like it to be.

 

There is a small downside to this. When you reconnect to the larger external screen, the window will be laptop-small sized. Drag it to the size you'd like it to be on your big screen, remembering to shut down InDesign before you shut down the system. Even if the application window is minimized, InDesign will remember how large the application window size was extended on yoiur big-screen external monitor and you'll have to go through this complete drill all over again. Please don't ask me how I know; the memory is too painful.

 

I believe this will help you, as it may help garethirwin1234, the original poster who sorta described this issue.

 

Hope this helps you both,

 

Randy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Thank you for all this explanation just for indesign to remember where I left it lol. Its not working there is abug somewhere.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I am not sure I follow. All I mean is when I close indesign, when I reopen it, my expectation is it will open with the same size window as when I closed it.

 

It does not do this, it opens to the full size of my screen, each and every time, which is not how I left it. Its persistently an issue. I can only assume some sort of incompatibility with PowerToys or something. Its only indesign no issue with illustrator, photshop etc.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

The Appliction Frame bounds are remembered, but I think that is an OSX only feature:

 

https://helpx.adobe.com/creative-suite/kb/troubleshoot-application-frame-document-window.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

InDesign doesn’t save the layout window position, but its bounds can be scripted.

 

This script would set the upper left corner x, y position to 50 pixels, and the width would be 75% of the available screen width, and the height would be 90% of the available screen height. It would also be possible to add a listener so every document gets positioned on an open event.

 

var hScale = .75
var vScale = .9

var x = 50;
var y = 50;


var sw = $.screens[0].right;
var sh = $.screens[0].bottom;
var w = Math.round ((sw*hScale)-x);
var h = Math.round ((sh*vScale)-y);

app.activeWindow.bounds = [sh-(y+h), x, sh-y, x+w]

 

After running:

 

Screen Shot 16.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

right i feel like I am in a parallel universe here or there is a massive language barrier.

 

1. I open indesign.

2. I make the indesign window the size that I want, lets say for instance half the size of my screen on the left hand side.

3. I do some super indeisgn stuff.

4. I quit indesign.

5. later I relaunch indesign.

6. Indesign is has not remember the laf screen left hand side settings and has reverted to taking over the whole screen,.

7. Goto 1

 

I really dont know how better to explain this, but I can tell you this 100% it should not and does not require a script.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Oh my god, this crap forum does not even allow editing of posts! Adobem, get it together really!

right i feel like I am in a parallel universe here or there is a massive language barrier.

 

1. I open indesign.

2. I make the indesign window the size that I want, lets say for instance half the size of my screen on the left hand side.

3. I do some super indeisgn stuff.

4. I quit indesign.

5. later I relaunch indesign.

6. Indesign has not remembered the screen left hand side settings and has reverted to taking over the whole screen,.

7. Goto 1

 

I really dont know how better to explain this, but I can tell you this 100% it should not and does not require a script

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

To edit posts click the more button:

 

Screen Shot 17.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I understand what you want to happen, but InDesign does not save layout window bounds with the document. You can file a feature request.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I simply feel we are not on the same page. I have a HP laptop which at work is hooked up to a seperate monitor. There indisgn opens to the same size from where it left off, Thats windows 10

At home on my main rig just the one screen 49 inch, it does not. Thats windows 10. So something is wrong here. The only differences I can think is I have powertoys on my main rig.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

I’m on OSX with 2 screens, and with the application frame turned off document’s always open fulll screen.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Sorry, I'm a bit late to the conversation, but this has been an issue with InDesign on Windows for ages. It simple does not remember your window layout. It just doesn't; and hasn't for ages. I think it goes back to CS4 or so.

I don't even think about it anymore. I used to find it aggravating but there are so many other things to worry about this just doesn't rate for me. And just so you know, it's no better on Windows 11.

That said, I may start pushing back on this now that there's finally some decent UI scaling for Windows. But it took years of screaming about to get any attention and that one is far more serious than this.

Finally, you could saved yourself some trouble by indicating from the get go that you were on Windows.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

LATEST

Having similar problems with my Windows laptops, especially when external monitors are attached. It's worse than in pre-2021 versions. On one of my laptops, it opens so large that I can't grab any edge of the window resize it. And the window spans 2 or more monitors.

 

Windows' basic KB shortcut to move / resize windows helps: Alt + Spacebar.

 

Not a solution, but helps.

 

Bevi Chagnon | Designer & Technologist for Accessible InDesign + PDFs |
Books & Classes | PubCom

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Just wanted to acknowledge that, yes, it is doing this same thing on my Windows 10 computer, and is not doing this on any of my macOS machines. Yes, it is aggravating, and no I haven't got a clever workaround to it.

Mike Witherell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines