• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

InDesign: Objects from Masterpages can’t be deleted locally

Community Beginner ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

V15.0.2 I’ve noticed a strange behaviour: only on some pages and with some elements i either cannot manually override (Mac; Shift+Command+click) single items at all,

or, when it’s possible, they duplicate and the locked object from the master page stays locked. Unlocking will spawn 10+ items of the same object, the original can’t be deleted.

 

Neither is it locked on the master page, nor is the option "Allow Master item overrides" deactivated, nor is the layer locked.

Reading a bit about this version, i gather it’s a bug. I CAN override ALL items and delete single objects, so it’s only a minor nuisance, but of course in certain situations this can come back to bite you in the ass.

 

Any help appreciated!

cheers

Harry

 

TOPICS
Bug

Views

1.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Sep 27, 2023 Sep 27, 2023

It's not a bug, it's a feature... I'll quote the solution that worked for me, found on another website:

 

"If your master page item is touching the center/gutter line, then it will think that this item is for the left page as well, and so, it will keep the item, even when you Shift+Click to unlock it from the master items.

Solution: Just leave a very slight amount of space (1/32") from the center/gutter line."

Votes

Translate

Translate
Community Expert ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

I have not seen this as a problem. I am working with that InDesign version on a Mac with Mojave and have not run into the trouble that you describe. Have you tried resetting your InDesign preferences to make sure that there is no corruption in your copy of the program?

To do so on a Mac:

The User Library folder in which InDesign’s preferences are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N). With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the folder called Preferences and within it find the folder called “Adobe InDesign” and the file called “com.adobe.InDesign.plist” and delete both that folder and that file. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

The advantage of manually deleting preference files in this manner is that after you’ve reset up the program (make sure that no document window is open) to your liking, you can create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Are you master pages based on a 'mother' Master page maybe? That said, also should not lead to the behaviour you see. Did you try the idml roundtrip?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

I’ve been seeing other posts describing the same problem.

 

Does it happen if you Save As to IDML and then open the saved IDML? If that doesn’t work can you share the file?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

I'm having the same problem. Did you ever find a solution?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

I'm having the same problem. Tried IDML and trashing preferences all to no avail

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2023 Sep 27, 2023

Copy link to clipboard

Copied

It's not a bug, it's a feature... I'll quote the solution that worked for me, found on another website:

 

"If your master page item is touching the center/gutter line, then it will think that this item is for the left page as well, and so, it will keep the item, even when you Shift+Click to unlock it from the master items.

Solution: Just leave a very slight amount of space (1/32") from the center/gutter line."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

LATEST

THANK YOU THIS WORKED!!!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines