• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

indesign publish online cover image not displaying in Facebook

Community Beginner ,
Feb 04, 2018 Feb 04, 2018

Copy link to clipboard

Copied

Hi. I've used the Publish Online capability for many InDesign documents, and this has never happened before. When I choose to share this document on Facebook, instead of the cover image, I get a generic image. Why? I'm not doing anything differently than ever before....

Views

722

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jul 27, 2022 Jul 27, 2022

It finally works on Safari FB debugger, but not on iMessage or other social platforms like linked in etc

 

Also when people share their links with me I'm not able to see the cover image of their links.

Likes

Translate

Translate
Community Expert ,
Feb 04, 2018 Feb 04, 2018

Copy link to clipboard

Copied

Hi Deborah:

What did you select under the Advanced tab for the cover thumbnail?

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2018 Feb 04, 2018

Copy link to clipboard

Copied

I've tried two different things. First, I did my normal selection, which has always worked just fine in the past — just the first page of the document. When that failed to work, I tried a "Chosen Page," and I selected page 1. Neither has worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 04, 2018 Feb 04, 2018

Copy link to clipboard

Copied

Hi Deborah:

That's odd. There is one more option to explore. You could export the first page of the file as a PNG, and then use Choose Image (again in Advanced) to load it.

Now, I'm unclear if this falls in the category, but when InDesign starts behaving erratically, trashing preferences (or the cache) often restores normal behavior.

Troubleshooting 101: Replace, or "trash" your InDesign preferences

CC 2018 InDesign—Don't Import previous settings and preferences

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2018 Feb 05, 2018

Copy link to clipboard

Copied

Yes, perhaps I will try trashing the preferences at some point. In the meantime, I had tried using the Choose Image option, and that does work. Hopefully, trashing the preferences will make it so this extra step isn't necessary. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 05, 2018 Feb 05, 2018

Copy link to clipboard

Copied

Hi Deborah:

A lot of InDesign answers fall into two categories:

  1. can we just make it work to meet a looming deadline, and once the doc is published (and you can breathe again);
  2. can we fix the underlying issue so that this crisis doesn't reoccur.

It sounds like we found a successful workaround for this publication. It would awesome if you could come back and let us know if trashing preferences takes care of it for future publications. I'm not having any issues with the cover image, so I'm hopeful that that will be the fix. And if not, of course, report that as well.

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 20, 2022 Jul 20, 2022

Copy link to clipboard

Copied

I'm having this same issue and choosing an image isn't fixing this. This has been a problem for years, can you guys please prioritize it to be fixed soon?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Hi @danielbhall ,

 

Sorry to hear about the trouble. Could you please share a few more details like:

 

  1. The version of InDesign & OS.
  2. Is this happening with a specific file or multiple files?
  3. Have you tested this on a different browser?
  4. Have you tried restoring preferences as suggested above?
  5. Will it be possible for you to share a sample link where the cover image is not appearing?

 

We're here to help, just need more information.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

1. InDesign 2022 on Mac BigSure v11.6

2. Multiple Files

3. I've tested on multiple sites and browsers

4. Yes I cleared preferences

5. see this link as expame - https://indd.adobe.com/view/1cdca2b8-922c-4544-94f6-7fe078e77962

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 22, 2022 Jul 22, 2022

Copy link to clipboard

Copied

I just shared this to my own FB feed (for my view only) and the preview looks fine, screen shot below.

I'm using Mac OS 11.6 and Safari 15.0.

Could it be a browser issue on your end? Can you try a different configuration?

DianeBurns_0-1658548353011.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

Wow, interesting!

 

But unfortunately still not working for me, I tried the FB debugger in chrome and safari as well as iMessage and it still comes up blank when links outside of indd are working just fine. See attachements for what I see on my end.

 

I too am using Mac OS 11.6 and Safari 15.0.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 25, 2022 Jul 25, 2022

Copy link to clipboard

Copied

So just to be clear, are you seeing the problem in Chrome also?

I just tested in both Firefox and Chrome on my Mac and the preview displays in FB just fine.

Do you have another device/computer you can check it on? 

Here is the Firefox example:

DianeBurns_0-1658785497582.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

LATEST

It finally works on Safari FB debugger, but not on iMessage or other social platforms like linked in etc

 

Also when people share their links with me I'm not able to see the cover image of their links.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines