Indesign pushes last line of paragraph to the next page

New Here ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

I have a book with text pages. The last line of one paragraph is being pushed to the next page, whatever I do (hard return just before, switch off all 'keep options'.

How?

See screenshot.

Thanks!

TOPICS
Bug

Views

108

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Aug 25, 2022 Aug 25, 2022

More advice:

Never use a style from Word named Normal.

Never use a paragraph style based on Normal nor Basic Paragraph Style. Make your BodyCopy style based on No Paragraph Style.

Try not to allow your paragraph style have manual overrides (the tiny + sign) on it. If you have bolds and italics, make sure those are made with character styles.

Subheadings should be their own paragraph style with Space Before and Space After defined, not extra returns.

Likes

Translate

Translate
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Be sure to make a paragraph style to control the paragraphs of text. Name it BodyCopy. Within paragraph style options, go to Keep Options and set it to either keep all lines together or, better, keep lines 2 and 2. This will prevent widowed and orphaned single lines that are alone and away from the rest of the lines in the paragraph.

 

Stop using multiple hard returns to space paragraphs. Instead, within the paragraph style options, define a Space After amount.

 

Stop using the Tab key to indent your first line. Instead, within the paragraph style options, use a First Line Indent amount.

 

InDesign is all about paragraph styles! Learn to let go of your habits of using a typewriter. 

Mike Witherell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Thanks Mike!
I did all that. Still this funny behaviour. leaving a big gap at the end of the column. See screenshot.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Do you have Keep With Next set in the Keep Options menu? Uncheck that. As Mike notes, there are many options to control text flow in this panel and your solution (and eventual satisfaction with the text breaks) probably lies there.

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Your screen grab shows Keep With Next set at 1.

This will definitely cause your issue if all those extra returns also have the same setting; it's trying to keep them all together and consequently pulling your single line from the previous page.

Instead, Set it to 0

(This is NOT controlled by the checkbox immediately above (Keep With Previous); these are two separate settings).

 

But yes, as advised, you should not be using paragraph returns for spacing; causes no end of issues. The more you use Paragraphs Styles, with all the spacing and tab options available, the more it will make sense to you, and you will soon never go back to what I call "typewriter spacing".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

If, after setting up your paragraph style correctly, it still does it, then export to IDML and then open the IDML file, and then SaveAs to an INDD document. This will have a tendency to wash out some possible corruptions.

Mike Witherell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Did not solve it unfortunately.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Could page 11 secretly have an empty no stroke/ no fill frame/box/object  in the lower part of that page? Maybe it is an object on the master page. If there is an invisible frame object, maybe that object has Text Wrap turned on?

Mike Witherell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

My thought, but no.

 

Solved it like this for now: shortened the text frame, created another text frame underneath and let the text flow on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

No! D:

Mike Witherell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Yeah, all humor aside, this is not the way to solve any problem.

 

I'd suggest you back up, create clean styles for all your paragraphs and (bold, italic, etc.) overrides, and apply them scrupulously to your text. You can't get anywhere with corrupted imported styles and layers of spot overrides. You'll "fix" one problem only to have three more show up, and pretty soon your whole document is the equivalent of duct tape and baling wire.

 

Take an hour to clean it all up with clean styles. It will be worth every minute you spend on the chore.

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

More advice:

Never use a style from Word named Normal.

Never use a paragraph style based on Normal nor Basic Paragraph Style. Make your BodyCopy style based on No Paragraph Style.

Try not to allow your paragraph style have manual overrides (the tiny + sign) on it. If you have bolds and italics, make sure those are made with character styles.

Subheadings should be their own paragraph style with Space Before and Space After defined, not extra returns.

Mike Witherell

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

The extra returns caused it! 
I put them in to create space for an inserted image. Other solution for that now.
Thanks for all your suggestions!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

LATEST

I'd bet that the extra returns that were formatted for "keep with next/previous" did it. Paragraphs without "keep with" specified have nothing keeping them from breaking across pages.

 

|| Word & InDesign to Kindle (& EPUB): a Professional Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines