Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


InDesign spellcheck incorrectly flagging capitalization issues

Participant ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

I have a document full of small text frames in which I have created custom hard line breaks for aesthetic reasons. So, for instance, I have:

 

This is an example

of what I have.

 

Above, I have inserted a hard line break after the word "example" in order to start line two with a preposition.

 

When I use spellcheck on this document, InDesign stops at the word "of" seen above... and every other word that I have forced to appear on a new line.  InDesign considers these words to be at the beginning of a new sentence and therefore flags them as requiring capitalization.

 

As a result, the spellcheck of this document takes ages, since 95% of the items caught are not actual spelling errors but rather incorrectly identified capitalization problems.  Is there a way to get spellcheck to ignore these cases where I have purposefully inserted a line break?  I'd like to be able to spellcheck this page inside InDesign.

 

If that's not possible, is there a script that one can suggest for exporting the text?  (That way I could spellcheck it in a program that doesn't assume that manual line breaks signal the start of a new sentence.)

 

Thanks for any ideas.

 

 

TOPICS
Import and export, Type

Views

175

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Feb 11, 2021 Feb 11, 2021
Thanks, John. I see how "shift-enter" will work. However, when I click on "save as" in the "file" menu drop-down, I do not see an option to save as text. The options are document. template & "C4 and later."

Likes

Translate

Translate
Adobe Community Professional ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

That's one of several reasons you shouldn't force line breaks by entering paragraphs. If you enter "forced line breaks" (Shift+Enter) instead, it should solve that problem.

 

You don't need a script for exporting the text; just export and choose Text Only from the Save as type: menu.

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

Thanks, John.

 

I see how "shift-enter" will work. However, when I click on "save as" in the "file" menu drop-down, I do not see an option to save as text. The options are document. template & "C4 and later."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

Right, you won't find Text Only in the Save As dialog; use File > Export.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

The only problem is that when I export, it only exports selected text.  This means I have to go through the document and select all the text frames.  I was hoping for a text export option that would just give me all the text without my having to select it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

I also did find, from a previous related post, that I can set preferences to have spellcheck ignore capitalization of sentences, so that will work for me, tho' I'll want to stop using that feature after finishing with this particular document.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

LATEST

" I was hoping for a text export option that would just give me all the text without my having to select it."

 

You already have a script at hand that exactly does this:

Open the InDesign Scripts panel, navigate to folder Application > Samples > JavaScript > ExportAllStories.jsx

 

From my German InDesign 2021:

ExportAllStories-Sample-1.PNG

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines