• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Is there a way to avoid wrapping in "special" words?

Guide ,
Jan 31, 2024 Jan 31, 2024

Copy link to clipboard

Copied

Hello!

By "special" I mean two situations like these I came across today:

1. At the end of a text line in block set text there is an e-mail address with a two-letter domain, such as .de. I changed it to .com and now it wraps after the dot. The mail address is considered as one word, but not by Indesign. This is also no hyphenation topic, so I couldn't find anything to make the word not wrap, except for tricks like lowering the character width or the tracking.

2. There is a single directory name like TEMP at the beginning of a text. In order to make it clearer that this is a directory, I changed it to \TEMP. Indesign would wrap the backslash into the previous line. This is also not hyphenation.

 

How to avoid the wrapping here? Is there a simple way?

TOPICS
How to

Views

101

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jan 31, 2024 Jan 31, 2024

Select the text (either the email address or \TEMP) and apply “No Break” on it. And better, create a character style with this only attribute.

Votes

Translate

Translate
Community Expert ,
Jan 31, 2024 Jan 31, 2024

Copy link to clipboard

Copied

Select the text (either the email address or \TEMP) and apply “No Break” on it. And better, create a character style with this only attribute.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jan 31, 2024 Jan 31, 2024

Copy link to clipboard

Copied

Ouch! I never really noticed the quick actions menu. I had looked into the Type menu to find nothing like this. As far as I see it, there is also no button in the top button menu (both layers).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2024 Jan 31, 2024

Copy link to clipboard

Copied

I never use the quick actions menu. You can find the “No break” command in the control panel option menu, at the very right end of the control panel.

Capture d’écran 2024-01-31 à 13.21.45.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jan 31, 2024 Jan 31, 2024

Copy link to clipboard

Copied

For me, this is the quick actions menu. 

DocMaik_0-1706705202517.png

The control panel options menu is the one above.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2024 Jan 31, 2024

Copy link to clipboard

Copied

LATEST

Absolutely. This is the one I clicked on.

Capture d’écran 2024-01-31 à 15.08.01.png

You get the “quick actions” menu (but the actual name is “quick apply”) by clicking on the lightning symbol.

Capture d’écran 2024-01-31 à 15.02.56.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines