• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Key = does not work in InDesign.

New Here ,
Sep 07, 2023 Sep 07, 2023

Copy link to clipboard

Copied

Every time I write the words such as " न्न श्व " I want to write a traditional one like " न्‍न, श्‍व " how can this be written ? The key "=" does not seems to work in indesign. Can anyone please help me?

TOPICS
Bug , How to , Type

Views

216

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Sep 15, 2023 Sep 15, 2023

Thanks for all of that additional information! Took me a while to figure it out, but I think I've nailed it. I've installed the Nepali Unicode Romanized input method myself, now. I find that the equal key successfully inserts a zero-width joiner, which looks like it's doing nothing, but it's certainly inserting a ZWJ.

 

जह'.gif

 

Then, I tried to type this combination using a variety of different fonts. However, there isn't a Nepali setting in my Language: dropdown, so I left it in English. It turns ou

...

Votes

Translate

Translate
Community Expert ,
Sep 07, 2023 Sep 07, 2023

Copy link to clipboard

Copied

Can you give us some more information? I don't know enough about typing in Devanagari script to know what is going on in your case, but there aren't that many possibilities.

 

Are you using Windows or Macintosh?

What's the name of the font you are using?

Are you using a standard 101-key Latin-script keyboard to type? 

What's the name of your input method? How do you turn it on?

Does this combination of hardware + software keyboard work to input your desired characters in other apps? (I'm guessing "yes it does")

 

I don't think you are using the default Hindi Inscript keyboard that comes with Windows, because I don't think you'd need the equals key "=" to type the characters you're trying to type. I don't know exactly how you would type it... a न, followed by a virama, followed by... something else? Not another न, because that clearly yields न्न. How would you type these glyphs in other apps?

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 08, 2023 Sep 08, 2023

Copy link to clipboard

Copied

The things you want to type have zero-width joiners; I still don't know why the equals key is part of your post, but if you didn't have a way to type this in your current input method in InDesign, I'd suggest adding a keyboard shortcut to Type -> Insert Special Character -> Other -> Joiner

 

whatuni.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2023 Sep 15, 2023

Copy link to clipboard

Copied

I didn't know about the term 'zero-width joiners.' Thank you.

In my typing layout, the '=' key is used for zero-width joiners. However, there is still a problem. In order to type 'न्‍न,' I have to type 'न,' '्,' 'ZWJ,' and 'न.' If I don't use ZWJ, then it appears as 'न्न,' as you mentioned. However, when I need to type 'न्‍,' I simply go to the Glyphs window.

I am using the Adobe Devanagari font, and my operating system is Windows. My input method is 'Nepali Unicode Romanized Layout.'

Interestingly, there is no problem when using the same layout and font in Adobe Photoshop.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 15, 2023 Sep 15, 2023

Copy link to clipboard

Copied

Thanks for all of that additional information! Took me a while to figure it out, but I think I've nailed it. I've installed the Nepali Unicode Romanized input method myself, now. I find that the equal key successfully inserts a zero-width joiner, which looks like it's doing nothing, but it's certainly inserting a ZWJ.

 

जह'.gif

 

Then, I tried to type this combination using a variety of different fonts. However, there isn't a Nepali setting in my Language: dropdown, so I left it in English. It turns out that some of the OpenType methods your font will rely on to render correctly are language-aware; if you don't pick your language in the Character dropdown, they don't work! There's no Nepali choice in my install of InDesign, so I picked Hindi instead.  In the following animation, note that Nirmala UI immediately changed its rendering of the glyph when I chose Hindi as the language, but I had to rekey it in Adobe Devanagari in order to get it to render correctly. 

 

ये.gif

 

 

It's not unusual for such features to be dependent on the language setting of the host application, especially since many languages that share the same writing system will have different ligature or contextual-alternate behaviors.

 

So I think that the correct answer is: actually, the equals key is working correctly; the problem is that InDesign doesn't have a language setting for Nepali. The workaround is to mark your text with a langauage that InDesign does have in its dropdown, one that supports the glyph-shaping behaviors you need. 

 

Lastly, I've gone over to indesign.uservoice.com (which is where we can make feature requests!) and suggested there that they should add Nepali as a language setting to InDesign. If you add your vote, it increases the likelihood that we'll see this feature added to InDesign.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2023 Sep 16, 2023

Copy link to clipboard

Copied

LATEST

You have solved my problem. I was having so much trouble due to this. Thank you so much.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines