Last used workspace doesn't open with documents

Community Beginner ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

I'm having a problem that comes and goes -- and always after an application update (though not after EVERY application update).

 

I use a custom workspace. When I close and save a document, that workspace is open. But when I open that (or another) document later, the workspace doesn't automatically open / show. It's still available in the menu Window > Workspace, and it opens when I select it there. It just doesn't re-open the next time.

 

This is a minor annoyance, but it IS STILL an annoyance. How do I fix it? (Using InDesign 17 and Windows 10 Enterprise.)

 

Thx in advance. 🙂

TOPICS
Bug , Feature request , How to

Views

40

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Try setting your workspace with no documents open.

You shouldn't have to do this - so there might be something else at play.

 

---

Your workspaces should be stored here

 

On a Mac, start at your Home folder, and go to:
[Home] > Library > Preferences > Adobe InDesign > version > language > InDesign Defaults

 

Windows:
C:\Documents and Settings\<USER>\Application Data\Adobe\InDesign\version\language\InDesign Defaults

 

So you can backup your workspaces - save them somwhere else

 

---

Try resetting your preferences:
The easiest way to reset everything is to delete the InDesign preferences: as soon as InDesign starts to boot hold down Shift, Alt, Ctrl (and Apple/Cmd if working on a Macintosh). A dialog will appear asking to delete the InDesign Preferences, select 'Yes' on this dialog.
Further info and instructions here if needed:
https://helpx.adobe.com/in/indesign/kb/indesign-preferences-support-file-locations.html

 

---

Reinstalling rarely fixes everything - you can do a complete reinstall using the
Creative Cloud Cleaner Tool https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

LATEST

Try setting your workspace with no documents open.

You shouldn't have to do this - so there might be something else at play.

 

I tried, no luck.

 

Your workspaces should be stored here ...

Windows:
C:\Documents and Settings\<USER>\Application Data\Adobe\InDesign\version\language\InDesign Defaults

 

Mine are at:

C:\Users\<USER>\AppData\Roaming\Adobe\InDesign\Version 17.0\en_US\Workspaces

Folder contains the following 6 .xml documents:

  • Advanced_CurrentWorkspace
  • Essentials Classic_CurrentWorkspace
  • Essentials_CurrentWorkspace
  • FG Custom
  • FG Custom_CurrentWorkspace
  • Start_CurrentWorkspace

 

So you can backup your workspaces - save them somwhere else

 

Moved the “Workspaces” folder to a different location, so there’s no “Workspaces” folder in “en_US”.

 

Try resetting your preferences:
The easiest way to reset everything is to delete the InDesign preferences: as soon as InDesign starts to boot hold down Shift, Alt, Ctrl ... . A dialog will appear asking to delete the InDesign Preferences, select 'Yes' on this dialog.

 

Launched InDesign while holding Shift-Ctrl-Alt; got a dialog saying:

 

InDesign.exe

Delete InDesign Preference files?

Clicked “Yes”

 

Got the InDesign “Home” window (Welcome to InDesign … Get started … “ etc.)

 

Couldn’t open the document from within the app, as it is located on a different server, and when I try to navigate there, I get a dialog saying:

 

Location is not available

[server name] is not available. If the location is on this PC, make sure the device or drive is connected or the disc inserted, and then try again. If the location is on a network, make sure you’re connected to the network or Internet [it is], then try again [I did, no luck]. If the location still can’t be found, it might have been moved or deleted.

 

Clicked “OK”

 

Went to a different window (already open) with the document showing, and double-clicked it; nothing happened.

 

Quit InDesign.

 

There is a new Workspaces folder at

C:\Users\Golubsfa\AppData\Roaming\Adobe\InDesign\Version 17.0\en_US\Workspaces

 

… with 1 file inside:

  • Start_CurrentWorkspace.xml

 

Double click the document; it opens. The menu "Window > Workspace" lists ID's 9 default workspaces [in square brackets].

 

Open “Essentials Classic” workspace, followed by “Essentials”. Make a change in the document, save and close.

 

Now there are 3 .xml files in “Workspaces”:

  • Essentials Classic_CurrentWorkspace.xml
  • Essentials_CurrentWorkspace.xml
  • Start_CurrentWorkspace.xml

 

Open the document again, and no workspace is showing.

 

Q: Should I do the complete reinstall?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines