Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Losing italics sucks!

Explorer ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

When I place formated text from Open Office or Scrivener, InDesign removes italics. I've tried style mapping and some other techniques I've found on this forum. They have not worked for me.

 

As a workaround, what I have to do is underline the italic text before exporting (ID doesn’t lose underline), then find and change the style in ID after I place it. I do long documents, so this is not the most productive way to work. Why is this so difficult for ID to do? I hope someday it can be fixed. I use 15.1.3 (far as I can go on this Mac).

 

Any ideas on how to make this correctly?

 
Thank you
TOPICS
Import and export

Views

220

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 14, 2021 Nov 14, 2021
After reading some more posts and articles on this, I finally remebered how I got this to work before. Forgive me if someone suggested this and I didn't act on it. I tried it before I made my first post but it didn't work. This time, however, I must have done it right. In Open Office, create a character style for italics and apply it to all italic text. Give it a name like "italics1"Create a character style in ID with the same exact name. When you place the file, make sure "Use InDesign Style De...

Likes

Translate

Translate
Adobe Community Professional ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

I don't know about Scrivener, but InDesign can import Word files and keep local overrides for character styles. There's an excellent online video tutorial on Word and InDesign integration on LinkedIn Learning by Anne-Marie Concepción, you can get 30-days free access.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Thanks for this. I will definately look into it. I'm not keen on signing up for LinkedIn. It took me forever to get them from stop sending me spam. I don't want to open that can of spam again. Maybe I can find it somewhere else.

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

What makes you think that it's an InDesign issue? Have you reached out to Open Office or Scrivener?

Text styles being removed is not normal. 

 

There's a post here - and apparently it's a known issue

https://www.kdpcommunity.com/s/question/0D5f400001Mu2M1/where-did-the-italics-go?language=en_US

 

I suggest you don't use Open Office or Scrivener - but use something else that doesn't do this.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Everyting works fine between Open Office and Scriviner when it comes to italics, so I was thinking the problenm is with ID. But maybe not. I have asked for help on other forums as well. This problem has been going on for some time. I can't just switch writing apps. My wife is the main writer. She's blind and uses Scriviener becuse it's easier for her to organize her books with it. It's a great app.

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Well - that makes sense.

The problem seems to be way Scrivener applies the Italics - it doesn't seem to use italics the same way as other apps. 

 

So it uses say Times New Roman and uses an internal font structure called TNRI (Times New Roman Italics) - which can't be read be external programs - including MS Word.

 

The solution - from what I've read - is to apply a character that isn't normally used in seting the text something like a ¬ to show where the italics is

 

So it would read something like ¬it was the best of times¬

And you can then find that text in InDesign and apply the italics - then remove the character.

 

I know it's not ideal - but seems to be what others are doing.

 

The other option of course is to make it Underline as you were doing - and find replace the underline to italics - which is most sensible approach I feel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

I've been doing something similar. I undrlive the text that's uspposed to be italic and then do a find change in ID after placing the text.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 13, 2021 Nov 13, 2021

Copy link to clipboard

Copied

When you Place the file ensure that Show Import Options is turned on.

 

capture-01.jpg

 

 

In the dialog box ensure that Preserve Local Overrides is turned on.

 

capture-02.jpg

Using this method I was able to preserve italics on imported text.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

I appreciate you going the trouble of putting that together. I've done all that stuff like a thousand times. It doesn't make a bit of differnce here.

 

Indesign imports other font styles but won't import italics for me. I know there is a way to fix this, becasue I did it like 5 books ago. But I forgot how I did it, and I think it was kind of a pain anyway, like replacing fonts every time I placed a file. 

 

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Have you experimented with saving your Open Office document as a Word document and Placing that into your InDesign document using the Microsoft Word Import facility, as described earlier in this thread?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Yes. I do save them as Word documents. I've tried from both Scriviner and Open Office.

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Thank you. No worries.
This is a wild stab in the dark but could changing the font in your source document help?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Yes, I've tried that, too. I ran out of ideas a long time ago, so I appreciate any and all.  I'm at a loss. Underlining  the text that needs italics and doing a find/replace in ID once it's placed is the easiest and fastest workaround so far. 

 

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Cheers. And you're sure the default font you are using in InDesign supports italics?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Yes, most definitely. I usally use Adobe fonts. My favorite is Garamond. But I've tried many differnt fonts. It hasn't solved the problem. And I just tried again to make sure. Nope. Boo!  

 
Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Best of luck mate. Hopefully someone else will come up with the solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Note – Direct formatting in Word is called Local formatting in InDesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Thanks, but I don't know what that means or how to make use of that information.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

If you follow the free for 30-days detailed Word to InDesign LinkedIn Learning course I mentioned it will explain all:

  • Differences between InDesign and Word styles
  • Identifying transferable formatting attributes
  • Controlling text formatting when cutting and pasting
  • Placing Word files in InDesign
  • Linking to Word files for automatic updating
  • Working with footnotes, hyperlinks, and tracked changes
  • Best practices for fixing text formatting
  • Extracting embedded images and converting Word art
  • Converting local formatting to character styles
  • Round-tripping to InDesign RTF to clear out file corruption
  • Syncing Google Docs with InDesign via DocsFlow
  • Converting Word docs to InCopy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Much appreciated. Thank you! I'll have to watch that with the trial. Maybe LinkedIn has settled down with its spam.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

After reading some more posts and articles on this, I finally remebered how I got this to work before. Forgive me if someone suggested this and I didn't act on it. I tried it before I made my first post but it didn't work. This time, however, I must have done it right.

 

In Open Office, create a character style for italics and apply it to all italic text. Give it a name like "italics1"

Create a character style in ID with the same exact name. When you place the file, make sure "Use InDesign Style Definition” is selected for Style Conflicts in the import window.

 

I tried this using Scrivener’s Presets (styles), also, but couldn't get it to work, so I have to export from there and prepare the file in Open Office first. I’m okay with that. 
 
Thanks for helping!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Hi wurliuchi,

one thing you can also try. Copy and paste.

With the help of a script written by Marc Autret:

 

RichPaste | Copy and Paste with Minimal Formatting [UPDATE]
Marc Autret, April 06, 2016

When it comes to pasting text from another document or application, InDesign provides two options, either keeping the original text attributes, fonts, styles (the full 'Paste' feature), or removing all attributes ('Paste without formatting'.) We also have tools and preferences in the field of style mapping, but on many occasions these features do not fit the need of dealing quickly with basic formatting problems. Here RichPaste comes to the rescue…

 

https://www.indiscripts.com/post/2015/10/richpaste-copy-and-paste-with-minimal-formatting

 

Regards,
Uwe Laubender

( ACP )

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Thank you for this. I think I'm going to have to do a complete clean install of InDesign, because this script doesn't even work for me. I mean, it works as far as pasting goes, but the italcis are still lost. So frustrating!

 

Thanks for the help. I was excitied to get this script. I'm sure it will come in useful when I get this problem cleared up. Urgh!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Hi wurliuchi,

that Marc's script is not working does not mean you have a faulty installation of InDesign!

Could well be, that the italic formatting is not transported to the clipboard the way the script code is expecting this.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

LATEST

Thanks. Yeah, I read that in the release notes. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines