• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Missing font modal or alert not appearing when opening files with missing fonts

New Here ,
Jan 09, 2023 Jan 09, 2023

Copy link to clipboard

Copied

I then can't do anything in Indesign and get a "Cannot handle the request because a modal dialog or alert is active." message.

 

I have lots of files that used Type 1 fonts and need to update to Opentype versions of the fonts. I have removed the old font files to make this easier to track but now whenever I open an indesign file with the old fonts, i do not get the missing fonts warning but the software acts as if the warning there. 

 

I have tried finding if the warning was hidden behind another window but it isn't. It popped up correctly once but has not appeared since. I usually have to Force Quit indesign once this happens and that doesn't actually fix anything. I have also restarted my machine and reinstalled Indesign 18.1. Files that I have already updated the fonts in open fine but as soon as I open a file with the old missing fonts it locks up.

 

Mac OS Ventura 13.0.1

TOPICS
Bug

Views

93

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Contributor , Jan 09, 2023 Jan 09, 2023

When you reinstalled, did you use the "cleaner" app to remove all vestiges? Have you deleted preferences?

Likes

Translate

Translate
Contributor ,
Jan 09, 2023 Jan 09, 2023

Copy link to clipboard

Copied

When you reinstalled, did you use the "cleaner" app to remove all vestiges? Have you deleted preferences?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2023 Jan 10, 2023

Copy link to clipboard

Copied

LATEST

I did not delete preferences the first time I uninstalled but that seems to have fixed it now.

 

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines