• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Missing required parameter from for method open

Community Beginner ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

Hi,

 

Have upgraded my machine to MacOS BigSur and updated to InDesign 2021 and whenever I attempt to open an .indd or .idml from the desktop, InDesign pops up this dialog box. 

 

I see I'm not alone with this issue as I see a couple of other threads that mention the same issue.  Is it an issue with InDesign or Big Sur? 

Untitled-1 copy.jpg  

TOPICS
Bug

Views

2.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Guide , Sep 27, 2021 Sep 27, 2021

On the Mac, the Open gesture (double-click a file etc.) translates to an open "AppleEvent" - the basic operation also used by an AppleScript.

 

This could be an issue with security :clown_face: in Cupertino overdoing it recently.

 

Have a look at System Preferences >> Security & Privacy >> Files and Folders, if there are any restrictions on InDesign. While I have no particular InDesign entry there, I have InDesign listed in the "Full Disk Access" next door.

Votes

Translate

Translate
Community Expert ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

I personally don't use BigSur so far but have not seen this issue reported by the people I know use InDesign and BigSur. Can you provide the following information

  • Does the file path have any special characters?
  • What happens if you create a file, save it and then try to open it, does it still fail to open?
  • Does it happen only to files saved on the Desktop?
  • Do you have any third party plugin or script installed on your InDesign? If yes try by removing those

-Manan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 26, 2021 Sep 26, 2021

Copy link to clipboard

Copied

Hi Manan,

 

  1. No special characters in the file path
  2. Yes, it still fails to open if I open them from Finder or the Desktop
  3. All files regardless of location
  4. No extra scripts or plugins

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

What code do you use to open a file?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 26, 2021 Sep 26, 2021

Copy link to clipboard

Copied

Hi Peter,

 

I'm not sure what you mean by code?  All I'm doing is double clicking or dragging the file onto the dock icon

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 26, 2021 Sep 26, 2021

Copy link to clipboard

Copied

Sorry, I thought you were trying to open a file using a script. I was wrongfooted by the title of the topic. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

On the Mac, the Open gesture (double-click a file etc.) translates to an open "AppleEvent" - the basic operation also used by an AppleScript.

 

This could be an issue with security :clown_face: in Cupertino overdoing it recently.

 

Have a look at System Preferences >> Security & Privacy >> Files and Folders, if there are any restrictions on InDesign. While I have no particular InDesign entry there, I have InDesign listed in the "Full Disk Access" next door.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

THANK YOU, Dirk.  That was indeed the problem.  InDesign wasn't allowed to access our network volumes.  All sorted now

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 31, 2023 Oct 31, 2023

Copy link to clipboard

Copied

Hello! thank you for your answer. I have been having a similar issue and checked my System Preferences, as insturcted to resolve the issue. However, for me all the boxes are checked. I unchecked them, then checked them again and restarted InDesign but no luck. 

The only way I can open files right now is directly from the File>Open tab on InDesign. If I choose to use the finder and double click the message pops up. This is for all files, I thought it might be the name or special characters but I tested different files and it persisted. Any additional suggestions are appreciated!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

Hi @Gus30945240wwxh,

 

Sorry to hear about the trouble. Please ensure InDesign has full disc access. To do that, you can go to System Settings > Privacy & Security > Full Disc Access and ensure InDesign is listed there. Also, you can check if your files have any symbols, like #, and try opening the file again.

 

Thanks

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2024 Mar 05, 2024

Copy link to clipboard

Copied

I'm having this trouble and neither solutions work

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 05, 2024 Mar 05, 2024

Copy link to clipboard

Copied

Hi Matildedigmann,

Sorry for the trouble, and thanks for trying the suggestions. Would you mind checking if the files you're trying to open have # symbol in their name? If so, please try removing the # symbol from your file name and let us know if you're able to open the files.

 

We will try our best to help you.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

Hi 🙂

I don’t have the # symbol in my filenames 🙂

Thanks for the help!
____________________________

Matilde Digmann
Artist & Author

Profile matildedigmann.dk
Showroom Møllegade 8b
SR Hours Saturdays 12-15
Shop matildedigmann.shop


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

LATEST

Hi @Matildedigmann

Thanks for sharing the info. Is this happening with a specific file or all files? Is it possible for you to share the file with me over a private message so that I can check on my end?

 

We will try our best to help.

 

Thanks,

Harshika

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines