• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Moved to Mac Studio (M1) with same setup but script doesn't communicate with ID

Participant ,
Apr 06, 2022 Apr 06, 2022

Copy link to clipboard

Copied

Hey all,

 

I'm using VS Code to script ID (17.2) it worked fine. I've now moved to the new Mac Studio, transferred all settings over and have bascially the same setup, but when I run a simple script, it doesn't do anything. I don't even get an error message, nothing happens.

Is there a specific setting (maybe in the launch.json) that need to be changed when using the M1 chip?

On both machines, I have the ExtendScript Debugger v1.1.2 and the Adobe ExtendScript Language by Ole Henrik Stabell installed. Again, it all worked fine on my old iMac.

 

Thanks!

Frank

 

PS: I'm still getting the error message "The ExtendScript Language Server server crashed 5 times in the last 3 minutes. The server will not be restarted." all the time, but I got this on my iMac as well, so that can't be the problem.

TOPICS
Scripting

Views

763

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Apr 06, 2022 Apr 06, 2022

Thanks for the reply, but this only brings the error "command 'extension.extendscript-debug.selectActiveTarget' not found". Meanwhile, I have foud another post about this issue and it looks like the Silicon version of VS Code doesn't work with ExtendScript… too bad. I have downloaded and opened VS Code for Intel and it immediately worked fine. Really sad the Silicon chip isn't supported.

Votes

Translate

Translate
Participant ,
Apr 06, 2022 Apr 06, 2022

Copy link to clipboard

Copied

I think the problem is that I haven't selected and can't "Select the target application" at the bottom of my VS Code window. How can I make that option appear?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 06, 2022 Apr 06, 2022

Copy link to clipboard

Copied

quote

I think the problem is that I haven't selected and can't "Select the target application" at the bottom of my VS Code window. How can I make that option appear?


By @AnotherFrank

CMD+Shift+A then set the target app. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 06, 2022 Apr 06, 2022

Copy link to clipboard

Copied

Thanks for the reply, but this only brings the error "command 'extension.extendscript-debug.selectActiveTarget' not found". Meanwhile, I have foud another post about this issue and it looks like the Silicon version of VS Code doesn't work with ExtendScript… too bad. I have downloaded and opened VS Code for Intel and it immediately worked fine. Really sad the Silicon chip isn't supported.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

How did you install the Adobe Apps? With Adobe's installer or via backup or other transfer from zhe old computer?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

I have used the Creative Cloud app to install ID fresh.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Hi @AnotherFrank , just to clarify, did you install Visual Stuio Code Universal version?

 

https://code.visualstudio.com/

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Hey @rob day, at first I installed the Apple Silicon version, and after it didn't work (no Target Application option) I installed the Intel Chip version (which works but isn't optimised for the Silicon chip). So, to answer your question, no, I haven't used the Universal version yet. Would the Universal version perform better than the Intel Chip version?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Don’t know, but my brief search tells me you need the Universal version

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

You might also check if the ExtendScript plugin has an update— do a clean install of both and create a new .json file for your workspace folder.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Erin, who is working on the ExtendScript 2.0 plugin said that even her new version requires Rosetta, so I don't think we'll see an ExtendScript plugin dedicated to Apple Silicon for quite some time. Hope I'm wrong.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 02, 2022 Jun 02, 2022

Copy link to clipboard

Copied

@AnotherFrank , did you speak with Erin directly or via forum thread? I have the same issue using "Universal VSCode" on M1 Mac Studio. I would like to see a direct answer from @erinferinferinf about this issue.

Edit: Installing the "Intel" version of VSCode worked.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 02, 2022 Jun 02, 2022

Copy link to clipboard

Copied

You can now launch VSCode in Rosetta Mode via the Get Info window on macOS. (We had to raise a bug with Microsoft to enable that, and they fixed it.)

 

We would like to get an M1 version going, but it's going to require more work... there's some internal library that needs to be upgraded or swapped out, as is my understanding. @sberic is the developer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 13, 2023 Nov 13, 2023

Copy link to clipboard

Copied

LATEST

This is sad indeed! I just invested in a Mac Studio with M2 "Ultra," specifically to speed up my work with Extend Script (I have written and maintain thousands of lines of the stuff, to use with InDesign).  The Intel version of VSCode runs slower in Rosetta Mode on the Mac Studio than on my Intel-based MacBookPro from 2019.  In one benchmark of a large, compute-intensive script, the MBP beat the Mac Studio's time 1:14 to 1:22.

Since I see no movement on this issue from Adobe -- since June, 2022 -- I'll probably return the system to Apple.

Hey Adobe, can I help you fix this?  I've got 30 years of dev experience!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines