• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

Multi-State Gallery Not Showing State 1 on Page Load

New Here ,
Mar 28, 2024 Mar 28, 2024

Copy link to clipboard

Copied

I have a 3 state multi-state object serving as an "image" gallery. Each state has a group of objects (text, images, etc) that have been animated. Left/Right buttons control the interactivity.

However, after adding animation to the first state (after no problems with the other two states), suddenly first state isn't visbile on loading the page. 

When testing it in the EPUB and I go to State-2 using the buttons and then return to State-1 the group loads and animates as planned.

Why won't the animation show when State-1 first loads?

TOPICS
Bug , EPUB , Performance , Publish online

Views

76

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 29, 2024 Mar 29, 2024

Copy link to clipboard

Copied

Are you working with a fixed-layout EPUB?

Mike Witherell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 30, 2024 Mar 30, 2024

Copy link to clipboard

Copied

Do you have the animation set to on state load or on page load?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 05, 2024 Apr 05, 2024

Copy link to clipboard

Copied

I tried both ways.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 05, 2024 Apr 05, 2024

Copy link to clipboard

Copied

LATEST

Two points:

1. If you need help, you're going to need to pop in here more than once a week.

2. Try setting the MSO itself to animate in on page load. If you that doesn't do it we need to see the file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines