Native American symbols displaying as squares

New Here ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

I attached 2 screenshots to help illustrate that the Native American symbols are not displaying correctly in InDesign (displayed as rectangles with X's), but when using the font on our website, it is able to display the symbols. 

 

In some Google searches, I changed the paragraph setting to 'Adobe World-Ready Paragraph Composer' but that did nothing.

 

How can we make our Native American symbols display properly?

TOPICS
Bug , How to , Type

Views

87

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Apr 04, 2022 Apr 04, 2022
I'd guess that you are using Avant Garde Gothic. There is a version of Avant Garde Gothic that has the"l-with-stroke", the Paneuropean version, but so far as I know it doesn't have a "modifier-letter-small-w". That glyph isn't used in Europe at all, I think. So it may be that Willi is correct (the website is substituting a different font for those glyphs that Avant Garde Gothic doesn't have) or perhaps that your browser is substituting glyphs. The l-with-stroke in your first screenshot looks not...

Likes

Translate

Translate
Adobe Community Professional ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

Your problem is that InDesign can't find the proper glyph for these symbols, so it substitutes the pink box. Did you load the correct, corresponding font?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

The World Ready Composer has nothing to do with missing glyphs. It is only if you work with a text in a pragraph which has not Left to right direction.

You need to find a font which has theese symbols. Your choosen font has not them. So you have to change the font. Webfonts are sometimes different or some website get missing glyphs from a replacement font.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

I'd guess that you are using Avant Garde Gothic. There is a version of Avant Garde Gothic that has the"l-with-stroke", the Paneuropean version, but so far as I know it doesn't have a "modifier-letter-small-w". That glyph isn't used in Europe at all, I think. So it may be that Willi is correct (the website is substituting a different font for those glyphs that Avant Garde Gothic doesn't have) or perhaps that your browser is substituting glyphs. The l-with-stroke in your first screenshot looks nothing at all like the one in Avant Garde Gothic Paneuropean; it looks like Arial Unicode MS to me, which is the font that your browser would most likely be used to subsitute the small-w modifier, assuming you're using Windows here. Pretty sure you are, because a Mac or a phone would most likely use Noto, and that modifier w looks nothing at all like the one in Noto. 

 

I've also seen rare cases (okay, one case) where the World Ready Composer was the thing that would make the modifier-small-w render correctly. The WRC actually is used in lots of left-to-right languages like Khmer and Burmese and Lao, and which in those languages actually can cause glyphs to hide, or be transformed into accents or in other ways. But you're not posting in an academic linguistics mailing list about your homemade OT font that you made with no comprehension of typography, so that's probably not the case for you. 😉 You just need to use a font that has those glyphs for rendering that Native language. Arial Unicode MS seems like the obvious choice here, but there are plenty of fonts that look much better than have good support for these languages. 

 

But I'm guessing that you'd rather match your organization's preexisting graphic identity stuff, and so want to stick with Avant Garde. If you're using paragraph styles here, it's quite easy to set up a GREP Style that will capture only the glyphs that aren't in your font, and set them in a character style with a font that does support them. If it's just a few dropped glyphs, then it might be faster to use the Find/Change dialog, or even to do it manually. 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

Thank you. Yes, I think I will just switch the character with Arial Unicode MS. I Wish InDesign was as smart as a browser to switch the special character like that!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

Indy is smart enough to auto-substitute, sometimes. It's called "missing glyph protection" and it's somewhere in your Preferences. Advanced Type, I think. I always keep it turned off b/c most of my work is with complex-script multilingual stuff and letting InDesign try to auto-substitute stuff for me is a bit of a nightmare. In your shoes it'd be awfully helpful, I bet. But it only works when you're a) typing or b) applying a font.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

LATEST

Graphic experts, which are using InDesign primarly, would never want to have a font exchanging letters automatically if the glyph is missing. That would make InDessign unusable for us. It is good as it is, when InDesign InDesign marks missing glyphs and shows the problem in the Preflight Panel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines