• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

No text breaks with hyphenations in a word

Explorer ,
Sep 18, 2023 Sep 18, 2023

Copy link to clipboard

Copied

Hi all,

If I have a word with a hyphenation (eg well-defined) is doens't break off at the hyphenation in English. It does when the text is set in Dutch. How can I fix this?

Thanks for your help!

 

 

TOPICS
How to

Views

96

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 18, 2023 Sep 18, 2023

Copy link to clipboard

Copied

Add this to the dictionary. Add a tilde ~ before the breaking point(s).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 18, 2023 Sep 18, 2023

Copy link to clipboard

Copied

I am not quite sure how I should do this? You mean for each occassion? Just adding ‘~-’ to the diciotnary doesn't work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 18, 2023 Sep 18, 2023

Copy link to clipboard

Copied

The hyphenation settings are language-specific, so if it works ini Dutch, but not English, you wouold need to edit the word in the Englich dictionary.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 18, 2023 Sep 18, 2023

Copy link to clipboard

Copied

OK, not a problem to do it individual but in the case it is with all hyphenated words.

So it won't brake off like: well-
defined

But as well-de-
fine

Isn't there a general setting for this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 18, 2023 Sep 18, 2023

Copy link to clipboard

Copied

LATEST

I've tried this in versions 8, 17 and 18, and I cannot get it to do what you want in any of them, but that doesn't mean it's impossible, necessarily. I thought I had it working using find/change to add a hair space after the hyphen but it won't repeat on a second test.

Maybe someone else has another idea...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines