• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Objects present in the InDesign article are not presented as part of the reading flow in Acrobat.

Explorer ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

Good morning,

 

This question is about an accessiblity issue ecountered when InDesign exports PDF to Acrobat.

 

In InDesign, sometimes I add a table to an article in the article panel, but when I generate the PDF and check reading order in Acrobat, that particular table is not part of the reading flow. It looks as it's not added to the article in the article panel back in InDesign. If I try to add it to the article in InDesign, I get the following error: "The selected object(s) are already present in the article".

 

Any ideas how to fix is is greatly appreciated.

 

Kind regards,

Kasra

 

 

TOPICS
Bug , Import and export

Views

1.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jun 04, 2020 Jun 04, 2020

Thanks to everyone for their advice. I've found the solution to this by accident. Apparantly this happens when a paragraph style other than the defualt [basic paragraph] is applied to the table object.

 

So I selected my table object, applied the  [basic paragraph] paragraph style to it, and now after export to PDF, the table object is part of the reading flow.

 

Maybe somewhere in paragraph style settings, there's a setting that prevent the object from being in the reading flow. I don't know what i

...

Likes

Translate

Translate
Community Expert ,
May 26, 2020 May 26, 2020

Copy link to clipboard

Copied

Hi

Is this a question on Accessibility and Section 508?

~ Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 04, 2020 Jun 04, 2020

Copy link to clipboard

Copied

Hi Jane,

 

Sorry for belated reply. Yes it is about accessiblity.

 

Kind regards,

Kasra

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2020 May 26, 2020

Copy link to clipboard

Copied

If the table is not in a seperate, own text frame but part of the text (Tables are anchored items) or if indeed in a seperate Text Frane but that seperate frame is an anchored object, it is part of the textflow. If so and you already dragged a Text Frame in the Articles panel with that anchored Table, you will see this message.

But be aware: the Article panel sets the tag order, NOT the reading order! The latter is determined by the Layers order, bottom to top!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 04, 2020 Jun 04, 2020

Copy link to clipboard

Copied

Thanks for the advice and sorry for belated reply. For some reason I havn't received any response notifications.

While all your advice is correct they will not solve this particular problem.Today I found out why it's happening by accident. I'll try to post it on top of the thread.

 

Kind regards,

Kasra

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 04, 2020 Jun 04, 2020

Copy link to clipboard

Copied

Please do 😉

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 04, 2020 Jun 04, 2020

Copy link to clipboard

Copied

Thanks to everyone for their advice. I've found the solution to this by accident. Apparantly this happens when a paragraph style other than the defualt [basic paragraph] is applied to the table object.

 

So I selected my table object, applied the  [basic paragraph] paragraph style to it, and now after export to PDF, the table object is part of the reading flow.

 

Maybe somewhere in paragraph style settings, there's a setting that prevent the object from being in the reading flow. I don't know what it can be. But at least it's fixed now.

 

Kind regards,

Kasra

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2022 Dec 20, 2022

Copy link to clipboard

Copied

LATEST

In which section of the settings do I need to make changes?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines