Only half of my Indesign index is being generated

Community Beginner ,
Dec 25, 2021 Dec 25, 2021

Copy link to clipboard

Copied

I am preparing quite a detailed index of a book made up of 20 linked files – about 786 pages, in the latest version of Adobe Indesign CC 17.0.1 – on a late 2015 iMac, OS 12.1, Monterey, with 32 GB RAM and with 390 GB available on the hard disk.

When I try to regenerate my index, only half of the index appears to load (half way through the ‘J’ entries).

Is this because the entries are ‘there’, but are not visible, or is it because 32 GB RAM is not enough, or is this because of something else?

If anyone can enlighten me, I will be most grateful. Thank you.

TOPICS
Print , Publish online , Type

Views

108

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Dec 27, 2021 Dec 27, 2021

Hi @hajjahmad:

 

That sounds like a good course of action. We will be here if you need help along the way. 

 

~Barb

Likes

Translate

Translate
Adobe Community Professional ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

32 Gb RAM is certainly more than enough. When you say 'Is this because the entries are ‘there’, but are not visible', what exactly do you mean by 'there but not visible'?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

Hi Peter, please see my reply to Barb Binder’s suggestion.

If you have a next step suggestion, it would be most welcome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

Hi @hajjahmad:

 

Is the text overset, or just not there at all? Try clicking in the index and choose Edit > Edit in Story Editor. Scroll down to the bottom. Is the last entry a J entry, or is the rest of the index visible in that view?

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

Hi Barb – thank you for this suggestion – in Story Editor, the whole Index is visible from A to Z – but as I scroll down, Indesign quits unexpectedly after a few seconds (when I report this to Adobe, they say they do not have a fix).

If you have a next step suggestion, it would be most welcome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

Hi @hajjahmad:

 

I feel cautiously optimistic since the entire index has in fact been generated. Are you willing to share the file with the index? I'd be happy to take a look. You can put it on dropbox and post a link here (public) or click my name above and message me the link directly (private).

 

If you can't share it, I would suggest taking a look at the formatting to see if something is not allowing the text to show up on the last pages. Perhaps no break has been applied inappropriately? Perhaps keep settings are enabled that shouldn't be? Perhaps there is a break character that needs to be removed? 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2021 Dec 27, 2021

Copy link to clipboard

Copied

Hi Barb – thank you for helpful offer and suggestions.

 

I have been using this situation as an opportunity to learn a lot more about how Adobe Indesign works and so far I have stabilised the Index file, so that I can view it in Story Editor without it crashing. I have also re-defined and fine-tuned the original default nested index styles. There does not appear to be any break where the OV overset section suddenly begins in Story Editor. I have tried the select all and then select No Break – and again – so it’s not that. I have selected Show Hidden Characters and no break characters show up where the Index entries cease to be visible. I will check to see if Keep Settings have been enabled inappropriately in due course.

 

I think part of the problem lies in the fact that the book and index started out about five years ago in CS3 and I’ve now transferred all the files into CC 17.01 – which is quite a quantum leap! So it may be that I’ll have to re-do the page references entered in CS3, some of which need editing anyway – and added to which, I did not know when I first started out, that all the files in the Book have to be open in order to index references throughout the Book (i.e. Add All) – so many of my early index entries are incomplete.  Added to which, I still have two thirds of the book to go through.

 

Bearing this in mind, creating the index is still very much a work in progress, so I think it is probably a little premature to let you have a look at the Index file – and hopefully in the process of my continuing the indexing as well as re-doing my early page references, the problem(s) will be resolved.

 

Thank you for helping my learning curve on its way – and if there are any more issues – of which I may be blissfully unaware – which I should be aware of or look out for, I would be very grateful if you would kindly enlighten me.

 

Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 27, 2021 Dec 27, 2021

Copy link to clipboard

Copied

LATEST

Hi @hajjahmad:

 

That sounds like a good course of action. We will be here if you need help along the way. 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines